Jump to content

Downloading subtitles using EmbyCon in Kodi


Skyecairns
 Share

Recommended Posts

Skyecairns

A Windows 10 PC  is where my Emby server is located.  If I open up Kodi  on my PC and use the EmbyCon add in I used to be able to download subtitles  but since I changed the path to UNC e.g. \\ACER10\e$\Kodi\Movies from E:\Kodi\Movies the subtitles no longer download but do appear on the screen.  I changed the path as on some rare occasions my movies would momentarily stop once I changed the path to UNC the streaming is smooth and fine.  Do I need to do something to get the subtitles to work?  Thanks

 

Link to comment
Share on other sites

TeamB

How are you downloading subtitles?

You should use the Emby server subtitle plugin to download and manage your subtitles on the server so they are available for all clients.

 

Link to comment
Share on other sites

Skyecairns

How are you downloading subtitles?

While playing a movie in Kodi using the EmbyCon addin I select download-download subtitle.  In the past the downloaded subtitle would end up in the same directory as the movie.  This is done on the same computer as the server.  The downloaded sub titles are available on all my devices.  The downloading doesn't seem to work since I've changed the folders path from C:\movies to \\server\movies. Any thoughts?

 

Thanks

 

Download-Download Subtitles.png

Link to comment
Share on other sites

TeamB

The kodi subtitle downloader might not like the unc path, might think it is not local or it can not write the path.

If the subtitles appear then they must be downloaded somewhere, perhaps the kodi subtitle downloader when it sees the unc path decides to use a local temp folder or something like that.

Link to comment
Share on other sites

Skyecairns

Ok. Thanks.

Link to comment
Share on other sites

  • 2 weeks later...
Wheemer

If you give kodi the permissions to access the path it should work. I have done this before. Add the path in kodi as a source with the correct username and password.

Link to comment
Share on other sites

Skyecairns

How and where in Kodi do I do this?  I would need to add more than one path.  Is it still possible?

Link to comment
Share on other sites

Skyecairns

I tried Files-Add Videos and Kodi doesn't like my UNC path. 😞

Is there somewhere else I'm suppose to go?

 

Thanks

Link to comment
Share on other sites

Wheemer

In file manager > add source > add network location

Link to comment
Share on other sites

Skyecairns

I've tried without success. Here's my error dialog box.  Doesn't like my UNC drive. I do have a workaround so no big deal.

error.jpg

Link to comment
Share on other sites

Wheemer

Try editing your mediasources.xml to look like this:

<mediasources>
    <network>
        <location id="1">smb://username:password@servername/</location>
    </network>
</mediasources>
 

You can also edit the library location in Emby and add the username:password to the location similar to above. I have used either with success in the past.

Link to comment
Share on other sites

Skyecairns

Mediasources.xml  already update.  Rebooted Kodi just in case.  Still the subs don't download.  Tried to amend Emby's source to smb:// etc.  Doesn't like the path.  Nevermind I'll just revert to my backup which is to have C:\download as my source.  Add the subtitles after the download and then moving movies plus subs to my library.

Thanks for your help.

Link to comment
Share on other sites

Wheemer

I'm using emby server on windows so maybe that's the difference.

Link to comment
Share on other sites

Skyecairns

My server is also on windows.  I'm trying to do the downloading on the same PC as the server.  The subtitles appear on the screen but not downloaded .  This all was do to changing my path to UNC format.  THe UNC format solves the problem I had on rare occasions where the film would stop momentariy .  Oh weill thanks again.

Link to comment
Share on other sites

Wheemer

You might try leaving local paths and ensuring allow direct file playback is selected within embycon settings.

Link to comment
Share on other sites

Skyecairns

Yeah I've always allowed Direct Playback.  But occasionally play high Def 1080 some movies would momentarily stop changing the path to UNC solved my problem.  Someone on the forum had a similar problem and changed his path to UNC to solve his problem.  

Link to comment
Share on other sites

Wheemer

The easiest solution is to just setup emby's subtitle plugins as mentioned before. Then you won't have to manually download them and you can keep unc paths.

Also just thought about your smb:// prefix... I don't have that in my paths within emby settings. I just have //server/path

Might try removing the smb: part.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...