Jump to content

TrueNAS: emby jail web interface not working after upgrade


Recommended Posts

Nick2020

About 3 weeks ago I let TrueNAS and emby jail install updates. Afterwards I realised that the emby web interface (http://192.168.1.105:8096) was not working: I get a can't connect to the server error on the browser.

I can connect to the TrueNAS web interface and see that the emby jail is up and running. 

I poked around trying to find the emby logs and found one called message that records the upgrade (i.e. a long list of emby packages deinstalled and installed) but nothing indicating a problem.

This is the configuration:

emby version: 4.5.4.0_1.

release: 12.1-RELEASE-p13

TrueNAS: TrueNAS-12.0-U3.

Any ideas about how to fix this (and what screwed it up) would be appreciated.

Link to post
Share on other sites
MRobi
19 hours ago, Nick2020 said:

About 3 weeks ago I let TrueNAS and emby jail install updates. Afterwards I realised that the emby web interface (http://192.168.1.105:8096) was not working: I get a can't connect to the server error on the browser.

I can connect to the TrueNAS web interface and see that the emby jail is up and running. 

I poked around trying to find the emby logs and found one called message that records the upgrade (i.e. a long list of emby packages deinstalled and installed) but nothing indicating a problem.

This is the configuration:

emby version: 4.5.4.0_1.

release: 12.1-RELEASE-p13

TrueNAS: TrueNAS-12.0-U3.

Any ideas about how to fix this (and what screwed it up) would be appreciated.

Prior to the upgrade, what release version was your jail running? It's possible you went from being based on FreeBSD11 to FreeBSD12 which requires a different version of emby

Link to post
Share on other sites
Nick2020
Posted (edited)
On 02/05/2021 at 14:49, MRobi said:

Prior to the upgrade, what release version was your jail running? It's possible you went from being based on FreeBSD11 to FreeBSD12 which requires a different version of emby

Thanks for responding.

The working configuration (which was the first one I installed) was 

TrueNAS: 12.0-U1  (according to the TrueNAS Boot Environments screen)

Emby-server: 4.5.3.0  (according to the emby messages log)

TrueNAS 12.0-U2.1 was installed on the same day as the emby update and resulted in the first configuration that did not work. 2 weeks later TrueNAS was updated to TrueNAS-12.0-U3.

ps. I realise I may not have understood your question correctly. I will see if I can find the release of the jail explicitly.

Edited by Nick2020
afterthought!
Link to post
Share on other sites
Nick2020

According to the messages log on the NAS it was running FreeBSD 12.2-RELEASE-p2 initially when working and was p3 and then p6 in the non-working state.

I can't see / don't know where to look for the jail release version. Could that be different from the FreeBSD release?

Link to post
Share on other sites
MRobi
7 hours ago, Nick2020 said:

ps. I realise I may not have understood your question correctly. I will see if I can find the release of the jail explicitly.

It can be a little complicated.

You can be on TrueNAS 12 while your jail is still running on 11.X. This is the automatic behavior when you update from FreeNAS 11.X to TrueNAS 12.X, your jails don't upgrade with it.

I ask this question because in your initial post you said you updated the emby jail. So depending on what/how you did here, you may have taken your jail version from 11.X to 12. If this is the case you'd have to reinstall the emby package to one based on 12.X.

To check your jail version, in the GUI you should just have to go to the jails section and there's a spot there that says "release"

Link to post
Share on other sites
Nick2020

Thanks again for your help and patience!

I did a clean instal of TrueNAS 12.0 RELEASE and never had FreeNAS installed.

Currently the jail release is 12.1-RELEASE-p13 but I do not know where to find the original release in my log files. 

Link to post
Share on other sites
MRobi
Posted (edited)
9 hours ago, Nick2020 said:

Thanks again for your help and patience!

I did a clean instal of TrueNAS 12.0 RELEASE and never had FreeNAS installed.

Currently the jail release is 12.1-RELEASE-p13 but I do not know where to find the original release in my log files. 

If it was a clean install of TrueNAS 12 unless you specifically told it to install a different jail version, your jail should be based on 12 as well.

How did you install Emby?

And are you able to access the emby logs?

Edited by MRobi
Link to post
Share on other sites

I'm still struggling with this.

From the TrueNAS shell I can ping the jail IP 172.16.0.2. However, I get connection refused if I try to connect with nc at all ports between 1 and 10,000 (nc -v 172.16.0.2 1-10000).

But I don't know if that result is significant or not.

FYI the config.json for the emby_jail is as follows:

Quote

root@truenas[/mnt/pool3TB/iocage/jails/emby_jail]# more config.json
{
    "basejail": 1,
    "boot": 1,
    "defaultrouter": "172.16.0.1",
    "host_hostname": "emby-jail",
    "host_hostuuid": "emby_jail",
    "ip4_addr": "vnet0|172.16.0.2/30",
    "jail_zfs_dataset": "iocage/jails/emby_jail/data",
    "last_started": "2021-05-08 17:21:16",
    "nat": 1,
    "nat_forwards": "tcp(8096:8096)",
    "plugin_name": "emby",
    "plugin_repository": "https://github.com/ix-plugin-hub/iocage-plugin-index.git",
    "release": "12.1-RELEASE-p13",
    "type": "pluginv2",
    "vnet": 1,
    "vnet0_mac": "96de80ad6742 96de80ad6743"
}

On the emby plugin screen on TrueNAS it say the admin portal is http://192.168.1.105:8096 and the ipv4 address as 172.16.0.2/30.

Any clues about would be welcome... 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...