Jump to content

emby server 4.5.4.0 on debian network configuration changes were not applied


Go to solution Solved by whytea,

Recommended Posts

whytea

Hi

I have the problem that any changes I made on https://<name>:8920/network won't be saved.
For example if I change Internet streaming bitrate limit (Mbps) from 4 to 5 save the page and reload it the value is 4 again.

If I made the change directly in /var/lib/emby-server/config/system.xml and restart the server the changes were applied.
The authorization is correct from my point of view.

148982 -rw-r--r-- 1 emby emby 3,0K Apr 22 12:11 /var/lib/emby-server/config/system.xml

I hope anyone has an idea.

edit: added logfile; The last action before saving the logfile was trying to change the bandwidth limit from "not set" to "5".

 

Thx

Daniel

embyserver.txt

Edited by whytea
Link to post
Share on other sites
Luke

Hi, can you capture the contents of the browser debug console? Thanks.

Link to post
Share on other sites
whytea
Posted (edited)

Hi. I tried Firefox and Edge.

I hope this is what you need from Firefox.

09:18:32.320 XHRGEThttps://whytea.ipfire-zuhause.de:8920/emby/ScheduledTasks?IsEnabled=true&X-Emby-Client=Emby%20Web&X-Emby-Device-Name=Firefox&X-Emby-Device-Id=08f54b9b-a91a-48c5-9597-dfafc67f72a7&X-Emby-Client-Version=4.5.4.0&X-Emby-Token=11a08a0bbe254a788c45ff0337752f90
[HTTP/2 200 OK 0ms]

09:18:33.603 opening web socket with url: wss://whytea.ipfire-zuhause.de:8920/embywebsocket?api_key=11a08a0bbe254a788c45ff0337752f90&deviceId=08f54b9b-a91a-48c5-9597-dfafc67f72a7 apiclient.js:1:16355
09:18:33.618 GETwss://whytea.ipfire-zuhause.de:8920/embywebsocket?api_key=11a08a0bbe254a788c45ff0337752f90&deviceId=08f54b9b-a91a-48c5-9597-dfafc67f72a7
[HTTP/1.1 404 Not Found 4ms]

09:18:33.641 Firefox kann keine Verbindung zu dem Server unter wss://whytea.ipfire-zuhause.de:8920/embywebsocket?api_key=11a08a0bbe254a788c45ff0337752f90&deviceId=08f54b9b-a91a-48c5-9597-dfafc67f72a7 aufbauen. apiclient.js:1:16434
09:18:33.642 web socket closed apiclient.js:1:16979
09:18:33.643 nulling out web socket apiclient.js:1:17044
09:18:33.685 appRouter - processing path: /web#!/network, isBack: undefined router.js:1:9612
09:18:33.685 appRouter - user is authenticated router.js:1:10187
09:18:33.686 appRouter.sendRouteToViewManager - processing path: isBack: undefined router.js:1:7510
09:18:33.689 viewManager.onBeforeChange - processing path: isBack: undefined viewmanager.js:1:1694
09:18:33.738 XHRGEThttps://whytea.ipfire-zuhause.de:8920/emby/Plugins?X-Emby-Client=Emby%20Web&X-Emby-Device-Name=Firefox&X-Emby-Device-Id=08f54b9b-a91a-48c5-9597-dfafc67f72a7&X-Emby-Client-Version=4.5.4.0&X-Emby-Token=11a08a0bbe254a788c45ff0337752f90
[HTTP/2 200 OK 0ms]

09:18:33.802 XHRGEThttps://whytea.ipfire-zuhause.de:8920/emby/System/Configuration?X-Emby-Client=Emby%20Web&X-Emby-Device-Name=Firefox&X-Emby-Device-Id=08f54b9b-a91a-48c5-9597-dfafc67f72a7&X-Emby-Client-Version=4.5.4.0&X-Emby-Token=11a08a0bbe254a788c45ff0337752f90
[HTTP/2 200 OK 0ms]

 

Edited by whytea
Link to post
Share on other sites
Luke

Please supply the complete console contents. thanks.

Link to post
Share on other sites
  • 2 weeks later...
Luke

Hi, are you still having an issue with this?

Link to post
Share on other sites
Luke

OK i'm not sure what the problem is. @cayars can jump on with you and take a look. Thanks.

Link to post
Share on other sites
cayars

@whytea Have you checked permissions to make sure emby has write/update permissions to the Emby config files?
If you make a change to a user does that stick or also have this issue of not saving?

Link to post
Share on other sites
Q-Droid

Let's see who runs the emby server process.

ls -l /var/lib/emby/logs

 

Link to post
Share on other sites
whytea

 Sorry I was a few days afk.

 

Okay maybe we found something...

My /var/lib/emby  is empty.
The emby server is in /var/lib/emby-server

root@emby:~# ls -l /var/lib/emby*
/var/lib/emby:
insgesamt 0

/var/lib/emby-server:
insgesamt 260
drwxr-xr-x 12 emby emby   4096 Mai 10 11:00 cache
drwxr-xr-x  5 emby emby   4096 Apr 22 11:15 config
drwxr-xr-x  9 emby emby   4096 Apr 22 15:53 data
drwxr-xr-x  4 emby emby   4096 Apr 10  2017 ffmpeg
drwxr-xr-x  2 emby emby   4096 Aug 25  2017 localization
drwxr-xr-x  2 emby emby   4096 Mai 10 11:00 logs
drwxr-xr-x 10 emby emby   4096 Dez 13  2019 metadata
drwxr-xr-x  3 emby emby   4096 Feb 22 13:16 plugins
drwxr-xr-x  3 emby emby   4096 Nov  8  2016 root
drwxr-xr-x  2 emby emby   4096 Mai  9  2017 ssl
drwxr-xr-x  6 emby emby   4096 Apr 10 11:04 sync
drwxr-xr-x  2 emby emby 217088 Apr 22 22:21 transcoding-temp
root@emby:~# 

 

root@emby:~# ls -l /var/lib/emby-server/logs
insgesamt 36564
-rw-r--r-- 1 emby emby 10221011 Mai  8 00:00 embyserver-63756028800.txt
-rw-r--r-- 1 emby emby 10243318 Mai  8 23:59 embyserver-63756115200.txt
-rw-r--r-- 1 emby emby  8792855 Mai  9 23:59 embyserver-63756201600.txt
-rw-r--r-- 1 emby emby  8162919 Mai 10 11:27 embyserver.txt


It runs as user emby.

root@emby:~# ps aux | grep emby
emby      9877  3.7 29.8 4677676 766312 ?      SLsl Apr22 974:40 /opt/emby-server/system/EmbyServer -programdata /var/lib/emby-server -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb
root     30700  0.0  0.0  12780   968 pts/0    S+   11:26   0:00 grep emby

 

Link to post
Share on other sites
Q-Droid

The location is less important than the runtime UID/GID which does look right. The log files are being created by the same owner of the system.xml file so this isn't a problem with access or permissions.

 

Link to post
Share on other sites
Luke

Do other server settings get saved? Many of them go into the same config file.

Link to post
Share on other sites
whytea

Yes. For example I changed the language to english and  back to german.

It works fine. The file also got a new timestamp

root@emby:~# ls -liah    /var/lib/emby-server/config/system.xml 
148982 -rw-r--r-- 1 emby emby 3,0K Mai 11 08:22 /var/lib/emby-server/config/system.xml

I also tried several changes on the https://<server>:8920/network none work. Also the system.xml don't get a new timestamp.

Link to post
Share on other sites
whytea

The "Preferred display language". On the dashboardgeneral.html page.

Maybe I'm grasping at straws but maybe there's the rub. If I changed something on https://<server>:8920/network  then two popups appears.

First popup:

Hosting Settings
Changing these values may cause instability or connectivity failures. If you experience any problems, we recommend changing them back to default.

After pushing "Got it" a second appear.

Second popup:

Hosting Settings
To enable secure connections, you will need to supply a trusted SSL certificate, such as Let's Encrypt. Please either supply a certificate or disable secure connections.

Is it possible that the changes are discarded for this reason?

 

Link to post
Share on other sites
Luke

Did you make sure to click on on it, or did you cancel it?

Link to post
Share on other sites
cayars

@whyteado you have a domain and a valid cert configured and working or were you at some point trying to set this up?

Link to post
Share on other sites
Luke
14 hours ago, whytea said:

Yes, of course I clicked on it.

Sorry I mean did you make sure to click OK on the dialog.

Link to post
Share on other sites
Luke
Quote

Is it possible that the changes are discarded for this reason?

Yes it could. You tried to require SSL, and the dialog is saying you can't proceed until you supply an SSL certificate. Does this answer your question? 

Link to post
Share on other sites
  • Solution
whytea

Ok guys! I have it! Thank you so much for your help!

Yes, I have a valid certificate and it has been working like this for years but the certificate is not on the emby server but on a reverse proxy.
The connection mode was always set to "preferred but not required". I have now changed it to "handled by reverse proxy" and everything works as expected.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...