Jump to content

Unable to do some long press related operations in the Android app


xd003
 Share

Recommended Posts

xd003

In Emby Web , when we navigate to Settings - Users :

In Desktop Mode - we can click  on the three dots at the bottom and option to Edit and Delete the user shows up

Similarly in Mobile Mode - we can long press on the user to get the Edit and Delete Option

This thing is not possible in the Android App , there are no three dots at the bottom , neither does long pressing on user does anything .

 

Secondly While on the Home page in Emby Web , beside each of the libraries in My Media Section -

In Desktop Mode - we can click  on the three dots at the bottom and various options like play , shuffle , add to playlist , edit images etc show up

Similarly in Mobile Mode - we can long press on the libraries below the My Media tab to get the very same options

This thing again is not possible in the Android App , there are no three dots at the bottom , neither does long pressing on libraries do anything

 

All this functionality missing on the Android App, those options are quite handy and must be ideally present in similar way in each client app ( android app in my instance )

Also these are just 2 places where i found this inconsistency in functionality , there might be more such cases , i hope this gets fixed

 

Emby Android App v3.1.80

Edited by xd003
Link to comment
Share on other sites

xd003
21 minutes ago, Luke said:

Hi, what device and version of android?

Xiaomi Redmi note 3 running a AOSP based rom

Android 10 

Emby Android App v3.1.80

Link to comment
Share on other sites

xd003
Posted (edited)
2 minutes ago, Luke said:

What version of Chrome do you have installed?

I currently have Brave beta v1.22.58 installed in my android device . I don't use chrome

Brave is obviously based on chromium . Here's the chrome version if it helps

Screenshot_20210314-231523.jpg

Edited by xd003
Link to comment
Share on other sites

So on a touch device you shouldn't see the 3-dot menu at all, you should use the long press context menu. If you see the 3-dot buttons in brave, that looks like a defect in brave telling us that either a mouse or pen is connected, so therefore we show it. Or if it's also showing in Chrome, then an issue in Chromium on this device.

That's really a minor point though as it won't cause any harm, although it does mean there may be other parts of the web app that start acting like a desktop UI because of this, so something to watch out for.

However, you opened this topic about the long press menu in the android app, and I'm not sure yet. It would be helpful to know if the issue occurs running stock android as well.

Link to comment
Share on other sites

xd003
Posted (edited)
6 hours ago, Luke said:

So on a touch device you shouldn't see the 3-dot menu at all, you should use the long press context menu. If you see the 3-dot buttons in brave, that looks like a defect in brave telling us that either a mouse or pen is connected, so therefore we show it. Or if it's also showing in Chrome, then an issue in Chromium on this device.

That's really a minor point though as it won't cause any harm, although it does mean there may be other parts of the web app that start acting like a desktop UI because of this, so something to watch out for.

However, you opened this topic about the long press menu in the android app, and I'm not sure yet. It would be helpful to know if the issue occurs running stock android as well.

Sorry but i think there is a little confusion , my bad if it wasnt very clear . Lemme clear it up quickly

In my Original Post  when i said desktop mode  i meant it on my laptop ( uses touchpad )

and when i said in mobile mode, that was in brave browser in my android device

i gave these two examples just to show it works flawlessly on both laptop''s web browser + android brave browser . In short , theres no touch detection issue of any sort

Just that the long press doesn't seem to do anything in the Emby Android app , i will try it out on a device running different rom and let you know if issue persists

Edited by xd003
Link to comment
Share on other sites

Ok thanks. I'm not sure what's going on yet, although i have some ideas for workarounds that we can add. Thanks.

Link to comment
Share on other sites

xd003
16 hours ago, Luke said:

Ok thanks. I'm not sure what's going on yet, although i have some ideas for workarounds that we can add. Thanks.

Firstly i tested the Long Press in my mom's device which is running miui , it worked well

Then i told my friend who used Oxygen OS to test the same thing , he too reported long press doesn't do anything for him like mine

So at this point , it seems some rom related stuff . Also i wasn't sure if this long press activity would output anything in the Android Logs but i am uploading it nevertheless just in case it helps

Android.Long-Press.NotResponding.log

Link to comment
Share on other sites

  • 3 weeks later...
xd003
Posted (edited)

@LukeJust updating the status. I tested the mentioned issue in this post in the very recently updated Android Emby beta v3.1.84 and can confirm that it still exists whereby long pressing on items such as user , library etc do simply nothing. If you need any logs with the updated Emby Android Beta version , please do let me know. Thanks

Edited by xd003
Link to comment
Share on other sites

Yea I do have a workaround but I didn't include it because I don't like the side effects it causes on devices that don't need it. So it needs a little more work still.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...