Jump to content

I updated Kodi 18.8 to Kodi19


CharleyVarrick
 Share

Go to solution Solved by quickmic,

Recommended Posts

CharleyVarrick

Once installed, it showed a prompt that a bunch of addons were incompatible and were removed, sure enough Emby and Emby for Kodi were in the list.

It displays my stuff, but nothing plays.

I like to keep my programs updated, but I guess I'll need to downgrade back to 18.8 and come back here once in a while until Emby and Kodi are friends again.

Edited by jlr19
Link to comment
Share on other sites

CharleyVarrick

Me again,

I just noticed a minor issue, not sure if it relates or not to the recent Kodi update.

1st pic= In Emby web I see all my libraries, including Home Videos & Photos.  

2nd pic= In Kodi all I see that relates to the above is Pictures, but its empty

Is this normal ?

3rd pic = In Kodi, If I go in add-ons, select Emby-next-gen, Home Videos & Photos is there and accessible, but I would prefer it shows up from main page, as movies, tv and music do.

image.thumb.png.cd303a66bd789e05a380a7acc60be4b3.png

Kodi offering Pictures but nothing to show

image.thumb.png.76dc36f4886cf126bc7e72adbdfb400d.png

 

image.thumb.png.b31c3835e074f8bbb82609bfe1f05e5f.png

Link to comment
Share on other sites

quickmic

Native pictures support in main menu for Kodi is only supported in custom Skins or via addon query. So this seems alright. Was it different in the past (with 4.x versions?).

Link to comment
Share on other sites

CharleyVarrick
On 2/22/2021 at 2:24 PM, quickmic said:

Native pictures support in main menu for Kodi is only supported in custom Skins or via addon query. So this seems alright. Was it different in the past (with 4.x versions?).

Now you make me question myself, but I really thought for sure Pictures library was offered and functional straight from Kodi homescreen in v18.

Link to comment
Share on other sites

quickmic

Yes but as I recall, it just offered you a link to the picture addons -> I guess it was emby-pictures. Not sure about that, cause I always replaced the picture selection link on home screen with a node link.

 

Link to comment
Share on other sites

markdj
On 2/21/2021 at 1:25 PM, quickmic said:

You can already use it.

 

Is the settings menu from within the add-on gone (where movies, tv-shows, manage libraries, reset database et cetera were shown) gone? Also, I tried resetting my database from within the options menu but it doesn’t do anything? I’m having some issues but nothing I can do for now.

Link to comment
Share on other sites

quickmic

Settins menu -> It's there in the options menu. You can also access it from plugin "configuration". It's exactly the same.

"resetting my database" could take quite long if you have lot's of cached artwork.

 

Link to comment
Share on other sites

markdj
On 2/24/2021 at 1:32 PM, quickmic said:

Settins menu -> It's there in the options menu. You can also access it from plugin "configuration". It's exactly the same.

"resetting my database" could take quite long if you have lot's of cached artwork.

 

I see it in the configuration menu but it doesn’t do anything.

Never mind, guess it just fixed itself. Was sort of corrupted maybe.

 

edit: for future reference: reinstalling emby next gen fixed the problem.

Edited by markdj
  • Like 1
Link to comment
Share on other sites

CharleyVarrick
Posted (edited)

I use Kodi on 2 win10 machines, last week was my workhorse pc, this morning is the htpc's turn.

Everytime I turn my back, the lengthy scan that follows database reset seem to stop and die

EDIT: HDMI CEC was monkeying around, even though its supposed to be disabled.

 

 

Just for my understanding, the tons of data that's presently added back in Kodi hopefully comes from my own server running Emby, and not from carpet bombing the data providers (?)

Edited by CharleyVarrick
Link to comment
Share on other sites

wbravin

Hel

Since i upgrated to kodi 20  i have had s9imilar issues it would not load my movies folder.

I just becane stubborn and uninstalled  and reinstalled it several time

Since i am here, In adding and deleting the emby jails on the truenas server several times when i am in kodi and reinstall emby, it presents me  the emby server login screen anhd it now shows mutiple emby server to chose from. 

is ther a way to clean and edit this screen to  show only one emby server?

 

I have truenas 12.0 U2.1

emby jail 12.2-RELEASE-p3

Hodi 20.0

enby plugin 4.1.22 by angelfire05

 

Thank you all in  advance for your help

Edited by wbravin
  • Like 1
Link to comment
Share on other sites

quickmic

I assume you mean Kodi 19? Kodi 20 is alpha

emby plugin 4.1.22 no longer works with Kodi 19. Please switch to emby-next-gen from beta repository.

Link to comment
Share on other sites

CharleyVarrick
19 hours ago, CharleyVarrick said:

Just for my understanding, the tons of data that's presently added back in Kodi hopefully comes from my own server running Emby, and not from carpet bombing the data providers (?)

Hi Emby for Kodi experts

Link to comment
Share on other sites

wbravin
46 minutes ago, quickmic said:

I assume you mean Kodi 19? Kodi 20 is alpha

emby plugin 4.1.22 no longer works with Kodi 19. Please switch to emby-next-gen from beta repository.

 

 

 

Thank you for your quick response @quickmic

Hi Sorry for the confusion Yes I meant ver 19 and it did not work hence i reverted back to 18.9 to make the plugin work. Kodi 19 and emby next gen seamed to me as half baked solutions.

I stil;l need to fix 

The  emby server login screen when  it shows mutiple choiice of emby server login options. 

is ther a way to clean and edit this screen to  show only one emby server?

 

Edited by wbravin
Link to comment
Share on other sites

quickmic

The login screen should be exactly the same as in Kodi 18 and 4.1.22 plugin.

Still not sure what's the issue. You can use manual mode, emby connect or select the server via list. Is something not working?

Edited by quickmic
Link to comment
Share on other sites

wbravin
27 minutes ago, quickmic said:

The login screen should be exactly the same as in Kodi 18 and 4.1.22 plugin.

Still not sure what's the issue. You can use manual mode, emby connect or select the server via list. Is something not working?

Hi again thank you for responding so quickly.

 

when you install the emby plugin on kodi you get a popup sccreen that request you to login to a server . On my screen i get 10 emby server choices. this is not correct obviously. If i select one of these server to connct to i get server not reachable and i need to do this for all 10 servers. The problem i see is that when i select a server and i get the ereror message, this server does not remain in its original position it shifht down the list. 

hence because of my lack of patience I insert a server manually. This server is then displaued  at the top of the list and when selecting that server and all wourks well.

 The issue is that it just added an additional server to the list

How do i clean this screen to show only one server

Link to comment
Share on other sites

quickmic

So the server list is wrong?

The server information comes via network (I've to check, but I think it's UPNP).

I never seen that before, can you please upload a kodi.log file.

Best practice to migration from Kodi 18 to 19 is a clean installation, but sure it should also work on the fly.

 

Link to comment
Share on other sites

wbravin
41 minutes ago, quickmic said:

So the server list is wrong?

The server information comes via network (I've to check, but I think it's UPNP).

I never seen that before, can you please upload a kodi.log file.

Best practice to migration from Kodi 18 to 19 is a clean installation, but sure it should also work on the fly.

 

Thank you once again I do not think this is an issue with KODI i beleive this is the plugin. I do not know if the kodi log will cover the plugin. I will try to runthis tomorrow morning 

  • Like 1
Link to comment
Share on other sites

wbravin

hello all

 

here are the screen shots and the log. on is in wordpad and the other is just text

 

Thank you all for your time and for helping me

 

kodi emby.rtf kodi.log

Edited by wbravin
Link to comment
Share on other sites

  • 4 months later...
bigrndahouse

This maybe a newbie question but coming from Kodi, I have abandoned it as a media server and looking to pay out some well deserved cash for Premiere. Why still use Kodi? Am I missing something? 

 

Thanks

Link to comment
Share on other sites

52 minutes ago, bigrndahouse said:

This maybe a newbie question but coming from Kodi, I have abandoned it as a media server and looking to pay out some well deserved cash for Premiere. Why still use Kodi? Am I missing something? 

 

Thanks

Hi, welcome, and thanks for the support. It really comes down to personal preference and which app you prefer to use to connect to your Emby Server with. The Kodi add-on is meant to provide another option for those that prefer that.

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...