Jump to content

Podnapisi Plugin


Recommended Posts

Something is very strange with Podnapisi plugin. I can download subtitles from any languages with Podnapisi, but not norwegians subtitle. I get the error: There was an error processing the request. Please try again later. I have sent the log file. Subscene gives no result at all, but opensubtitles is working very well.

Thanks.

 

embyserver.txt

Link to post
Share on other sites
Luke

Hi, did you check the Podnapisi web site to see what subtitles they have for the title you're searching for?

Link to post
Share on other sites
13 hours ago, Luke said:

Hi, did you check the Podnapisi web site to see what subtitles they have for the title you're searching for?

Yes I have, something is wrong when I search for norwegians subtitle.

Link to post
Share on other sites
Luke
On 1/31/2021 at 9:26 AM, owi123 said:

Yes I have, something is wrong when I search for norwegians subtitle.

Does it happen on the website too?

Link to post
Share on other sites
  • 3 weeks later...
3 hours ago, Luke said:

Please go over an example. thanks.

For example 12 Years a Slave. I can download subtitles for all movies and  from all languages, exept subtitles in norwegian. Then I get an error that say: There was an error processing the request. Please try again later. For example if I download 12 years a slave with swedish subtitle it works, but not if I try to download norwegian subtitle.

Thank you.

Link to post
Share on other sites
  • 3 months later...
owi123

Podnapisi is still the same. I can't download norwegians subtitle, I still get this error message "There was an error processing the request. Please try again later" . All the other languages is no problem and download fine, only norwegians.

Link to post
Share on other sites
Luke
3 hours ago, owi123 said:

Podnapisi is still the same. I can't download norwegians subtitle, I still get this error message "There was an error processing the request. Please try again later" . All the other languages is no problem and download fine, only norwegians.

Hi, we'll take a look at it. Thanks for reporting.

  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...
Luke

I've pushed an update to the plugin. Please try it out. Thanks.

Link to post
Share on other sites
owi123
2 hours ago, Luke said:

I've pushed an update to the plugin. Please try it out. Thanks.

Yes, Thank you so much. Woking now!

  • Thanks 1
Link to post
Share on other sites
  • 1 month later...
ACarolan

I'm having the same issue with english subtitles. Available on podnapisi here, but getting the same vague error message.

image.png.43d02c1dd3b5e6faed27b20d9c6ad5d7.png

Log snippet example:

2021-07-20 22:41:18.237 Info Server: http/1.1 POST http://192.168.1.48:8096/emby/Items/41219/RemoteSearch/Subtitles/c65b3e54cb2c97e64513717d250a45c6_RPNG,en-loki-2021-S01E06-O-episode-%2316,en,?X-Emby-Client=Emby Web&X-Emby-Device-Name=Firefox&X-Emby-Device-Id=843ce21e-e772-480e-ab3b-c24cad3c0599&X-Emby-Client-Version=4.6.4.0. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0
2021-07-20 22:41:18.240 Info HttpClient: GET https://www.podnapisi.net/en/subtitles/en-loki-2021-S01E06-O-episode-#16/RPNG/download
2021-07-20 22:41:18.650 Info HttpClient: POST https://vip-api.opensubtitles.org/xml-rpc
2021-07-20 22:41:19.193 Error Server: Error processing request
	*** Error Report ***
	Version: 4.6.4.0
	Command line: /app/emby/EmbyServer.dll -programdata /config -ffdetect /app/emby/ffdetect -ffmpeg /app/emby/ffmpeg -ffprobe /app/emby/ffprobe -restartexitcode 3
	Operating system: Linux version 5.10.28-Unraid (root@Develop) (gcc (GCC) 9.3.0, GNU ld version 2.33.1-slack15) #1 SMP Wed Apr 7 08:23:18 PDT 2021
	Framework: .NET Core 3.1.13
	OS/Process: x64/x64
	Runtime: app/emby/System.Private.CoreLib.dll
	Processor count: 32
	Data path: /config
	Application path: /app/emby
	MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: UnsupportedMediaType
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
	   at Podnapisi.PodnapisiSubtitleProvider.GetSubtitles(String id, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Subtitles.SubtitleManager.DownloadSubtitles(Video video, String subtitleId, LibraryOptions libraryOptions, CancellationToken cancellationToken)
	   at MediaBrowser.Api.Subtitles.SubtitleService.Post(DownloadRemoteSubtitles request)
	   at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
	Source: Emby.Server.Implementations
	TargetSite: Void MoveNext()

 

Link to post
Share on other sites
Luke
12 hours ago, ACarolan said:

I'm having the same issue with english subtitles. Available on podnapisi here, but getting the same vague error message.

image.png.43d02c1dd3b5e6faed27b20d9c6ad5d7.png

Log snippet example:


2021-07-20 22:41:18.237 Info Server: http/1.1 POST http://192.168.1.48:8096/emby/Items/41219/RemoteSearch/Subtitles/c65b3e54cb2c97e64513717d250a45c6_RPNG,en-loki-2021-S01E06-O-episode-%2316,en,?X-Emby-Client=Emby Web&X-Emby-Device-Name=Firefox&X-Emby-Device-Id=843ce21e-e772-480e-ab3b-c24cad3c0599&X-Emby-Client-Version=4.6.4.0. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0
2021-07-20 22:41:18.240 Info HttpClient: GET https://www.podnapisi.net/en/subtitles/en-loki-2021-S01E06-O-episode-#16/RPNG/download
2021-07-20 22:41:18.650 Info HttpClient: POST https://vip-api.opensubtitles.org/xml-rpc
2021-07-20 22:41:19.193 Error Server: Error processing request
	*** Error Report ***
	Version: 4.6.4.0
	Command line: /app/emby/EmbyServer.dll -programdata /config -ffdetect /app/emby/ffdetect -ffmpeg /app/emby/ffmpeg -ffprobe /app/emby/ffprobe -restartexitcode 3
	Operating system: Linux version 5.10.28-Unraid (root@Develop) (gcc (GCC) 9.3.0, GNU ld version 2.33.1-slack15) #1 SMP Wed Apr 7 08:23:18 PDT 2021
	Framework: .NET Core 3.1.13
	OS/Process: x64/x64
	Runtime: app/emby/System.Private.CoreLib.dll
	Processor count: 32
	Data path: /config
	Application path: /app/emby
	MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: UnsupportedMediaType
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
	   at Podnapisi.PodnapisiSubtitleProvider.GetSubtitles(String id, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Subtitles.SubtitleManager.DownloadSubtitles(Video video, String subtitleId, LibraryOptions libraryOptions, CancellationToken cancellationToken)
	   at MediaBrowser.Api.Subtitles.SubtitleService.Post(DownloadRemoteSubtitles request)
	   at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
	Source: Emby.Server.Implementations
	TargetSite: Void MoveNext()

 

@ACarolan, that Podnapisi url is not valid, unfortunately. Try putting it in a browser and it returns 404 not found.

Link to post
Share on other sites
ACarolan

Ah, yeah that would explain it--thanks @Luke! Unfortunately all the options available have the same response, so maybe it's an issue with podnapisi or the plugin or something? The data is definitely available, just no way to point it to the right URL. It wouldn't matter if opensubtitles worked ever 😂

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...