Jump to content

weird new problem - football won't play, other recrded shows will


mohoelx
 Share

Recommended Posts

So sat down to resume watching a game I was watching yesterday via my Roku Ultra (normal method of watching Emby), and the "Retrieving" bar stops / starts / stop / etc. until I get a red "Playback error - too many errors, moving on". I can resume that in my Chrome browser though.

Tried several other games from start, and same thing, with the occasional error complaining that I've exceeded my # of streams, but alas, I am the only one watching anything. Max streams is set to 6. Restarted the server thinking maybe some phantoms / streams that didn't close out, etc, but no help.

Tried resuming another show (tv sit-com) and it worked fine.   

Rebooted Roku, checked for updates on Roku, Server (4.5.3) and the Emby app on Roku, all say they are good.

The other odd thing is it appears to be wanting to transcode everything even though historically it was direct-play here within the home. 

Is this all related to 4.5.3?

Does 4.5.3 'uncover' some errant setting that I have?

 

 

embyserver.txt ffmpeg-transcode-0ab3b443-e72d-41ec-8a3c-7f303a989ed5_1.txt

NFL_ffmpeg-transcode-a83bae6e-6561-47d1-8665-fca500acff26_1.txt

Edited by mohoelx
Link to comment
Share on other sites

Also noticed this in the "Alerts" section on the dashboard. Don't know if it's related or not, but first time I've seen a bright red alert message... It posted yesterday (1/5/2020) at 4:54 PM.

 

No such host is known.
at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
at MediaBrowser.Common.Updates.GithubUpdater.CheckForUpdateResult(String organzation, String repository, Version minVersion, PackageVersionClass updateLevel, String assetFilename, String packageName, String targetFilename, TimeSpan cacheLength, CancellationToken cancellationToken)
at Emby.Server.Implementations.ApplicationHost.CheckForApplicationUpdate(CancellationToken cancellationToken, IProgress`1 progress)
at Emby.Server.Implementations.ScheduledTasks.SystemUpdateTask.Execute(CancellationToken cancellationToken, IProgress`1 progress)
at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options)

Link to comment
Share on other sites

TranscodeReasons=ContainerBitrateExceedsLimit

You need to check what you have set for this. Because of the limit it has imposed transcoding. During transcoding something perpetually happens that makes the Roku unable to play the item. It is probably directly related to that error you have shown above. Something is askew.

@Luke

Link to comment
Share on other sites

Ok, I assume that it's on the Roku Playback settings I need to be looking? Since that is the only device that is failing playback.... 

While I have not changed these settings prior to the problem starting, the playback video quality setting is "Auto", but even trying to set it to 1080p 60 FPS, which is the highest I record at, I get the same error. Is this the right place to be looking?

Still seems odd that it worked yesterday, and not today... Roku hasn't updated since 11/13 (running 9.4.0), Emby on Roku is Version 4.0 Build 4 and says it's up-to-date but not sure when it last updated. Emby Server updated to 4.5.3.0 on 12/4, so that is the most recent change. 

Appreciate your efforts on this project! Hope to get this resolved, but not totally understanding why the ContainerBitrate changed or exactly where / how to change it.

Link to comment
Share on other sites

So I tried rolling back to 4.5.2.0, and it doesn't seem to make a difference. The weird thing is other shows recorded on the same channels seem to play fine. At least I haven't come across anything OTHER than the football games that will not play.

I saw an email about a post asking if these were interlaced, but they are not. Some 720p, some 1080p. They will play on Chrome or my Android tablet, just not the Roku. If the Settings / Playback / Video Quality is where I should be changing settings to increase the container bitrate, I've tried several settings with no difference. If I should be changing something else, please let me know.

 

Link to comment
Share on other sites

Raise the Quality/Bitrate to as high as it  goes to 110. Make sure on the items pre-play detail screen there are not subtitles that require burning selected. If these are graphical subtitles they will cause video to transcode. You want to play these files after you set the quality to highest possible and make sure no graphical subtitles are selected. Let us know what happens after doing this and attempting playback.

You can set the quality to "2160P 4K(UHD) - 110 Mbps" without having 4K. This raises the bitrate to the maximum. The "2160P 4K(UHD)" part is there to give indication what these media types usually require. If your device cannot support the resolution you select on the quality the next available resolution will be used but the 110 bitrate will stick. The Roku also can downscale media. We can figure this all out by query your device, making on-the-fly adjustments to the application and adjusting what is reported as capabilities to the server. Different code runs depending on each device. Just know that we will direct play as often as possible as much as possible. When things do not direct play the stats for nerds will always tell you why.

There is very little you will need to do besides set the appropriate bitrate when AUTO fails and press play. You may have to use Playback Correction under the cog on the video player UI when there are visible playback issues (stuttering, framerate judder, etc). The rest should just be automatic. Apologies you are having these issues. If you continue to experience them please report back. Thanks and Happy Holidays.

Edited by speechles
Link to comment
Share on other sites

Thanks Speechles but setting to 110 is still a no-go. 

Here's a weird part that may confuse / may help. All my recordings come from the same OTA source, recorded via Tablo then ported over to Emby for watching. So the incoming shows are from the same 1080p OTA channel, and ripped to Emby via the same process, so they come out 1080p H264, NUD AAC Stereo, and subtitles are available (SRT) but during playback they are off.

CBS football games of the KC Chiefs (11/29 vs Tampa Bay, 12/7 vs Denver) will not play, but MaGyver recorded from the same source (CBS on 12/4) will play. Similarly, all non-football shows I've tried to watch have played fine, but none of the football (even those I had watched prior to this problem) will play.

Thinking maybe it has something to do with the 'live sports', I also tried a few baseball games I still have around, and they will not play either (although most of them are 720p from Fox).Now another really curious bit is a MLB game that was rained out, plays the substitute programming just fine. 

Also forgot to mention - Gymnastics and Figure Skating (which may be 'live sports'?) also play fine.

This is totally boggling my mind!

 

Edited by mohoelx
Link to comment
Share on other sites

Ok, I'll give you that. According to the antenna map on my Tablo, it is 1080i. Not sure what happens / where from recording (Tablo), to ripping (Tablo Ripper) to library scan/metadata population (Emby), but it shows up in the Emby library claiming to be 1080p... my bad. 

However, if it is an interlacing problem, why don't the other shows I record on the same channel, that take the same path, have the same problem? That is just befuddling me!

1748776690_Screenshot2020-12-10182541.thumb.png.450f425b970c682f07de1ed0f42cb75a.png

Link to comment
Share on other sites

Ok, so I think I've figured something out. It seems that Emby was NOT seeing my Roku as being on the local network ... the 4250000 max is what I have set for playback going outside the local network since I have 5 gig upload from my ISP. I increased that to 5 gig, and the playback worked (direct play since it didn't hit that limit). However, the Roku is in fact on the same network (192.168) as my Emby. I even tried setting the local IP on the Network tab to what the Emby server has, and it still thinks the Roku is "IsInLocalNetwork: False". 

Ultimately, I signed out of EmbyConnect and re-linked (using the Emby.Media/Pin) and now they are both seen as on the local network. Weird.

Net-net is the 4.5.3.0 upgrade (or something unrelated?) jacked my Emby Connect from my Roku, causing Emby to treat it as an external device. I'm back to working as expected.

2020-12-12 15:20:24.271 Info SessionManager: Playback start reported by app Roku SG 4.0.4 playing Buffalo Bills vs. San Francisco 49ers. Started at 0 ms
2020-12-12 15:20:24.275 Info Server: http/1.1 Response 204 to 98.213.xxx.xx. Time: 38ms. http://98.213.xxx.xx:8096/emby/Sessions/Playing
2020-12-12 15:20:24.308 Info Server: http/1.1 GET http://98.213.xxx.xx:8096/emby/Items/17/Images/Backdrop?width=275&tag=e901a9eefd168aca7403be9274177bc0&quality=70. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36 Edg/87.0.664.57
2020-12-12 15:20:24.310 Info Server: http/1.1 Response 200 to 98.213.xxx.xx. Time: 2ms. http://98.213.xxx.xx:8096/emby/Items/17/Images/Backdrop?width=275&tag=e901a9eefd168aca7403be9274177bc0&quality=70
2020-12-12 15:20:24.421 Info Server: http/1.1 GET http://98.213.xxx.xx:8096/emby/Users/ffb4305cfdac45be817c70d4bf1313ed/Items/4639?fields=Overview. UserAgent: Roku/DVP-9.40 (469.40E04190A)
2020-12-12 15:20:24.426 Info Server: http/1.1 Response 200 to 98.213.xxx.xx. Time: 5ms. http://98.213.xxx.xx:8096/emby/Users/ffb4305cfdac45be817c70d4bf1313ed/Items/4639?fields=Overview
2020-12-12 15:20:24.611 Info Server: http/1.1 POST http://98.213.xxx.xx:8096/emby/Items/4639/PlaybackInfo?UserId=ffb4305cfdac45be817c70d4bf1313ed&isplayback=true&maxstreamingbitrate=110000000&starttimeticks=00000000. UserAgent: Roku/DVP-9.40 (469.40E04190A)
2020-12-12 15:20:25.622 Info App: User policy for chris. EnablePlaybackRemuxing: True EnableVideoPlaybackTranscoding: True EnableAudioPlaybackTranscoding: True
2020-12-12 15:20:25.623 Info App: RemoteClientBitrateLimit: 4250000, RemoteIp: 98.213.xxx.xx, IsInLocalNetwork: False
2020-12-12 15:20:25.623 Info App: Bitrate exceeds DirectPlay limit: media bitrate: 4914672, max bitrate: 4250000
2020-12-12 15:20:25.623 Info App: Bitrate exceeds DirectStream limit: media bitrate: 4914672, max bitrate: 4250000
2020-12-12 15:20:25.624 Info App: RemoteClientBitrateLimit: 4250000, RemoteIp: 98.213.xxx.xx, IsInLocalNetwork: False

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...