Jump to content

Emby Web UI "Forbidden"


strikefreedom

Recommended Posts

strikefreedom

Emby was working fine last week. My NAS is Asustor AS6204T & router is Asus AX88. Over the weekend I was tidying the list in port forwarding list and now I could not access Emby on Web anymore with error message "Forbidden". I revert back all settings on the port forwarding list but still no results. When access from LG TV, it was asking if Emby was running and could not connect. 

Before this "Forbidden" error happens, I could access smoothly and explore around with the Web UI perfectly via localip:portno. I restarted NAS and router a couple of times but no success. Please help thank you.

Link to post
Share on other sites
strikefreedom

In-Network Connections with http://localhost:8096 - failed

Emby apps - unable to connect to server right now. ensure it is running and try again. 

A useful test is to try to use a web browser on another device, such as another computer, smartphone or tablet. You'll need to ensure the other device is connected to the same WIFI network. Try opening a web browser on that device and entering the local address manually - failed

Open TCP Port 8096 and 8920 - done in NAS

External Connections via Emby Connect - unable to connect to server right now. ensure it is running and try again. 

Locate Your External Address - forbidden

Setup Port Forwarding - done in router. even tried DMZ on router. 

Verify Public Port - opened 8096 & 8920

Link to post
Share on other sites
Happy2Play

Is there a option to disable sleep mode?  The would be my first test.  But have no idea how Emby enter acts with this mode, so I am just guessing with the info provided.

Link to post
Share on other sites
strikefreedom
7 hours ago, Happy2Play said:

Is there a option to disable sleep mode?  The would be my first test.  But have no idea how Emby enter acts with this mode, so I am just guessing with the info provided.

I agree. the sleeping status of Emby looks fishy. Will figure out a way to bring it online.

Link to post
Share on other sites

Dont know if this will help you or not but I have a Asustor AS7010T with the latest ADM update and have found that after updating Emby have to stop and restart the Emby App a couple of times in the APP store for some reason it clears whatever is causing the stalling on server start up which may be what is inducing your sleeping server also check your power settings in the settings module to see if you have the Nas itself set to sleep as a power setting as I found that when i first got my NAS the Power setting was defaulted to save by sleeping until wake on Lan was activated which may be causing it as well. I have mine set to always on which isn't exactly energy saving but does alleviate a lot of the other problems induced by the power saving features. HTH

Link to post
Share on other sites

Also noticed you mentioned it is on a Asus Ax88 router is this coupled to your isp's modem if so is the modem set to bridge mode as you may  have a double router situation. I have a Asus AX88U router that gave me fits until i figured that was what caused me the problem of not being able to connect. Also check and make sure if using a dynamic ip setting on the router that it didn't change your servers ip which i have had that happen also. The ip for your Emby server should be the same as your NAS ip if it was updated depending on how you are signing into your NAS it may be already set to the new ip but your ip for the Emby server won't be updated in your tv or on the Emby server itself which would have you trying to sign into the old ip number don't ask me how long i beat me head against the wall before i figured that one out.

Link to post
Share on other sites

Forgot to mention that for some reason rebooting a ASUS router sometime shuffles the ips around on your different devices which cases the aforementioned changes and in the double router situation one router may be blocking the ports and the other isn't unless one of the routers is in bridged mode so check that as well

Link to post
Share on other sites
strikefreedom

Hi wangbo thank you for all the useful information. will try them out 1 by 1 to narrow down the causes. nice pointer on the power saving.

I restarted NAS & router a couple of times. even uninstalling and reinstalling emby. my NAS & emby ip are the same and they are static.

my ax88 is in router mode. i do have a 2nd router which is running as access point via lan connection tapping onto the ax88 router.

Link to post
Share on other sites

Is the NAS connected to the second router or to the Asus AX88 if to the second router then one or the other routers need to be set to bridge mode if the AX88 is your primary connection to your ip and then the NAS is connected to it directly then is not a double router set up but if is connected to the second router which is connected to the AX88 router then it is a double router situation or is the NAS connected via WIFI to one of them? if so the AX88U has the WIFI 6 standard (AX) capability maybe it got changed to that when rebooting or updating the router firmware which is possible the NAS can't operate in the AX mode or WPA3 is also available on the AX88 whereas the NAS might not be able to and the router is set to WP3 then the handshake will fail again causing connection problems these are a a few more possibilities HTH

Link to post
Share on other sites
  • 2 months later...
strikefreedom

Hi wangbo thank you again on all the pointers. my emby is back alive after a few updates on the NAS. I could connect to emby internally but not publicly for some reasons. I was able to connect to emby out of my home network many months ago until that specific updates that crashed it. 

Link to post
Share on other sites
Luke
12 hours ago, strikefreedom said:

Hi wangbo thank you again on all the pointers. my emby is back alive after a few updates on the NAS. I could connect to emby internally but not publicly for some reasons. I was able to connect to emby out of my home network many months ago until that specific updates that crashed it. 

Hi, so are you able to connect remotely now?

Link to post
Share on other sites

Glad to hear you were able to get it working and your welcome to the tips or to pass them on to others as needed.

  • Like 1
Link to post
Share on other sites
strikefreedom
On 17/02/2021 at 01:30, Luke said:

Hi, so are you able to connect remotely now?

yes it is working now. after many months of hiatus. thank you for all the help. 

Link to post
Share on other sites
strikefreedom
On 17/02/2021 at 01:34, wangbo said:

Glad to hear you were able to get it working and your welcome to the tips or to pass them on to others as needed.

thank you for all the help. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...