Jump to content

Trying to setup EMby Theather on RPi 4, help pls


EdwinH

Recommended Posts

About a year ago I switched from Kody to EMbY, and I like it so much I subscribed to premiere.

My EMBY server (4.5.0.20) runs on my QNAP NAS.

I had setup emby client (theater) (3.0.11) on my RPI 3 without issues.

 

Now my challenge :

I purchased a Rpi4 and I like to run emby on

I started to take the image :

https://github.com/MediaBrowser/emby-theater-electron/releases/download/3.0.12/emby-theater-rpi_3.0.12.zip

But that build stutters like crazy ( also has that behavior on my RPi 3 )

So I tried one build lower, of which I knew it runs perfect on my RPI3
https://github.com/MediaBrowser/emby-theater-electron/releases/download/3.0.11/emby-theater-rpi_3.0.11.zip

This time the movie starts. but after 10 seconds the image freezes but the sounds continues.

The image stay frozen also blocking view to any menu. Only solution is a reboot of the Rpi 4.

 

My question : is there is stable build of Emby client for Rpi4  ( image) ?

Thanks in advance for your answers and advice..

 

Edited by EdwinH
Link to post
Share on other sites

Hi Luke,

Thank you for taking time to look into this matter and help me.

On Emby server I had set hardware acceleration to 'Advance' and selected 'ARM V4L2 H.264',

Which works for my RPI3 running emby theater 3.0.11, client' video settings hardware acceleration to 'Auto' 

 

I turned hardware acceleration from 'advanced' to 'No' in emby server on NAS  and in RPi4 ' emby theater from 'Auto'  to 'none' , for testing purposes, results are :

RPi 4 with emby theater 3.0.12 : no change,. movie starts but image still stutters,  sound is clear.

RPi4 with emby theater 3.0.11: Movie starts in a play window popup, but behind the menu screen, ALT-TAB let me go cycle to window where movie is playing, but also picture stuttering. Window which plays video shows in top bar ' stream.mkv?DeviceId=raspberrypi&MediaSourceId08b6d01329e9a3f....   and the number goes on. 

 

With each change in settings or build, I double checked settings of hardware acceleration are set to 'none' in emby theater.

 

I moved my sdcard from RPi 3 ( emby theater 3.0.11, which plays without issues) to Rpi 4

Movie starts in a play window popup, but behind the menu screen, ALT-TAB let me go cycle to window where movie is playing, but also stuttering.

 

I start to suspect the HDMI cable ( different kind than for a Rpi 3) which came with the new Rpi 4, but before I go and buy a new one, I like to rule out any setting issues.

 

Any suggestions ?

Edited by EdwinH
Link to post
Share on other sites

A new day, Another try..
 

I removed al previous downloads, and decided to start fresh.

Downloaded  image from https://github.com/MediaBrowser/emby-theater-electron/releases/download/3.0.12/emby-theater-rpi_3.0.12.zip

With Etcher put image into a 32Gb Sdcard.

 

Put SDcard into Rpi4, set hardware acceleration to "none" 

And to my surprise , Movie starts, no stutter.

Putting Hardware acceleration to 'AUtO' in Rpi 4 Emby theater still runs movie stutter-free.

On EMbY server (NAS) Hardware acceleration is still set to 'No'.

I guess this issue resolved itself.

Thank you Luke for taking time and giving me your advice, Appreciated.

FYI,  No changes where made to hardware or software..

Spoke to soon, 
After setting config.txt EMBY stutters like crazy

Edited by EdwinH
Link to post
Share on other sites

I cheered to soon..


From clean image emby theater 3.0.12 , RPi4 Emby theater runs fine. (hardware acceleration turned on or off does not matter)

 

But I need the Rpi to force HDMI output, after I changed some settings below,  again stutter video playback ( hardware acceleration is off. )

 

I unquoted /boot/config.txt lines :

disable_overscan=1

hdmi_edid_file=0xa5000080  ( Rpi is connected to my Pioneer VSX-S520D HDMi and passthrough to my Samsung TV, I don't think Rpi is able to read TV's EDID)

hdmi_force_edid_audio=1  ( To pretend all audio formats are supported) 
hdmi_force_hotplug=1 (HDMI output mode will be used, even if no HDMI monitor is detected

hdmi_group=2

hdmi+mode = 82 ( t match TV's resolution 1080p 50hz 16:9

hdmi_drive=2 (Normal HDMI mode)

 

All other options are off with # in front

 

Why does video playback now stutter on a RPi4 ? 

Turning setting off in /boot/config.txt ( add # in front of the lines)

Does not help, video keeps stuttering.

 

I repeated process twice now, install fresh 3.0.12 to sdcard and try set HDMI settings in /boot.config.txt

 

 

I find it hard to believe that a Rpi3 runs perfect but a newer Rpi4 has this many issues running emby theater smooth.

 

Pease advice.

Edited by EdwinH
Link to post
Share on other sites

Started with an fresh install of Emby theater 3.0.11 for the Rpi 4( since that version runs perfect on my Rpi3)

Disabled hardware acceleration in settings of emby theater 3.0.11 ( Server update to 4.6.0.5, hardware acceleration set to 'No')

only option set in /boot/config.txt :

hdmi_force_hotplug=1

 

Movie does start but after 5 seconds the picture freezes , sound continues

 

How come that Rpi3 runs perfect with this build of emby theater (3.0.11) but Rpi4 give me so much trouble (theater 3.0.11 and 3.0.12) ?

 

 

 

Link to post
Share on other sites

I gave up on EMby Theater, It will not run smooth on Rpi4 

I tried even different Linux distro ( debian, Ubuntu) and install emby theater on it.

 

I now have installed LibreELEC 9.2  Kodi 18.9 on my new Rpi4 and installed add-on EMBY-con.

Everything runs smooth now, even able to play 4K movies flawless.

 

How is it that  LibreELEC 9.2 Kodi 18.9 with Emby-con runs smooth, but Emby theater image for Raspberri pi stutter on a RPI4 ?

 

I would love the get an answer on above question.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...