Jump to content

NextPVR 5.08 - Emby connection error - No playback & Not refreshing guide or lineup changes


brainfryd

Recommended Posts

Hi

Not sure whether to post this here or over at NextPVR, but I'm having issues get Emby to be able to connect with NextPVR. I'm on the latest server beta 4.6.0.1 using NextPVR plug-in 3.6.0.0 provided by @emveepee and NextPVR 5.0.8. 

Basically on the surface, it looks ok, but despite multiple guide refreshes , server restarts, it wont reflect new channel changes or allow playback/streaming of TV data. It also cant access recording schedules. i can see recorded content. Interestingly the guide data is up to date for the channels that have not changed. I have attached the logs for both Emby and NextPVR. in the emby log, it shows the following, which seems to indicate Emby cant authenticate/communicate with NextPVR due to a version error?

2020-10-04 09:51:24.451 Info App: [NextPVR] Start GetChannels Async, retrieve all channels
2020-10-04 09:51:24.475 Info App: [NextPVR] Start InitiateSession
2020-10-04 09:51:24.475 Info HttpClient: GET http://192.168.12.10:8866/service?method=session.initiate&ver=1.0&device=emby
2020-10-04 09:51:24.488 Error App: Check NextPVR Version 5
2020-10-04 09:51:24.491 Error LiveTvManager: Error refreshing channels for service
    *** Error Report ***
    Version: 4.6.0.1
    Command line: C:\Users\MBServer\AppData\Roaming\Emby-Server\system\EmbyServer.dll
    Operating system: Microsoft Windows 10.0.19041
    Framework: .NET Core 3.1.8
    OS/Process: x64/x64
    Runtime: C:/Users/MBServer/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
    Processor count: 4
    Data path: C:\Users\MBServer\AppData\Roaming\Emby-Server\programdata
    Application path: C:\Users\MBServer\AppData\Roaming\Emby-Server\system
    System.UnauthorizedAccessException: System.UnauthorizedAccessException: Check NextPVR Version
       at LiveTV.Plugins.NextPVR.Responses.InstantiateResponse.GetClientKeys(Stream stream, IJsonSerializer json, ILogger logger)
       at LiveTV.Plugins.NextPVR.LiveTvService.InitiateSession(CancellationToken cancellationToken)
       at LiveTV.Plugins.NextPVR.LiveTvService.EnsureConnectionAsync(CancellationToken cancellationToken)
       at LiveTV.Plugins.NextPVR.LiveTvService.GetChannelsAsync(CancellationToken cancellationToken)
       at Emby.LiveTV.LiveTvManager.RefreshChannelsInternal(ILiveTvService service, IProgress`1 progress, CancellationToken cancellationToken)
       at Emby.LiveTV.LiveTvManager.RefreshChannelsInternal(IProgress`1 progress, CancellationToken cancellationToken)
    Source: LiveTV.Plugins.NextPVR  "

 

embyserver.txt logs-20201004-1005.zip

Edited by brainfryd
Link to post
Share on other sites

@Luke,

With some help from @emveepee one the NextPVR forums, i can confirm that this works fine on a portable version of 4.51, so it seems to be related to server 4.6.0.1.
I've attached the new embyserver logs from the 4.51 version, i can see the schedules, guide is correct and can playback Live TV from the Web app with this version.

Hope this helps

Regards

brainfryd

embyserver 4.51.txt

Link to post
Share on other sites
arrbee99

Its playing here now using the same bits - 4.6.0.1 beta, 3.6.0.0 plugin and 5.08 NextPVR and Windows 10.

I presume it all working and plays in NextPVR.

Can't think of much except some basic stuff. No re-installs recently so that your NextPVR Base url still matches your Emby In-Home (LAN) Access. Maybe it'll work and its just a matter of time and updating guides when it feels like.

No idea what to look for in a log btw.

Link to post
Share on other sites

Yes, no dramas with NextPVR at all, can use the web app fully no problem and all the settings line up for Emby and NextPVR. I'll wait and see if someone can respond about why its ok on 4.51 but not on 4.6.0.1

Link to post
Share on other sites

The error has nothing to do with guide or sync issues since it is not getting that far.  @brainfryd you do have a similar error on 4.5.1 on an API call that fails when it shouldn't and it seem related to a an network timeout or issue with the connection,  it just happens that NextPVR ignore this error on PIN 0000 on localhost.

 

Martin

Link to post
Share on other sites

Ok now I'm really confused...

I realised that running a portable version of Emby on the same PC as NextPVR and running as localhost might not highlight issues correctly

Thanks @emveepee, the pin thing was a problem but in NextPVR, it seems to have reverted to the default at some point... it looked ok (4 digits), so i have changed that in NextPVR, but this is where it gets weird... I shut down my main Emby install, installed a portable copy of 4.5.1 elsewhere on this machine, setup one media library, did library scan and then closed Emby. Dropped the Nextpvr v5 dll into a plugins folder, restarted Emby. Configured the ip address and pin as per screenshot to match NextPVR.

625329179_EmbyNextPVRSettings.png.8eeecb8f7ae6bc9c4be54f9ae15e7e94.png

Ran a guide refresh (only ran for 2-3 secs ??), than ran a library update. Restarted Emby, checked Live TV- no channels/guide/schedules - Check error log - same error as 4.6.0.1

Here's a couple of extra screenshots, with results of one of the GET commands when entered straight into the browser

1492709002_Screenshot2020-10-05123312.png.4c4370a77cae9608fddc317563570952.png

this shot is the Next PVR web app screen from the Emby server PC, so i can get to this PC ok from the server PC ?

655586257_ScreenshotNextPVRWebfromServer.png.f64929d988467ab779fe77dcf7cbb5ba.png

Have done network resets on both pc's, reset router, restarted both PC's numerous times... this has worked in this configuration for last couple of years with no real issues communicating between these PC's the NextPVR rig is also my main HTPC, so it plays all my stored content on Emby Theater client with no problem. I have only started having issues since V5 NextPVR... or some random windows update, i guess.

Have attached new embyserver log for the portable installation on the MBServer pc.

If anyone has any ideas, i'm up for anything, as i have spent way too much time going round in circles.. I really dont want to fresh install the main Emby install or NextPVR if i can help it. I appreciate all the replies so far

Regards
brainfryd

embyserver Portable ServerPC.txt

Emby NextPVR Settings.png

Screenshot 2020-10-05 123312.png

Edited by brainfryd
Fix grammar and remove doubled up image
Link to post
Share on other sites

You are using the XML interface, the plugin uses the JSON interface via an http header you would need to use the &format=json parameter however this is not really proving much since we saw the proper call was getting to NextPVR with a good response.

If I had to guess it could be you have a very short timeout on the socket connection since the error is coming at 9ms or something like a VPN, firewall or AV suite is blocking.  I don't think it is Emby or NextPVR .

Martin

Link to post
Share on other sites

@emveepee
Hi Martin

Thanks for your responses so far... i appreciate you looking at this...

I had a big spiel here, but then realised i still had some AV processes running... shut them down and now it's back working... will have to investigate changing AV products...

 

Edited by brainfryd
new information :)
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...