Jump to content
bizarro252

LiveTV Watching behind live time - crashed?

Recommended Posts

bizarro252

Hello!

Long time no talk!  Been working great but I am still having issues with live tv if I pause and then play later being say 45 min behind live it will work for a while but then the picture will freeze, audio keeps playing then the loading bar appears and it will resume video but from the live time, losing the buffer of time we were behind in the show.  In this case the show was also being recorded.

This has happened a handful of times lately but I had not been near a computer, tonight I was so I pulled logs directly after.  They are attached.

 

I am on v4.4.3.0 on a FreeNAS box, using a HDHomerun for the TV source and streaming via a RokuTV Roku App (My wife cant recall if we were on beta or not so its either Beta 4.0 build 9 or standard build 4.0 build 4 - hope the logs show if that is important, otherwise I will track it next time.)

 

 

ffmpeg-directstream-ff17fae2-6d99-4c22-a554-f24690b2fc03_1.txt embyserver.txt

Share this post


Link to post
Share on other sites
ebr

Looks like the server is killing the transcode for some reason. A progress report was received two seconds prior to this so that is not the reason.  @softworkz

2020-09-07 21:26:09.220 Info EncodingManager: Transcoding kill timer stopped for JobId ff17fae2-6d99-4c22-a554-f24690b2fc03 PlaySessionId aa97bca4eca04418ac651b75ffd4cca2. Killing transcoding

 

Share this post


Link to post
Share on other sites
softworkz
5 hours ago, ebr said:

Looks like the server is killing the transcode for some reason. A progress report was received two seconds prior to this so that is not the reason.  @softworkz

 

@Luke

Share this post


Link to post
Share on other sites
Luke

hi @bizarro252 have you tried Emby Server 4.5? Are you still running into this?

Share this post


Link to post
Share on other sites
bizarro252

Hi @Luke

Had not seen the new version released, just installed and will test it out, thanks!

Share this post


Link to post
Share on other sites
Luke

Let us know how you get on. Thanks.

Share this post


Link to post
Share on other sites
bizarro252

Hi @Luke

So similar thing keeps happening, it will be playing along and then just freeze.  Backing out and going back to the channel (or recording) fixes it and it will not re-freeze at that same mark again.  I just caught an instance now while watching a recorded show (the recording in this case is already completed) where the image froze, audio kept playing and we had to back out and go back in to continue watching.

It marked the show as watched as well even though we were only 8 min into the show (~45 min show) after this freeze.  

Attached the logs from the above.

I see there is a new version (I am on 40.5.0.50 now) so will update and see if it improves.

These issue happen both on the stable and beta Roku App

ffmpeg-directstream-57a9db85-74fc-43bd-8dce-fc1e921a671f_1.txt embyserver (2).txt

Share this post


Link to post
Share on other sites
Luke

Hi, can you please try with Emby Server 4.5.2 and see how that compares? Thanks.

Share this post


Link to post
Share on other sites
bizarro252

Hi @Luke

No crash, but still freezes video, audio will continue.  Just happened again (using Roku stable client).  Video being watched we are watching live and it is also being recorded.  Video froze and audio continued, have to back out of the show and go back in to get it to unstick.  Attached logs, video froze approx 1 min before I got these downloaded.

Thanks!

embyserver (3).txt ffmpeg-directstream-c25ffec3-dd8a-41fa-aaa5-2666f57196e7_1.txt

Share this post


Link to post
Share on other sites
bizarro252

Noticed the ffmpeg log appears to just kind of... stop.  Here is that same log but after I backed out to the tv guide and restarted the show if that helps at all.

The previous attachments I pulled without touching anything with the video frozen.

ffmpeg-directstream-c25ffec3-dd8a-41fa-aaa5-2666f57196e7_1 (1).txt

Share this post


Link to post
Share on other sites
Luke

Can you try lowering the quality setting in the Roku app so that the server does a full transcode? Please see how that compares. Thanks.

Share this post


Link to post
Share on other sites
speechles

Or just press the playback correction button (inside the cog/gear) when playing Live TV. That will induce a full transcode without altering your quality.

It is when the MPEG2 stream is delivered raw to the Roku (directplay or directstream). The Roku is in charge of handling video decode.

When you transcode the video stream this is using ffmpeg to handle the decode of the MPEG2 stream and acting as the middleman to clear up errors in the stream that occur with low signal quality. Any dropouts ffmpeg should just work through. The Roku is never aware these occured when transcoding. When you are directplay or directstream the Roku can hang decoding the video. The screen will hang on the last image decoded but the audio is still moving forward.

This is an error in their MPEG2 decoder on the Roku. They are supposed to be fixing this in the next firmware updates just before Christmas *. We will know if that is true at that time. Until then playback correction can help work through these problems when they happen back to back. The issue is always signal quality and transmision errors. Roku needs better error handling for their MPEG2 decoder.

* The update should occur in mid November just before the store holiday blackout until Jan 7th. The store blackout is normally around Nov 18th until Jan 7th. During those dates the store is frozen and updates are queued. Roku is on holiday. The update therefore should occur before November 18th.

Edited by speechles

Share this post


Link to post
Share on other sites
bizarro252

Thanks. Tried this yesterday and all seemed to work fine. Will test more. 

Share this post


Link to post
Share on other sites
speechles
  • Friday, November 13, 2020 through Sunday, November 29, 2020
  • Friday, December 11, 2020 through Sunday, January 3, 2021

 

Those are the "exact" dates of the Roku store blackouts for 2020/21. During these times they will push no firmware updates. They must have them pushed by November 13th so be on the lookout. ^_^

During the blackout period the regular store app cannot be updated. Updates are queued. But the Beta app can be updated through these blackouts.

If you are not using the Emby Beta for Roku now is a good time to do so.

 

Edited by speechles

Share this post


Link to post
Share on other sites
bizarro252

Hi @speechles

Thanks for the tip. I am using the beta app and the behavior happened on both stable and beta but I will try that playback correction instead of lowering quality.

 

Is there a way to auto force it to always be in playback correction mode? My server is more than powerful enough to always transcode and not be bothered by it.

 

So far it did seem to fix the issue but would be nice to not have to manually enter that mode every playback.

Share this post


Link to post
Share on other sites
speechles
10 minutes ago, bizarro252 said:

Is there a way to auto force it to always be in playback correction mode? My server is more than powerful enough to always transcode and not be bothered by it.

 

Presently there is not. There is a setting regarding enable or disable directstream of in-progress recordings.

Perhaps we need an option that would enable/disable directstream of Live TV (separately from in-progress recordings) because of this Mpeg2 problem? @Luke @ebr

Edited by speechles

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...