Jump to content
MrGiles

Music Video Folders not showing

Recommended Posts

MrGiles

I have a library of music videos (mostly downloads from YouTube) in mp4 format.  I've created a music video library with the structure Music Videos\Artist\File.  So there is a folder for each artist, and in each folder are stored the mp4s.  However, in Folder View only a few folders are showing - where there is only one music video in the artist folder, the video itself is displayed rather than the folder - is this normal?   It also makes the sorting a bit weird as the folders are shown alphabetically by artist name, but then the remaining files are shown alphabetically by either the song title or artist name depending on the file name.  

Share this post


Link to post
Share on other sites
Luke

Hi there, can you please go over an example? Thanks.

Share this post


Link to post
Share on other sites
MrGiles

In the attached example, there are folders showing for those artists that I have more than one music video for - then it starts back at the beginning of the alphabet for artists where there is just one video in the folder.  When you click on a folder icon/thumbnail it shows the song titles for the files in that folder.  When you click on a thumbnail for an artist with just one video, it brings up the Media Info for that artist/ video.  I'm really confused as to why it doesn't just show the Artist folder regardless of how many videos there are in that folder.  

I'm new to Emby, and just trying to set up my Music Video library and having a number of issues - photos, movies, music and TV libraries have all been set up with no problems, but Music Videos are currently defeating me.  I'm also finding that it's sometimes grouping videos together for the same artist, as if they're TV episodes, but when I click on 'split versions' and re-scan it puts them back together again.  I'm sure I'm missing something, but I don't know what.

Just to be clear, the location of all my music videos is /Video/Music Videos/Artist Name/filename.mp4.  The filenames are mostly in the format of 'artistname - songname', although I'm sometimes having to delete the artistname in order to get the library to recognise it as a separate video.

Capture.JPG

Share this post


Link to post
Share on other sites
PenkethBoy

my MV library is setup slightly differently

./Music Videos/Artist/Songname/Songname.ext - even if i only have one for the artist - so separate folder for each video - then you will get a consistent view for your library

where songname is just that with no artist in the name - so you will need to remove "artist - "

531828429_Annotation2020-09-02172634.jpg.2f77bb70250d811df20c0d79b8bf312e.jpg

to get anything meaningful from IMVDb plugin if you are using it - then the songname needs to be the same as they have it - and even then you will only get say 60% match as they dont have everything

Share this post


Link to post
Share on other sites
MrGiles

Thanks, I'll try that!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...