Jump to content
MartijnB

FetchTV (australia) DNLA issues

Recommended Posts

MartijnB

Good evening,

I am fairly new to emby (jumped from Plex). I have my server running on ubuntu.

I am trying to stream to a fetchtv box (see https://www.fetchtv.com.au/packages/mighty). It seems that libraries containing movies work fine, but those containing tv shows fail.
I browse to the TV Shows library, "Continue watching" or "Latest" folders work, but clicking on "shows" or "folders" does nothing. This happens in multiple libraries, each is of the type "tv shows", but those listed as "movies" are fine.

The entire network is gigabit, i can't think of what this could be... any ideas?

Share this post


Link to post
Share on other sites
Luke

Hi there, can you please attach the emby server log? Thanks.

Share this post


Link to post
Share on other sites
MartijnB
Posted (edited)

oops... server log attached.

Few additional notes: If i add the same content using the library type "Mixed content" it works fine. Seems to be something about the TV Shows type.
Also turned off the real time monitoring of libraries as this caused some error.

embyserver (2).txt

Edited by MartijnB
additional info

Share this post


Link to post
Share on other sites
Luke

Does the fetchtv box support the content that you're trying to play?

Share this post


Link to post
Share on other sites
MartijnB
Posted (edited)

Yes, it does.

 

Edited by MartijnB
Add visual

Share this post


Link to post
Share on other sites
Luke

What formats does it support?

Share this post


Link to post
Share on other sites
MartijnB

avi, mkv, mov, mpeg, mpg, mp4.

The system will play it if i go through the mediahub > NAS > folder > select file > play
It fails (as per video) if i go through emby (DNLA) > folder >

And this only for type tv shows.

 

Share this post


Link to post
Share on other sites
MartijnB

Can you confirm that browsing the DNLA server isn't captured in the log... only playing files?

I have enabled DNLA logging for now, I see the following:

2020-08-09 09:52:57.492 Info HttpServer: HTTP GET http://192.168.0.200:8096/videos/143402/stream.mkv?DeviceId=d717044bf032b1a33f6618be0256002c&MediaSourceId=06487825ce3bb0ba1f197a6fd78015f7&Static=true&PlaySessionId=3b7f0ae7fc6d8528bcaa4913ac6ba451. HOST=192.168.0.200:8096, Range=bytes=13926400-295906147, DATE=Sat, 08 Aug 2020 23:52:57 GMT, CONNECTION=close, USER-AGENT=Linux/3.14.28-1.6, HTTP/1.0, Portable SDK for HTTP devices
2020-08-09 09:52:57.492 Info HttpServer: SocketException: http://192.168.0.200:8096/videos/143402/stream.mkv?DeviceId=d717044bf032b1a33f6618be0256002c&MediaSourceId=06487825ce3bb0ba1f197a6fd78015f7&Static=true&PlaySessionId=3b7f0ae7fc6d8528bcaa4913ac6ba451
2020-08-09 09:52:57.492 Info HttpServer: HTTP Response 206 to 192.168.0.136. Time: 96ms. http://192.168.0.200:8096/videos/143402/stream.mkv?DeviceId=d717044bf032b1a33f6618be0256002c&MediaSourceId=06487825ce3bb0ba1f197a6fd78015f7&Static=true&PlaySessionId=3b7f0ae7fc6d8528bcaa4913ac6ba451
2020-08-09 09:52:58.152 Info HttpServer: SocketException: http://192.168.0.200:8096/videos/143402/stream.mkv?DeviceId=d717044bf032b1a33f6618be0256002c&MediaSourceId=06487825ce3bb0ba1f197a6fd78015f7&Static=true&PlaySessionId=3b7f0ae7fc6d8528bcaa4913ac6ba451
2020-08-09 09:52:58.152 Info HttpServer: HTTP Response 206 to 192.168.0.136. Time: 661ms. http://192.168.0.200:8096/videos/143402/stream.mkv?DeviceId=d717044bf032b1a33f6618be0256002c&MediaSourceId=06487825ce3bb0ba1f197a6fd78015f7&Static=true&PlaySessionId=3b7f0ae7fc6d8528bcaa4913ac6ba451
2020-08-09 09:54:32.544 Info HttpServer: HTTP GET http://192.168.0.200:8096/emby/System/Logs/embyserver.txt/Lines?SortBy=IsFolder%2CSortName&SortOrder=Ascending&Fields=BasicSyncInfo%2CProductionYear%2CStatus%2CEndDate&ImageTypeLimit=1&EnableImageTypes=Primary%2CBackdrop%2CThumb&StartIndex=600&Limit=100&EnableTotalRecordCount=false. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.61 Safari/537.36


I stopped playing a file (loaded through "Latest") at 2020-08-09 09:52:58.152 and then waited until my clock turned to 9:54AM and browsed through the emby server (via DNLA) but nothing is showing in the log.

Share this post


Link to post
Share on other sites
Luke

Did you also enable debug logging in the server logs section?

Share this post


Link to post
Share on other sites
MartijnB

Done.

What i see in the logs now (added the FetchTV profile in DLNA):

2020-08-10 05:10:34.944 Debug HttpServer: HTTP POST http://192.168.0.200:8096/dlna/41e72e403fba4a338e42b3b65f8925df/contentdirectory/control. UserAgent: Linux/4.1.20-1.9, UPnP/1.0, DLNADOC/1.50
2020-08-10 05:10:34.944 Debug Dlna: Found matching device profile: FetchTV
2020-08-10 05:10:34.945 Debug Dlna: Received control request Browse
2020-08-10 05:10:34.974 Debug HttpServer: HTTP Response 200 to 192.168.0.104. Time: 30ms. http://192.168.0.200:8096/dlna/41e72e403fba4a338e42b3b65f8925df/contentdirectory/control

If i put " http://192.168.0.200:8096/dlna/41e72e403fba4a338e42b3b65f8925df/contentdirectory/control" in a webbrowser, i get: Unable to find the specified file.

Share this post


Link to post
Share on other sites
Luke

Right you can't put that in a browser, that won't work.

So you created a device profile, why?

Share this post


Link to post
Share on other sites
MartijnB

Cause I am grasping at straws here. Trying to identify why FetchTV isn't reading the folders of the tv shows library type.

If you want to know, I also started looking through the code in Emby.Dlna.dll, seeing if anything there could point me in the right direction. Unless i get this working, I won't be looking at Premiere. Maybe I need to go back to plex.

Share this post


Link to post
Share on other sites
Luke

Most likely the issue is that fetchtv doesn't like something about our xml response. I'm just not sure what it is yet.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...