Jump to content

Roku 4.0 Playback Issues - Video freezes, Audio Continues


Recommended Posts

murky024

I have been having some playback issues with my TCL Roku TV since the upgrade to 4.0. When I am playing back a movie it freezes the screen but continues with the audio. When I back out of the video, the resume button is not available and it does not maintain the spot on the video. This has happened about 4 times since upgrading to 4.0, always a different spot on the video and once I replay the video and fast-forward to the spot it plays normal.

 

Here is the text from the log file when it happened:

2020-07-02 18:53:08.243 Error HttpServer: Error processing request
	*** Error Report ***
	Version: 4.4.3.0
	Command line: C:\Users\murky\AppData\Roaming\Emby-Server\system\EmbyServer.dll -noautorunwebapp
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///C:/Users/murky/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	System.Environment.Version: 3.1.4
	Processor count: 4
	Program data path: C:\Users\murky\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\murky\AppData\Roaming\Emby-Server\system
	System.InvalidOperationException: System.InvalidOperationException: Operation is not valid due to the current state of the object.
	   at Emby.Server.Implementations.Library.LibraryManager.ConvertImageToLocal(BaseItem item, ItemImageInfo image, Int32 imageIndex, CancellationToken cancellationToken)
	   at Emby.Drawing.ImageProcessor.ProcessImage(ImageProcessingOptions options, CancellationToken cancellationToken)
	   at MediaBrowser.Api.Images.ImageService.GetImage(ImageRequest request, Int64 itemId, BaseItem item, Boolean isHeadRequest)
	   at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
	Source: Emby.Server.Implementations
	TargetSite: Void MoveNext()

 

embyserver-63729331203.txt

Link to post
Share on other sites
ebr

Hi. That error is unrelated to playback.

Is there an ffmpeg log?  Did your Roku also recently update to 9.3 firmware?  If so, can you try disabling transcode throttling in your server?

Link to post
Share on other sites
murky024
Posted (edited)
1 hour ago, ebr said:

Hi. That error is unrelated to playback.

Is there an ffmpeg log?  Did your Roku also recently update to 9.3 firmware?  If so, can you try disabling transcode throttling in your server?

No, it was directly played through the Roku, there were no ffmpeg logs for that day. Also, yes to the recent firmware upgrade from the TCL TV. I noticed that updated a week or so back automatically.

Edited by murky024
Link to post
Share on other sites
Luke

If it's direct playing then it is a problem in the Roku player. We can report this to Roku. Workaround in the meantime would be to use the playback correction menu during playback to switch to transcoding.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...