Jump to content

Update 4.4.3.0-1 broke ASS embedded subtitles for me


Recommended Posts

crippah

Hi there,

I've been using Emby for a while now without issues. After update 4.4.3.0-1 my ASS embedded subtitles stopped working. 
The video struggles to show the subtitles as it takes about 2 - 3 minutes for the subtitles to start showing up. 
After the subtitles show up, the video starts lagging, flickering and has short freezes. Also sometimes the subtitles will freeze completely while the video continues.
Videos using external SRT files work fine without issues. Synology Video Station / Plex both work without issues. 
Weird thing is that when I play the video on my Android App it works fine. When I play the video in the browser or chromecast it does not. 

I've tried the following solutions:

Disabled transcoding (because I thought it might be forced transcodig and the server can't handle that)
Disabled on the fly subtitle extract
Reinstalled Emby
Reinstalled my Synology NAS

NAS: DS216j

Thank you kindly for the help 😇

Edited by crippah
Link to post
Share on other sites
Luke
Quote

Disabled transcoding (because I thought it might be forced transcodig and the server can't handle that)
Disabled on the fly subtitle extract

Yes if you disable both of these then there is a good chance you will have problems.

Link to post
Share on other sites
crippah
Posted (edited)
On 6/16/2020 at 4:56 PM, Luke said:

Yes if you disable both of these then there is a good chance you will have problems.

As I stated above, I tried this as a solution and it did not work (normally these are enabled).
Uploaded the logs.

 

Edited by crippah
Link to post
Share on other sites
  • 2 weeks later...
6zayn

If the file names for the video and the SRT file vidmate don't match, if the subtitle track is disabled or if the program doesn't support the correct encoding

Edited by 6zayn
Link to post
Share on other sites
Luke
7 hours ago, 6zayn said:

If the file names for the video and the SRT file don't match, if the subtitle track is disabled or if the program doesn't support the correct encoding

Hi there, are you asking a question?

Link to post
Share on other sites
  • 2 weeks later...
crippah
Posted (edited)

It's still not working. All video files work fine with SRT embedded subtitles but do not work with ASS embedded subtitles. Currently HorribleSubs anime videos with ASS embedded subtitles do not work.

Currently I'm just extracting the ASS subtitles and converting them to SRT and that works for me.

Edited by crippah
Link to post
Share on other sites
crippah

Another update: I tried using Synology Video Station and to my surprise it worked flawlessly with embedded ASS mkv files. Very strange.

Link to post
Share on other sites
Luke
5 hours ago, crippah said:

Another update: I tried using Synology Video Station and to my surprise it worked flawlessly with embedded ASS mkv files. Very strange.

Can you please supply the information I requested in post #2? Thanks.

Link to post
Share on other sites
  • 1 month later...
crippah
Posted (edited)

I'm sorry. I did not get a response for a while so I thought this post was forgotten. Logs included from a fresh install of emby on my PC instead of my Synology NAS.

 

 

embyserver.txt

Edited by crippah
Updated server log
Link to post
Share on other sites
  • 2 months later...
crippah

@Luke I forced the update manually and I tried running an Anime Episode with embedded ASS subtitles. Again the subtitles did not show for 35 seconds. After that the video stopped for a couple of seconds and started lagging and stuttering.

Link to post
Share on other sites
Luke
On 11/3/2020 at 6:51 AM, crippah said:

@Luke I forced the update manually and I tried running an Anime Episode with embedded ASS subtitles. Again the subtitles did not show for 35 seconds. After that the video stopped for a couple of seconds and started lagging and stuttering.

Would you mind providing a new log example from the latest version? Thanks.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...