Jump to content
cmacfarlane93

Secure connection option not working for me

Recommended Posts

cmacfarlane93
Posted (edited)

In settings, Network under Secure Connection Mode, I have enabled "Required for all remote connections". However I am able to still connect via http to my emby server. Why is this?

Edited by cmacfarlane93

Share this post


Link to post
Share on other sites
Luke

Hi there, can you please go over an example? Did you setup an ssl certificate?

Share this post


Link to post
Share on other sites
cmacfarlane93
Posted (edited)

Hi there, can you please go over an example? Did you setup an ssl certificate?

Yes I have. The certificate works perfectly when I connect via https. it is provided by cloudflare. The only issue I have is when I go to http://app.emby.media I can still connect to my server, despite the setting for requiring https enabled. for example I can connect to my emby server from both https://app.emby.media and http://app.emby.media, despite secure connection mode being required. 

Edited by cmacfarlane93

Share this post


Link to post
Share on other sites
Luke

Right OK. It will still use your https server url when doing that.

Share this post


Link to post
Share on other sites
cmacfarlane93

Right OK. It will still use your https server url when doing that.

Hey thanks for the response, however forgive me I don't fully understand. Does this mean despite using http://app.emby.media to navigate to my server, https protocol is being used? Does this mean traffic is still being encrypted? My broswer shows insecure when I use http://

Share this post


Link to post
Share on other sites
Luke

The web page html download is insecure, but the connection to your emby server is still secure. That's what that means.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...