Jump to content
boardbum

ANSWERED Update check fails and can't search images

Recommended Posts

boardbum

Strange title but I'll explain.

Today added 2 movies and they were identified but no images were shown.  I tried edit image but a search returned no results even when checking all languages.  I tried identify using the imdb id but there where NO results that way so I tried just typing the name and putting the date in.  I received 3 results one of which was correct but there was no image.

 

I went to dashboard and found that application, version update and tvdb installation had all failed.  

 

I had a similar problem on another pc and had to disable ivp6.  Did it on this pc and nothing changed.  I haven't changed settings or even rebooted until today when I had problems.  A new show added a few weeks ago showed images.

 

When I click on the (i) for the update I get this :

Access to the path '/media/3T/EmbyCache/cache/httpclient/0fb243ded9649ae6d18059c674a4ae00' is denied.
at Interop.ThrowExceptionForIoErrno(ErrorInfo errorInfo, String path, Boolean isDirectory, Func`2 errorRewriter)
at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String path, OpenFlags flags, Int32 mode)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, FileOpenOptions fileOpenOptions)
at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, Boolean isAsync)
at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.CacheResponse(HttpResponseInfo response, String responseCachePath)
at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
at MediaBrowser.Common.Updates.GithubUpdater.CheckForUpdateResult(String organzation, String repository, Version minVersion, PackageVersionClass updateLevel, String assetFilename, String packageName, String targetFilename, TimeSpan cacheLength, CancellationToken cancellationToken)
at Emby.Server.Implementations.ApplicationHost.CheckForApplicationUpdate(CancellationToken cancellationToken, IProgress`1 progress)
at Emby.Server.Implementations.ScheduledTasks.SystemUpdateTask.Execute(CancellationToken cancellationToken, IProgress`1 progress)
at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options)

 

there's nothing locked in the cache, and permissions haven't changed that I know of so I can't fiugre out what is going on.

 

Any suggestions?

If I need to provide more info let me know.  I'm attaching the log.

embyserver (1).txt

Share this post


Link to post
Share on other sites
boardbum

ok, solved.  I had to change the owner to emby - Emby Server and the group to emby.  It was "user".  Either it was like this all along or something changed it.  If it was "user" all along how come suddenly it's and issue?  if not, how could it have been changed?

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Glad you figured it out. Thanks for the feedback.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...