Jump to content
somy

Possible for Emby not to download subtitles repeatedly?

Recommended Posts

cayars

What subtitle am I looking for in the log?

Can you provide one of the subtitle files as well to look at that are in txt format?

Share this post


Link to post
Share on other sites
cam1313
39 minutes ago, cayars said:

What subtitle am I looking for in the log?

Can you provide one of the subtitle files as well to look at that are in txt format?

Here are three of many (subtitle files in txt format attached as well):

Weekend at Bernie's II (1993).1.en

Revenge of the Nerds II Nerds in Paradise (1987).1.en

D.A.R.Y.L. (1985).1.en

 

Still getting multiples of actual subtitle files as well.  Lucky Numbers (2000) is an example.

 

Thanks again.

Weekend at Bernie's II (1993).1.en.txt Revenge of the Nerds II Nerds in Paradise (1987).1.en.txt D.A.R.Y.L. (1985).1.en.txt

Share this post


Link to post
Share on other sites
Luke

We'll take a look at it. Thanks for reporting.

  • Thanks 1

Share this post


Link to post
Share on other sites
cayars

Those seem to be SRT files.

Do you know which plugin is downloading these?

Share this post


Link to post
Share on other sites
cam1313
3 hours ago, cayars said:

Those seem to be SRT files.

Do you know which plugin is downloading these?

Yes, the files contain subtitles but they are saved as txt files and without manually updating they are not recognized by Emby. 
 

I am unable to tell from the log which plugin these came.

Share this post


Link to post
Share on other sites
cayars

I just went back and looked at your log file from Saturday cam1313 and seeing this:

2020-07-19 00:52:15.027 Error SubtitleManager: Error downloading subtitles from Addic7ed

2020-07-19 00:52:15.029 Error SubtitleManager: Error downloading subtitles from NapiSub

2020-07-19 00:52:15.029 Info HttpClient: GET http://api.thesubdb.com/?action=search&hash=EBF9B9D942431046249156B041755D83
2020-07-19 00:52:15.237 Debug LibraryMonitor: New file refresher created for /share/CACHEDEV1_DATA/Multimedia/Movies/Grindhouse (2007)/Grindhouse (2007).1.en.txt

So if I'm reading the log correctly (kind of hard to tell in this spot) but it looks like thesubdb.com is where the .en.txt files are coming from.

Have you configured Addic7ed & NapiSub?  I didn't look hard but they are giving errors.

Share this post


Link to post
Share on other sites
cam1313
1 hour ago, cayars said:

I just went back and looked at your log file from Saturday cam1313 and seeing this:

2020-07-19 00:52:15.027 Error SubtitleManager: Error downloading subtitles from Addic7ed

2020-07-19 00:52:15.029 Error SubtitleManager: Error downloading subtitles from NapiSub

2020-07-19 00:52:15.029 Info HttpClient: GET http://api.thesubdb.com/?action=search&hash=EBF9B9D942431046249156B041755D83
2020-07-19 00:52:15.237 Debug LibraryMonitor: New file refresher created for /share/CACHEDEV1_DATA/Multimedia/Movies/Grindhouse (2007)/Grindhouse (2007).1.en.txt

So if I'm reading the log correctly (kind of hard to tell in this spot) but it looks like thesubdb.com is where the .en.txt files are coming from.

Have you configured Addic7ed & NapiSub?  I didn't look hard but they are giving errors.

Thanks for the assist.  Addic7ed was configured but it appears the website has recently blocked traffic from my country, and NapiSub has no settings to configure.  I removed both plugins as well as thesubdb.com (for the time being) to see what happens.   

Share this post


Link to post
Share on other sites
cayars

I've been trying to reproduce without success.

I think I might need to test with different language/country settings.

Can you tell me what these are set to on your system or PM me?

Share this post


Link to post
Share on other sites
cam1313
Just now, cayars said:

I've been trying to reproduce without success.

I think I might need to test with different language/country settings.

Can you tell me what these are set to on your system or PM me?

I've got it set to download both English and Korean subtitles.

Share this post


Link to post
Share on other sites
cayars

And sorry forgot to ask but what is your setting for Preferred metadata download language?

Share this post


Link to post
Share on other sites
cam1313
52 minutes ago, cayars said:

And sorry forgot to ask but what is your setting for Preferred metadata download language?

Sorry, just saw this. It’s English. 

Share this post


Link to post
Share on other sites
cam1313

Update: It appears the problem was resolved by removing plugins

...which one was the culprit?  I don't know.

With Addic7ed, NapiSub, and thesubdb.com removed I no longer get duplicate subtitles.  Now if we could just figure out which one was causing the problem it would be nice to reinstall some plugins for additional options. 

Thanks.

Share this post


Link to post
Share on other sites
cayars

You were getting errors:

2020-07-19 00:52:15.027 Error SubtitleManager: Error downloading subtitles from Addic7ed

2020-07-19 00:52:15.029 Error SubtitleManager: Error downloading subtitles from NapiSub

So that almost makes it seem like the dupes couldn't have been coming from either of them but not certain.

What you could do is add thesubdb.com back only and monitor the situation to see if the multiples come back.  If so we have the culprit and could get a dev to look at it.

Share this post


Link to post
Share on other sites
cam1313

Good call...I'll give that a shot and report back. Thanks.

 

  • Like 1

Share this post


Link to post
Share on other sites
cam1313

Happy to report it appears everything is functioning as intended with thesubdb.com reinstalled.  Thanks again for the help!

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback.

Share this post


Link to post
Share on other sites
somy
Posted (edited)

Removed the double post

Edited by somy

Share this post


Link to post
Share on other sites
somy
On 7/6/2020 at 4:32 AM, Luke said:

Please try this in Emby Server 4.4.3. Thanks.

Hi, just want to report back if I only choose to download "Chinese Simplified" the issue is gone. However if I choose both "Chinese Simplified" and "Chinese Traditional" it will keep re-downloading all Chinese subtitles. I only have opensubtitle plugin, and I can reproduce it in 4.4.3.

Share this post


Link to post
Share on other sites
trashken
1 hour ago, somy said:

Hi, just want to report back if I only choose to download "Chinese Simplified" the issue is gone. However if I choose both "Chinese Simplified" and "Chinese Traditional" it will keep re-downloading all Chinese subtitles. I only have opensubtitle plugin, and I can reproduce it in 4.4.3.

Can confirm I did this. I have unchecked both and the problem did not reoccur.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...