Jump to content
plex1

Emby not releasing HDHomeRun

Recommended Posts

plex1

Now that I have Live TV working, I have found one problem.

 

When I stop watching a TV program (I use the back button and go back to the main menu area before quitting), the HDHomeRun tuner is still "attached" to the server and the channel is still open.\

 

Anyway to correct the server/app so that the HDHomeRun is closed when no longer watching TV?

Share this post


Link to post
Share on other sites
mediacowboy

Just noticed this myself after watching the SpaceX launch

Share this post


Link to post
Share on other sites
plex1

I also have three (yes, three) Plex servers that are also doing Live TV.    They seem to monitor the user that is watching the channel.   If the user disconnects, then it releases the tuner.    Better than relying on the user to exit properly.

 

In my case, I was using the Roku app, tuned to a channel.    Quit the video (backed out to the main menu) and exited the app.   The tuner stayed locked to that channel.

 

I then used my browser (Chrome) and did the same thing on another channel.   Backed out to the guide and exited.   Again, the tuner was locked.    I had to power cycle the Prime tuner to release it.

 

Tried again with the Roku app (I have two tuners, a Prime and a Quatro).    Tuned a channel that was on the Quatro.    Exited correctly, and it locked the channel on the tuner!

 

Seems that Emby is not releasing the way it needs to.    Would be great if they would follow the lead Plex has done with monitoring the user.

 

Having Emby is ideal in my case.    I use it to create a "child friendly" server where only the children's directories are visible and I can control what tv channels they have access to.     This is the one thing I cannot do with Plex, which has all movies (over 36,000) and TV channels available.

Share this post


Link to post
Share on other sites
ebr

Hi.  What version of the server are you running and exactly how are you "exiting" playback (what button on the remote)?

Share this post


Link to post
Share on other sites
plex1

Emby Server:  4.4.3.0

Roku   Software version: 9.2.0   Build: 4808    (Insignia - Roku TV model 5410X   NS-24DR220NA18

 

Use "back arrow" on Roku remote.      Further testing shows this to be an intermittent problem.     If only watching a channel for a short time, this works fine.   If watching for a long period or if internet is interrupted, it locks.

 

I have been testing on some other Roku TV's, including two 4k models, some are Insignia, one Vizio and one Samsung (Samsung 4k is using an external Roku Ultra).    Most of the testing has been on the Insignia above since it is in my computer room.      Insignia 4k in Master Bedroom and Insignia in Family Room are both hard wire ethernet.    All others are WiFi.   All have strong WiFi signal (3 access points in home) and signal checked on each tv.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...