Jump to content
Bamit

ANSWERED Roku 4 Ultra and Audio - AC3 5.1 remux question

Recommended Posts

Bamit

I have a Roku 4 Ultra and the AC3 5.1 no longer works.
I began to notice lately that the sound was not as good as it use to be so I checked with a small MP4 I use periodically to check each of my speakers and it now remuxes the file to a .TS using 2 channel stereo where it used to play direct.

In fact, I've noticed that almost all of the media I have is now Remuxing where it used to play direct.
Also, the setting that asks if I want to Convert Multi-Channel AAC (which is Set to Yes), does not seem to make a difference.

Has something changed with the settings in the Roku App or could it be a setting somewhere on the server?

- - -

I Have a Roku 4 4660X ver. 9.2.0 Build 4807-46
running Emby 3.0.223 and also Emby Beta 4.03
An LG 86UM8070PUA Smart TV
Sony HT-RT3 5.1 Soundbar with HDMI ARC connected to TV

Note:
If I use the Roku's Media Play app, it works correctly.
If I use the TV's Emby Player app, it works correctly.
If I use the TV's generic DLNA connections app, it works correctly.

Share this post


Link to post
Share on other sites
speechles
Posted (edited)

Nothing was changed in the application in the capabilities/profile section.

 

But you are using ARC so what may have happened is the HDMI chain is broken. The Roku doesn't understand that you could decode Dolby via pass-through over ARC. Depending on the order devices were turned on can complicate things.

 

Always follow these steps when using ARC:

1) turn on receiver

2) turn on TV

3) unplug Roku and plug back in so it realizes the current HDMI setup with all devices on

4) enjoy

(note: A Roku TV combines steps 2 and 3 into one step.)

 

Are you sure steps 1 through 4 were completed in the order above. You may just need to do step 3 and 4 more than likely. A reboot of the Roku should solve it. If the reboot does not solve it I also have an 4660 and can run more tests with a sample of the same media you are using. Let us know if this helps. Thanks. ;)

 

 

We detect all codec support by query the Roku device. We do not manually assume your device supports any codecs. Some Roku applications assume all Roku devices support certain codecs. We do not do this we read all from the device responses. This is why I suspect the HDMI chain is not reporting all devices because the Roku "does not see" what is connected via ARC.

 

image.png

 

This is remux because the audio channel count exceeds what the device reports as supported. Basically it is 8 channel AAC and Roku likes 6. So to keep the immersion the Emby server transcodes to AC3. This is on my 4660 as the stats for nerds above shows.

 

When you change the "Convert Multi-Channel AAC" option to NO it will allow the Roku to decimate on the device to 2 channel stereo. The Roku only supports AAC in 2 channel stereo (but will report support for up to 6.. it lies). So we created that option to allow you to keep surround sound when AAC reports over 2 channels. If you set that option to YES it will allow the Emby server to transcode the audio and it will use AC3 if that codec is found supported. Otherwise it will have no choice but to fallback to 2 channel stereo in AAC.

 

Can you show us a picture of the stats for nerds on your 4660 with the problem file? Thanks again. :)

Edited by speechles

Share this post


Link to post
Share on other sites
Bamit
Posted (edited)

Thanks for your help.  I followed the steps you provided and did it twice for extra measure.  Sadly, no joy.  I've attached a screen shot of my Stats for Nerds.  Hopefully it will help shed some light on my issue.

 

Update:  I've tried to post the image of the screen shot using .jpg and .png and I got this message:

 

 * You are not allowed to use that image extension on this community.

 

Sorry....

Edited by Bamit

Share this post


Link to post
Share on other sites
speechles
Posted (edited)

Thanks for your help.  I followed the steps you provided and did it twice for extra measure.  Sadly, no joy.  I've attached a screen shot of my Stats for Nerds.  Hopefully it will help shed some light on my issue.

 

Update:  I've tried to post the image of the screen shot using .jpg and .png and I got this message:

 

 * You are not allowed to use that image extension on this community.

 

Sorry....

Try uploading to http://imgbb.com

 

Once uploaded click into the image so it shows full size. Right click and choose copy image address.

 

Then use this somewhere in your post to include the image:   [img]<Paste the image address here>[/img]

 

It will embed the image into the page rather than attach it. This will use an offsite image storage and you can upload any type you want this way

Edited by speechles

Share this post


Link to post
Share on other sites
Bamit
Posted (edited)

.

Edited by Bamit

Share this post


Link to post
Share on other sites
Bamit
Posted (edited)

I will try this.  What is funny, I've uploaded images before, so maybe it is this Roku section that has image limits for it?

Here is the link I created there.  Hopefully it makes it through.

 

https://i.ibb.co/WDTrcrm/20200524-113654.png

 

20200524-113654.png

Edited by Bamit

Share this post


Link to post
Share on other sites
ebr

What is the audio setting on the Roku itself?

Share this post


Link to post
Share on other sites
speechles
Posted (edited)

Press * as video plays to bring up the OPTIONS menu. On that menu you will find VOLUME MODE. For pass-through to work this must be set to OFF. This might be what is causing your issue. You also want to check the HDMI-AUDIO settings on your Roku like mentioned above. VOLUME MODE can only be changed from OFF when using AUTO. I suspect you are using AUTO for HDMI-AUDIO and have changed VOLUME MODE to something other than OFF. When VOLUME MODE is anything but OFF it will assume AAC stereo 2 channel audio as the Roku reports different capabilities to the application. VOLUME MODE only works in stereo as it must work with both the TV or private listening (headphones in the remote). The pass-through feature will not work with private listening (headphones). You must already have your headphones plugged in so that we can detect properly that stereo must be used. If you plug in the headphones while Dolby is already playing we cannot detect the change during playback yet. This is coming in firmware 9.3x and we will be able to support that at that time. :)

 

If your HDMI-AUDIO setting is not AUTO and you have set it to DOLBY or some direct setting (DOLBY DOLBY+ DTS) this will override the HDMI chain detection. It is only when using AUTO that it depends on the HDMI chain of devices to detect pass-through support.

Edited by speechles
  • Like 2

Share this post


Link to post
Share on other sites
Bamit

ebr, I have the Roku Audio set to Auto.

 

speechles,  I am Speechless!!  That was it.  My Volume Mode was set to Level. Once I changed it to Off, it was fixed and my 5.1 works again. 

 

Thank you so very much!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...