Jump to content

Emby Theater CEC Port Settings


Recommended Posts

I'm having an issue whereby emby theater will switch the TV to HDMI port 1 when its launched and emby theater won't receive the CEC (pulse 8) input.
My understanding is that this is because the libCEC software rolled into emby theater is defaulted to HDMI 1 with no option to change (that I can find). A semi workaround is to launch libCEC tray before emby theater starts and set the correct port in the setting panel there (port 2 in my case) and then run theater. I say this is semi workaround because upon turning the TV/AVR off (not the PC) it reverts to being broken (thinking its on HDMI 1, from what I can tell). And I have to reboot and start again.
I'm running emby Theater 3.0.11 on Windows 10.
I'm unable to plug into HDMI 1 on my TV as it doesn't carry ARC sound.

I've tried uninstalling and reinstalling both emby and libCEC.


Is there anyway to change the default port libCEC in emby looks for, a config file or anything like that?


I don't have this issue with Plex or Kodi as they have the hdmi port setting in the apps.

Threads that have helped me so far;
Chap had the same issue, was able to set the correct setting in libCEC and it stuck; Link

Same again, and hints at plans to add the setting in future releases; Link


Thank you for any help.

Link to comment
Share on other sites

Hi, we'll add an option to the app to allow you to specify the hdmi port to set. Thanks for the feedback.

Link to comment
Share on other sites

The test build with the CEC selection works fine for me. Thank you and the team for adding this in so quickly, I'm very grateful.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...