Jump to content
schnappi

Remote server cannot cast to any devices

Recommended Posts

schnappi
Posted (edited)

Current Emby server setup in remote location behind nginx reverse proxy over HTTPS cannot cast to any devices. "Play on" menu is perpetually empty. "Enable DNLA Play To" is checked. User has max permissions. Locally installed server would list "My Device" but even this is not listed...

Edited by schnappi

Share this post


Link to post
Share on other sites
Happy2Play

DLNA can not broadcast outside its local network or you would be broadcasting to everyone on the internet.

Enable DLNA Play To
Emby can detect devices within your network and offer the ability to remote control them.

Share this post


Link to post
Share on other sites
schnappi

Understood. However, if I were to say login to NBC.com could cast a streaming TV show from web player to a chromecast...same situation.

Share this post


Link to post
Share on other sites
Luke

Chromecast is supported in this situation but not dlna devices at this time.

Share this post


Link to post
Share on other sites
pir8radio

Understood. However, if I were to say login to NBC.com could cast a streaming TV show from web player to a chromecast...same situation.

 

To be clear, chromecast should be working from emby.    DLNA has nothing to do with casting to chromecast.       Are you using any kind of CSP that you know of in your nginx config?  or advanced security settings?  

Share this post


Link to post
Share on other sites
schnappi

Checked and no nginx content security policies. Would posting the nginx configuration for emby be helpful to figuring this out?

Share this post


Link to post
Share on other sites
Luke

Sure.

Share this post


Link to post
Share on other sites
schnappi
Posted (edited)

 # Emby
        location /emby/ {
        proxy_pass http://127.0.0.1:8096;
        rewrite ^/emby(/.*)$ $1 break;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-for $proxy_add_x_forwarded_for;
        proxy_set_header Host $host;
        proxy_set_header X-Forwarded-Proto $remote_addr;
        proxy_set_header X-Forwarded-Protocol $scheme;
        proxy_redirect off;

        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";

        }

 

@@pir8radio

Edited by Luke

Share this post


Link to post
Share on other sites
pir8radio
Posted (edited)

 # Emby

        location /emby/ {

        proxy_pass http://127.0.0.1:8096;

        rewrite ^/emby(/.*)$ $1 break;

        proxy_set_header X-Real-IP $remote_addr;

        proxy_set_header X-Forwarded-for $proxy_add_x_forwarded_for;

        proxy_set_header Host $host;

        proxy_set_header X-Forwarded-Proto $remote_addr;

        proxy_set_header X-Forwarded-Protocol $scheme;

        proxy_redirect off;

 

        proxy_http_version 1.1;

        proxy_set_header Upgrade $http_upgrade;

        proxy_set_header Connection "upgrade";

        }

 

@@pir8radio

 

ahh you are using sub-directory.       I bet if you switch to sub domain it works  :-)       That will take some digging on your part to get to work, I would have to setup my server to do sub-directory and start searching for what is not loading to be able to help..   Sub directory reverse proxy often breaks stuff...      I recall other similar posts, I'll look for those.. But as far as I recall everyone of them switched to a sub domain setup.

 

Also are you running on a VM like a docker or container?   

What do your emby network settings look like?   the network settings that are shown in your emby server dashboard menu?     

 

Chromcast is "mostly" client side.

Edited by pir8radio

Share this post


Link to post
Share on other sites
schnappi

Interesting.

 

When login with the Jellyfin Android app can see "My Device" and a Roku in another location under the "Play On" drop down menu. When login with the Emby Android app or via Emby on any web browser (including Chrome) cannot see anything under the "Play On" drop down menu.

 

Also interesting. The Emby Android app is supposed to be limited to 1 minute playback (https://support.emby.media/support/solutions/articles/44001173099-emby-premiere-feature-matrix.) Not complaining, but the Emby Android app has no playback restrictions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...