Jump to content


Photo
- - - - -

Music Videos


  • Please log in to reply
23 replies to this topic

#1 Olynthus OFFLINE  

Olynthus

    Member

  • Members
  • 14 posts
  • Local time: 09:56 PM

Posted 27 March 2020 - 02:11 PM

Very annoying bug in that you can't delete unwanted music videos in the Emby GUI. It has to be done in file folders of windows. But even after that is done you still have residual graphics in the Emby GUI. What I'm I doing wrong?

#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 12:56 AM

Posted 27 March 2020 - 02:30 PM

Hi there, why do you feel that you can't delete them from the web interface?



#3 Olynthus OFFLINE  

Olynthus

    Member

  • Members
  • 14 posts
  • Local time: 09:56 PM

Posted 27 March 2020 - 02:55 PM

Because there is no option available to do so like there is in music, videos and all other media.

#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 12:56 AM

Posted 27 March 2020 - 02:59 PM

Did you ensure your emby user has permission to delete from that library?



#5 Olynthus OFFLINE  

Olynthus

    Member

  • Members
  • 14 posts
  • Local time: 09:56 PM

Posted 27 March 2020 - 03:09 PM

Yes, looks as though it is left over residual graphics I can't remove. Is there a way I can post photos to you? The other music videos do have the options to delete.

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 12:56 AM

Posted 27 March 2020 - 03:27 PM

Yes you can attach screenshots to your posting. Click the more reply options button next to post.



#7 Olynthus OFFLINE  

Olynthus

    Member

  • Members
  • 14 posts
  • Local time: 09:56 PM

Posted 27 March 2020 - 03:32 PM

See attached thanks

Attached Files



#8 Olynthus OFFLINE  

Olynthus

    Member

  • Members
  • 14 posts
  • Local time: 09:56 PM

Posted 27 March 2020 - 03:37 PM

I've tried refreshing but can't get these to go away. They are residual from video music that Emby labeled with the wrong information.

#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 12:56 AM

Posted 27 March 2020 - 03:56 PM

How did you try to refresh? 



#10 Olynthus OFFLINE  

Olynthus

    Member

  • Members
  • 14 posts
  • Local time: 09:56 PM

Posted 27 March 2020 - 04:07 PM

See attached

Attached Files



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 12:56 AM

Posted 27 March 2020 - 04:19 PM

Try just running a regular library scan.



#12 Olynthus OFFLINE  

Olynthus

    Member

  • Members
  • 14 posts
  • Local time: 09:56 PM

Posted 27 March 2020 - 04:56 PM

Tried that as well. This has been an issue for a long time and I ignored it till now.



#13 Peter Nent OFFLINE  

Peter Nent

    Advanced Member

  • Members
  • 43 posts
  • Local time: 06:56 AM
  • LocationVenlo, Netherlands

Posted 28 March 2020 - 02:18 PM

Same problem here: all other libraries work just fine, except music video's....I tried several times, but still a problem here also....

 

Editing > 400 music video files by hand is not an option anymore.... :huh:


Edited by PeterNent, 28 March 2020 - 02:19 PM.


#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 12:56 AM

Posted 28 March 2020 - 05:44 PM

Same problem here: all other libraries work just fine, except music video's....I tried several times, but still a problem here also....

 

Editing > 400 music video files by hand is not an option anymore.... :huh:

HI there, what does "same problem here" mean? What issue are you having?



#15 Peter Nent OFFLINE  

Peter Nent

    Advanced Member

  • Members
  • 43 posts
  • Local time: 06:56 AM
  • LocationVenlo, Netherlands

Posted 29 March 2020 - 01:42 PM

Dear Luke,

 

As long term & very satisfied Emby user, everything works fine, except the Music Video library metadata: in the past years, I've tested several setup, but it always ended by manually editing all approx. 400 musicvideos....a very anoying task.

It is my experience, that the metadata of IMVDB and TheMovieDb is disturbing matters.

 

I've tested several setups:

  • all files in one directory called MUSIC
  • all files in their 'own' artist directory (as instructed/documented in your documentation)
  • all files in their own subdirectory with the same name as the file
  • file names: <artist> - <album or concert> <(year)>.<extension>
  • within the artist directory, without the artist in de filename: file names: <album or concert> <(year)>.<extension>
  • enabling IMVDB and TheMovieDb
  • Using NO musicvideo type of library, but movies or another type of library

The 'final solution' until now seems to be, to edit the meta data by hand of all approx.400 files: artist, album or concert name, pictures setting by hand.....: thats the only way so far....

 

As I had a database issue several weeks ago, I had to setup the database again (stop Emby, move the library.db and start Emb again and scan all metadata again): after hours of waiting, everything worked nice and stable again, except the manually entered musicvideo library....

 

As I don't know how to copy the musicvideo data from the old library.db, I have to setup the musicvideo library again ....by hand ?

 

What I've noticed:

  • The artist is mostly not correctly detemined in the metadata, even if i've setup the directory correctly: all files in their 'own' artist directory (as instructed/documented in your documentation)
  • The name of the album or concert is mostly incorrect through the metadata supplier: IMVDB and TheMovieDb and thus the pictures are incorrect...

 

Possible solution:

I'm convinced that the metadata sources are mainly the source of these problems, together with the fact, that

  1. the artist is mostly not determined correctly: Emby issue ?
  2. The metadata of musicvideo is detemined incorrect, mayby other metadata suppliers ?
  3. OR accept another file determination method for musicvideo as well: file names= <artist> - <album or concert> <(year)>.<extension>

Could you have a look at it and solve my problem by correcting it in Emby, or otherwise give me suggestions how to solve this ?

 

 

Thanks & best regards,

Peter



#16 PenkethBoy ONLINE  

PenkethBoy

    Advanced Member

  • Members
  • 4291 posts
  • Local time: 05:56 AM
  • LocationWarrington,UK

Posted 29 March 2020 - 04:08 PM

Music videos do work - but you have to do a few things to help emby - make sure you have the library type as music videos

 

1. name your mv with songname.ext

2. add artist and albumartist metadata to the mv files

3. only use imvdb

4. i put my mv in an artist folder then each mv in its own sub folder named by the songname - not essential

 

then approx 40% to 60% will get matched to imvdb data

 

the rest you will manually have to find yourself and amend the imvdb id - or blank it out if imvdb does not have the mv listed

 

and turn on nfo saving for you mv library so any mods you make are saved outside the db - so next time you wont have to redo this again.



#17 Peter Nent OFFLINE  

Peter Nent

    Advanced Member

  • Members
  • 43 posts
  • Local time: 06:56 AM
  • LocationVenlo, Netherlands

Posted 05 April 2020 - 08:48 AM

Dear PenkethBoy,

 

First of all: many thanks for sharing your MV experience: it helped me understand the source of my problem more clearly, and I did following the past days:

  • STEP-1: setup a completely NEW Music Video library, using nfo (first time for me...), only IMVDB as metadata content provider, all pictures also in the MV direcorries, all my MV files already were organised as you advised: all files in their 'own' artist directory, file names: <artist> - <album or concert> <(year)>.<extension>, no automatic refresh from the internet set, 
  • STEP-2: run a automatic metadata via IMVDB: as I have many concerts recorded from TV, a have a fairly 'low' matching rate (approx.20-30%)
  • STEP-3: made an initial back-up by using FastCopy v3.86 of appox. 1.7TB of my MusicVideo files to a back-up 3TB HDD: works very fast and easy ! 
  • STEP-4: manually maintain the metadata of rest (approx.70-80% ALL approx.400)....tedious & time consuming work....)
  • STEP-5: manually add the pictures, looked up manually on the internet (sometimes IMBD, sometimes IMVDB, mostly Google....etc., again .... time consuming work)
  • STEP-6: made a delta back-up by using the same FastCopy tool: it then 'only' had to back-up the files added of changed during this time-consuming process....

During looking up my MV files manually at IMDB of IMVDB, etc, it became clear that many of my MV files are simply not know (jet) there.....Google became 'my best friend, as it always found what I needed!

 

During the Emby automatic metadata scans at IMVDB of my MV library, Emby probably didn't look to the 'special' MV directory structure (as per artist a seperate directory as instructed) to find the artist.....the artist was almost always wrong.....(@Luke?)

 

The automatic metadata scan & pictures at IMVDB were OK forr approx. 20-30% of my MV-library, the approx. 70-80% had to done manually: everything is perfect now.....

 

@Luke: this suggests that the artist name is not comming from the directory structure: can you fix this ?

@Luke: after manual search of IMVDB, IMDB, MusicBrainz, etc.: it became clear to me, that IMDB had a much higher hit rate then IMVDB, although IMDB cannot be set in the MV-library etup within EMBY: why not ? The metadata of musicvideo is detemined incorrect, mayby other metadata suppliers ? OR accept another file determination method for musicvideo as well: file names= <artist> - <album or concert> <(year)>.<extension>...or...?

 

Sofar my experiences of setting up the MusicVideo library again....a lot of work, but with great succes !

 

 

Thanks & best regards,

Peter


Edited by Peter Nent, 05 April 2020 - 09:05 AM.


#18 PenkethBoy ONLINE  

PenkethBoy

    Advanced Member

  • Members
  • 4291 posts
  • Local time: 05:56 AM
  • LocationWarrington,UK

Posted 05 April 2020 - 10:01 AM

i think i was not clear

 

"1. name your mv with songname.ext"

 

i.e. <song name>.ext - not <artist> - <songname>.ext

 

year is fine

 

get a better hit rate on imvdb that way - as you have artist name as folder name anyway

 

But you are done now :)



#19 PenkethBoy ONLINE  

PenkethBoy

    Advanced Member

  • Members
  • 4291 posts
  • Local time: 05:56 AM
  • LocationWarrington,UK

Posted 05 April 2020 - 10:03 AM

As for images - i created my own via ffmpeg and extracting images from the video and picking the best



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156731 posts
  • Local time: 12:56 AM

Posted 05 April 2020 - 01:07 PM

We don't try and parse the artist name from the folder or filename.

It either has to be embedded metadata in the file or specified in the metadata editor.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users