Jump to content

Connectivity port forwarding


hiepvu
 Share

Recommended Posts

Hi there

 

I've been searching the forums and can't seem to find the correct solution for my issue. 

 

I can't connect remotely to my server but I can connect locally. I am assuming that my port needs to be forwarded as when I check canyouseeme I can't see the port 8096.

 

I am on a Mac with a TPlink router. 

 

When I log on to my router I go 'Forwarding' + 'Virtual Servers' +'Add new"

 

I see spaces for 'Service port' 'Internal port' 'IP address' 'Protocol' 'Status' and a drop down for 'Common Service Port'

Service port - 8096

Internal port -blank

IP address - 192.168.1.xxx (the address on the front page of my emby server)

protocol - all

status - enabled

common service port - blank

 

When I use these settings I can't connect remotely and get a 'connection failure' error.

 

Can someone help me with what I may be doing wrong in the setup of port forwarding or anything else I may be doing wrong?

I have ticked 'allow remote connection on this server' in emby settings. All other settings I've left default. 

I am using Little Snitch connection app to control IO on my mac but have emby set to allow all incoming and outgoing connections.

I have no issues connecting to Plex remotely.

 

Thanks for any help. 

 

 

Link to comment
Share on other sites

Hi there


 


I've been searching the forums and can't seem to find the correct solution for my issue. 


 


I can't connect remotely to my server but I can connect locally. I am assuming that my port needs to be forwarded as when I check canyouseeme I can't see the port 8096.


 


I am on a Mac with a TPlink router on top of a Hitron cable modem.


 


When I log on to my router I go 'Forwarding' + 'Virtual Servers' +'Add new"


 


I see spaces for 'Service port' 'Internal port' 'IP address' 'Protocol' 'Status' and a drop down for 'Common Service Port'


Service port - 8096


Internal port -blank


IP address - 192.168.1.xxx (the address on the front page of my emby server)


protocol - all


status - enabled


common service port - blank


 


When I use these settings I can't connect remotely and get a 'connection failure' error.


 


Can someone help me with what I may be doing wrong in the setup of port forwarding or anything else I may be doing wrong?


I have ticked 'allow remote connection on this server' in emby settings. All other settings I've left default. 


I am using Little Snitch connection app to control IO on my mac but have emby set to allow all incoming and outgoing connections.


I have no issues connecting to Plex remotely.


 


Thanks for any help. 


 


UPDATED: I port forwarded the modem and I can now see port 8096 on canyouseeme.org but still no connection to my Mac server. 


I installed emby server on a PC connected directly to my modem and I can connect remotely to that.


It appears I can't get through my router even with port forwarded (hopefully) and all security off.


 


Link to comment
Share on other sites

Happy2Play

 

Hi there

 

I've been searching the forums and can't seem to find the correct solution for my issue. 

 

I can't connect remotely to my server but I can connect locally. I am assuming that my port needs to be forwarded as when I check canyouseeme I can't see the port 8096.

 

I am on a Mac with a TPlink router on top of a Hitron cable modem.

 

When I log on to my router I go 'Forwarding' + 'Virtual Servers' +'Add new"

 

I see spaces for 'Service port' 'Internal port' 'IP address' 'Protocol' 'Status' and a drop down for 'Common Service Port'

Service port - 8096

Internal port -blank

IP address - 192.168.1.xxx (the address on the front page of my emby server)

protocol - all

status - enabled

common service port - blank

 

When I use these settings I can't connect remotely and get a 'connection failure' error.

 

Can someone help me with what I may be doing wrong in the setup of port forwarding or anything else I may be doing wrong?

I have ticked 'allow remote connection on this server' in emby settings. All other settings I've left default. 

I am using Little Snitch connection app to control IO on my mac but have emby set to allow all incoming and outgoing connections.

I have no issues connecting to Plex remotely.

 

Thanks for any help. 

 

UPDATED: I port forwarded the modem and I can now see port 8096 on canyouseeme.org but still no connection to my Mac server. 

I installed emby server on a PC connected directly to my modem and I can connect remotely to that.

It appears I can't get through my router even with port forwarded (hopefully) and all security off.

 

So you have a double nat situation.

 

Forward your modem to your router and your router to your PC

Link to comment
Share on other sites

Hi

thanks for your reply. Can you be a bit more clear as to how to do this or what to do where?

Since I can see the port 8096 on canyouseeme.org, doesn't that mean the port is open for emby?

 

So when you say forward my modem to my router, which port should I forward to which IP address? And the same with router to PC?

Which one should forward 8096? 

Thanks for any help since this does not seem to be clearly laid out in any posts i've seen so far and must be very frustrating to others who are in the same situation.

Especially since from what I've seen, most people who have this issue have their Plex server running fine.

Link to comment
Share on other sites

Happy2Play

Hi

thanks for your reply. Can you be a bit more clear as to how to do this or what to do where?

Since I can see the port 8096 on canyouseeme.org, doesn't that mean the port is open for emby?

 

So when you say forward my modem to my router, which port should I forward to which IP address? And the same with router to PC?

Which one should forward 8096? 

Thanks for any help since this does not seem to be clearly laid out in any posts i've seen so far and must be very frustrating to others who are in the same situation.

Especially since from what I've seen, most people who have this issue have their Plex server running fine.

I would assume the other guys are using UPNP (port mapping).  Emby has port mapper if enabled in Emby and all hardware, should work.   I personally disable this as I want control of what apps are doing.

 

But the modem you would forward port 8096 to your router address ie 192.168.0.1. then your router 8096 to your computer ip (192.168.0.x).

Link to comment
Share on other sites

Ok thanks I will try that. 

One question I was wondering was, I do see on my router that Plex is using UPnP to do the port mapping as well as Jellyfin, but even when I click Emby port mapping that it does not show up and does not work. Since the functionality is also not there, is there some way that I can try to get that working? Was there something in the install/setup of Emby that I should have done to enable UPnP?

Link to comment
Share on other sites

Happy2Play

Ok thanks I will try that. 

One question I was wondering was, I do see on my router that Plex is using UPnP to do the port mapping as well as Jellyfin, but even when I click Emby port mapping that it does not show up and does not work. Since the functionality is also not there, is there some way that I can try to get that working? Was there something in the install/setup of Emby that I should have done to enable UPnP?

I would assume you have the Emby Port Mapper plugin installed and enabled via Dashboard-Network "Enable automatic port mapping", not sure is sure need restarting when enabling/disabling this option.

Link to comment
Share on other sites

I tried putting the modem in bridge mode and that did not solve the problem. I can still see the port in canyouseeme.org but no connection.

I still can't see Emby in the UPnP tab in my router. I've restarted Emby. The 'enable automatic port mapping' box is checked. This would solve alot of my problems I think if I could get it to work.

This is so frustrating since the 'other' app just works with no hassle.

I don't know if my dynamic ip has anything to do with it. I don't want to have to go the No-IP DuckDNS route. 

I might just give up even though I paid for Premiere subscription

Link to comment
Share on other sites

pwhodges

UPnP is only automating a setting which you can make manually in the router yourself - this hardly seems a reason to give up on Emby.

 

But aside from that, you mentioned Jellyfin.  If you have that running, by default it also uses port 8096, so perhaps it's taken control of that setting first.  But perhaps the mention of Jellyfin was a red herring.

 

Paul

Link to comment
Share on other sites

I will try to continue to work on this but the difference in ease of setup between the 2 programs is perplexing.

I've removed Jellyfin and it was not showing up anymore on the UPnP tab on my router. 

I had tried bridging the modem to no effect. I think it might come down to the dynamic IP. 

The Emby automatic port mapping does not seem to do anything. 

Is there someway to fire up UPnP on Emby? Does Emby even support UPnP. That seems to be the thing that is making Plex work through the 2 routers.

I can't really see any other way to handle the double nat right now except the no-ip and duckdns way. 

Have I missed anything else I can try?

Link to comment
Share on other sites

When I'm trying to forward the port of my modem to my router, should I use the IP address of the WAN of the router? 

I am currently using the WAN of my router as the IP address forwarding from my modem (port 8096) 

then I am forwarding the router (port 8096) to the IP address on the Emby Dashboard (LAN).

This set up is not working, so was wondering what might be wrong

Link to comment
Share on other sites

Happy2Play

When I'm trying to forward the port of my modem to my router, should I use the IP address of the WAN of the router? 

I am currently using the WAN of my router as the IP address forwarding from my modem (port 8096) 

then I am forwarding the router (port 8096) to the IP address on the Emby Dashboard (LAN).

This set up is not working, so was wondering what might be wrong

No you forward 8096 from your modem to your router ip usually x.x.x.1 

Link to comment
Share on other sites

So when I try to forward port 8096 from my modem to my router ip xxx.xxx.x.1 (the LAN ip address of the router) I get this error. The modem is a Hitron CGA3 and the router a TPlink C7.

'Local IP isn't in LAN IP address subnet'. 

I can't initiate the port forward due to this error.

 

Any ideas?

Link to comment
Share on other sites

pwhodges

Tell us the actual IP addresses and subnet mask of each of the devices, and we can work from there.

 

Paul

Edited by pwhodges
  • Like 1
Link to comment
Share on other sites

Happy2Play

So you would forward 8096 on Modem to 192.168.0.10, the 8096 on Router to your PC ip 192.168.1.x.

Edited by Happy2Play
Link to comment
Share on other sites

pwhodges

Right, presumably the output from the modem is cabled to the WAN port of the wifi router, so you then need to forward your chosen incoming port from the modem to 192.168.0.10, port 8096.  You then need in the wifi router to forward incoming port 8096 to the IP address of your Emby server 192.168.1.xxx, also port 8096.  If the router has a separate firewall setup, you may need to ensure that the port is allowed through.

 

Paul

Link to comment
Share on other sites

I've had it this way all along. 

Modem port forward 8096 to 192.168.0.10 on router

Router port forward 8096 to 192.168.1.xxx (emby server IP)

I've tried with router firewall off and on. 

Still no remote connection.

I can see port 8096 on canyouseeme.org

I can connect on the local network with wifi on.

 

Any other ideas?

Link to comment
Share on other sites

Ok I have managed to connect remotely by manually adding WAN server IP to the signin dashboard. Not sure why the Emby connect was not connecting to the server. 

Kinda have no idea which of these solutions did the trick but if this will work then I will continue with this. I will test all my other remote network devices and see if it will work.

 

thanks to all for your help and I look forward to getting the most out of Emby.

 

PS. was wondering, I just noticed that a Teredo entry has appeared in my UPnP settings. Is this something I should be concerned about and what app might be using it? @@cayars @@Happy2Play

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...