Jump to content

New Plugin: Discord Notifications


rechigo

Recommended Posts

Did the French Canadian translation, which should be mostly interchangeable with just a regular French translation if there isn't one.

 

Yeah, once the base language is complete I'll probably just merge it with the other dialects and people can make changes to them when fit

 

Thanks for the contributions guys!

Link to comment
Share on other sites

One of my goals here is to make sure everyone is able to use this plugin, to do that we need translations

 

I have opened up a onesky board for translations here: https://emby-discord-notifications.oneskyapp.com/

It is open for the public, all you have to do is create an account and start translating!

 

I would appreciate it if you guys could help translate it into your language. There are about 16 strings that need to be localized. If you see any incorrect strings, feel free to correct them.

 

Let me know if there are any issues, thanks!

 

I mean @@ebr that is devotion to the plugin...   lol     I'm trying for you rechigo....... 

  • Like 1
Link to comment
Share on other sites

what is this "rich media" you speak of?

 

 

 

  • Added option to hide any trace leading to your remote server address (for people who for whatever reason want to hide their actual server address)

 

Does this feature remove the images all together?    seems like it does for me.

Edited by pir8radio
Link to comment
Share on other sites

what is this "rich media" you speak of?

 

 

 

  • Added option to hide any trace leading to your remote server address (for people who for whatever reason want to hide their actual server address)

 

Does this feature remove the images all together?    seems like it does for me.

 

It removes images that are served locally, if the images come from an external source it should just use the fanart or tmdb URL (in my testing it always provides the external links)

 

Did you manually add artwork or was it downloaded from a source like fanart or tvdb

 

eq1.png

Edited by rechigo
Link to comment
Share on other sites

It removes images that are served locally, if the images come from an external source it should just use the fanart or tmdb URL (in my testing it always provides the external links)

 

Did you manually add artwork or was it downloaded from a source like fanart or tvdb

 

eq1.png

 

came from the movie db that emby uses for metadata..    none of my movies were showing pictures so i disabled that and pictures started showing up again...

 

I have another question, ive been seeing alerts every time i record a show...   But i created a "discord" user in emby and he only has access to my movie library.    Why would emby send him alerts for libraries he doesnt have access to?

Link to comment
Share on other sites

came from the movie db that emby uses for metadata..    none of my movies were showing pictures so i disabled that and pictures started showing up again...

 

I thought I tested this scenario but I guess I didn't test it thoroughly enough.

 

Question: Do you have "Download images in advanced" enabled in your library settings? I think we will have the answer after you answer that.

 

 

I have another question, ive been seeing alerts every time i record a show...   But i created a "discord" user in emby and he only has access to my movie library.    Why would emby send him alerts for libraries he doesnt have access to?

 

Right now, the media added notification listen in on the MediaAdded event which isn't tied to any user, so it will send a notification regardless if the user has access to that library.. I will look into this before the next update.

Link to comment
Share on other sites

I thought I tested this scenario but I guess I didn't test it thoroughly enough.

 

Question: Do you have "Download images in advanced" enabled in your library settings? I think we will have the answer after you answer that.

 

 

 

Right now, the media added notification listen in on the MediaAdded event which isn't tied to any user, so it will send a notification regardless if the user has access to that library.. I will look into this before the next update.

 

 

5e86967576e6d_Screenshotfrom202004022050

Link to comment
Share on other sites

5e86967576e6d_Screenshotfrom202004022050

 

Ok yea that is why

 

If an image is found, but hasn't been downloaded yet Emby populates the paths to the image with the remote URL (tmdb, fanart). Once the images are downloaded though, the paths to the images are replaced with the path to the local image downloaded on the filesystem. I'll try to find a way to always use the remote URL from image fetchers even if the artwork has already been downloaded

 

note so i dont forget: I need to create translations for the SERVERSIDE of the plugin (specifically, the custom media added notification

The Emby string "ValueHasBeenAddedToLibrary"should (hopefully) integrate perfectly

Edited by rechigo
Link to comment
Share on other sites

Is it possible to get the picture to show for playing and stop events to.

Not showing for me, or is it a bug.

Link to comment
Share on other sites

Is it possible to get the picture to show for playing and stop events to.

Not showing for me, or is it a bug.

 

Right now, no, since the plugin (besides the media added notification) is still using Emby's notification system which doesn't give that much information, but it's possible for the future.

Link to comment
Share on other sites

Hi there, I am using 4.5.0.5 beta and this plugin seems to crash Emby. When I scan my movie library it stops at 94%. From that moment I need to kill the program to use it again.

Link to comment
Share on other sites

Hi there, I am using 4.5.0.5 beta and this plugin seems to crash Emby. When I scan my movie library it stops at 94%. From that moment I need to kill the program to use it again.

Do you have a log from when this happened?

 

Sent from my SM-G973U using Tapatalk

Link to comment
Share on other sites

hey rechigo, I have checked the embyserver log. It seems nothing is there during the time the server crashed. The crash happened just before I had posted about it here. And the log stops 2 mins before that incident. I can try to reproduce it in the morning (this time with debug logging enabled) as now the server is actively used. 

 

EDIT: What I see now is that from notification settings 'new content added' notification is not enabled. Maybe this could cause the crash? Anyway will verify this as well tomorrow :)

Edited by RobinM
Link to comment
Share on other sites

Couple of questions:

 

Does the server crash even if you click "scan library" and you haven't added any items to the library? Or does it only crash when you click scan library and there are new items being added in?

 

Do library scans crash the server if the plugin is uninstalled?

 

If it doesn't crash when it's uninstalled, try installing an older release (prior to 1.0.4.2 ) and see if it still results in crashes

 

I'm working on switching how the plugin handles a couple things internally due to another issue I discovered which I believe is related to this

Edited by rechigo
Link to comment
Share on other sites

What i found so far is that it only crashes when there is new media.

 

I have deleted the plugin and installed older version 1.0.3.2. With this version it doesn't crash and the notification gets send!

Link to comment
Share on other sites

I am able to recreate this now, seems like something that was introduced in 0.5. I narrowed down what is causing this. The issue doesn't seem to occur in the 4.5.0.4 beta, so I'll take a look in a little bit at what might be wrong

 

This looks to stem from IServerApplicationHost, testing the affected method with a boilerplate plugin to narrow down the problem

 

OK, Luke is looking into this. Now, we wait....

Edited by rechigo
Link to comment
Share on other sites

let us know when you come up with a fix...   I use your plugin daily lol so im holding off on upgrading emby.

Link to comment
Share on other sites

Hi rechigo, thank you for looking into it. Please let me know how I can give you a small token of appreciation!

 

@@RobinM You can leave a like on the original post and/or star the GitHub repository

Link to comment
Share on other sites

So if i read your release correctly...   if i update to 4.5.0.5  I will loose the attached images in the alerts?

Link to comment
Share on other sites

So if i read your release correctly...   if i update to 4.5.0.5  I will loose the attached images in the alerts?

 

Yes, the only option would be to use Emby's built in notification system for when media is added

 

Once Luke fixes it you can just reenable the media added override and everything will work again, I will update the thread when that happens

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...