Jump to content

Emby does not show USB DISK on Raspberry Pi


qbranchltd@gmail.com

Recommended Posts

qbranchltd@gmail.com

I have just installed Buster on My RaspPi.  I have a movie folder on a USB flash drive plugged into the Pi. The drive shows on the file manager as pi/media/USB DISK - and opening that the folder is there - "movies". When I try to add that folder I can get to pi/media - and no further. I manually wrote this in and it cannot be found. I really don't know what to do at this point. How do I direct Emby to find that folder with my movies in it. (If this worked my plan was to put a larger usb drive on the Pi to hold more movies.) Any and all help is appreciated.

 

Thanks.

Link to post
Share on other sites
qbranchltd@gmail.com

Hi there, did you check the permissions of the folder by following this:

https://emby.media/community/index.php?/topic/32218-file-permissions-guide-for-new-linux-users/

  I followed this exactly - same response each time - bash: setfacl: command not found

 

????????

 

Tried same starting with sudo -  same response - setfacl command not found.

 

How can this be? 

 

Rasbian Buster - newest Raspbian OS version - and what was recommended to use to have with emby server. 

Link to post
Share on other sites
qbranchltd@gmail.com

I just found out that setfacl has to be added through a package called acl - am doing that now.

 

 

We shall see. Thanks.

 

No - now says " setfacl: Option -m: Invalid argument near character 1

 

this followed this command

 

settfacl -m user.emby.rxw /home/media/pi

 

????

 

@@mastrmind11

Edited by Luke
Link to post
Share on other sites
mastrmind11

what is the output of 

ls -l /home/media

 and 

ls -l /home/media/pi
Link to post
Share on other sites
qbranchltd@gmail.com

 

what is the output of 

ls -l /home/media

 and 

ls -l /home/media/pi

Thanks @@mastrmind11. In the process of trying a suggestion to move the USB Disk to another location on Raspbian I crashed the entire OS and I am in the process of reinstalling. So I am starting all over again.  Thanks for your help. I even copied the path of my USB Drive Movies folder and pasted it into Emby where it adds folders and it still would not find the drive.  I know that Emby works as I moved a movie file to the home folder and added that as a movies folder and the movie played on my Roku.   One thing I find is that Linux is just too machine level to be manageable and I learned programming back in 1973 on a mainframe. I will try again once I get Rasbian Buster reinstalled.  Again thanks.

Link to post
Share on other sites
qbranchltd@gmail.com

Thanks @@mastrmind11. In the process of trying a suggestion to move the USB Disk to another location on Raspbian I crashed the entire OS and I am in the process of reinstalling. So I am starting all over again.  Thanks for your help. I even copied the path of my USB Drive Movies folder and pasted it into Emby where it adds folders and it still would not find the drive.  I know that Emby works as I moved a movie file to the home folder and added that as a movies folder and the movie played on my Roku.   One thing I find is that Linux is just too machine level to be manageable and I learned programming back in 1973 on a mainframe. I will try again once I get Rasbian Buster reinstalled.  Again thanks.

I reinstalled Raspbian Buster. I have not yet put Emby on this install but I tried your two commands above -  both come up no folder. I opened File Manager and opened the movies folder on the "USB DISK" - which is what Rasbian has named it. This is the path - /media/pi/USB DISK/movies. The result of ls -1 and this path is "ls: cannot access 'media/pi/USB' : No such file or directory. AND this - "ls: cannot access 'Disk/movies': No such file or directory.

 

On my first install I tried renaming the USB DISK to something else - like just "usb" but it would not allow me to do that in the File Manager.  And trying to move the location was a disaster resulting the in being unable to start Rasbian at all again.

 

Very frustrating. I will reinstall Emby now on the Pi and I am sure there will be nothing different from before.

Link to post
Share on other sites
qbranchltd@gmail.com

I changed the name of the USB Drive - using win 7 to USB instead of USB DISK, thinking that the two word name was causing a problem. The new path is now /media/pi/USB/movies. Using ls the results show the contents of the movies folder - so it exists.  I ran this through emby to add a movies library and got the same  - path does not exist. There is a message at the top of the screen about granting permissions - and I found this command line to add universal permissions to all folders and files -

sudo chmod -R ugo+rw /media/pi/USB/movies

I ran that and it came back with the prompt so it went in.

 

I again tried to add the folder to the library in emby and the same results occured - no such path - grant permissions.

 

I tried again using chmod but this time dropped off movies from the end - still no go on emby.

 

I then went to your recommendation of the post using setfacl - and that again returns this error -

setfacl: Option -m: Invalid argument near character 1

 

Should all of this be this hard?  Surely I can't be the only one trying to use a usb flash drive with media files on the RaspPi with Emby.  If the media files  folder is in the home/ folder the library is created and the file in the folder plays and is streamed to Roku. It is the usb stick that will not be found on the emby list of file folder locations. The usb stick is formatted as FAT32. It was formatted on Win 7 - I could reformat on the Pi but then I will have to bring the usb drive to Win 7 to load the movie files onto the drive.




			
		
Link to post
Share on other sites
Luke

 

 

Should all of this be this hard?

 

Who is making it hard? Emby Server runs under a system user on your machine called emby (which is created during the install process). Therefore whatever folders you wish to add to Emby server, the emby system user will need permissions for.

Link to post
Share on other sites
qbranchltd@gmail.com

Who is making it hard? Emby Server runs under a system user on your machine called emby (which is created during the install process). Therefore whatever folders you wish to add to Emby server, the emby system user will need permissions for.

@@JaScoMa

And that is what I have been struggling to do and so far nothing I have found or has been suggested works.  If I could even see the usb in the folders listing through emby add folder, at least I would know that something is progressing but as far as emby sees it does not exist - and anything I have tried to grant emby permission so far has not worked.  Can I assume that since Emby can find video files in a folder on /home that emby created a system user called emby?  The step by step for stepfacl in the first link suggested here comes back with the same error - there is a problem with the -m and some invalid argument for character 1 (and I have no idea what "character 1" means - and searching for that has not come up with anything related. I had emby working on a Win10 laptop but I can't keep that laptop running as a media server. I have the RaspPi and would like to get it working on there.

 

I just found out how to find system users and emby is there - last one on the list. Not that this helps but it is installed and there.

 

I really appreciate your help.  And thank you!

Link to post
Share on other sites
mastrmind11

Post the results of ls -l for whatever the folder is now called.

 

The problem with using a GUI file manager on Linux is that it treats USB mounts differently (permission wise) than it would if there were no GUI installed.  I think that's where your problems are coming from.  I would suggest mounting your USB drive manually from the command line and forget trying to manage it with the file manager.  Try this link, and once you have it mounted the right way, lets see if we can get your permissions correct.

 

https://www.raspberrypi-spy.co.uk/2014/05/how-to-mount-a-usb-flash-disk-on-the-raspberry-pi/

Link to post
Share on other sites
qbranchltd@gmail.com

Post the results of ls -l for whatever the folder is now called.

 

The problem with using a GUI file manager on Linux is that it treats USB mounts differently (permission wise) than it would if there were no GUI installed.  I think that's where your problems are coming from.  I would suggest mounting your USB drive manually from the command line and forget trying to manage it with the file manager.  Try this link, and once you have it mounted the right way, lets see if we can get your permissions correct.

 

https://www.raspberrypi-spy.co.uk/2014/05/how-to-mount-a-usb-flash-disk-on-the-raspberry-pi/

I followed the instructions on the page linked exactly and got as far as mounting the USB - using all command lines exactly as shown - result of mount command is "mount: /media/usb: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.

 

I unmounted the USB drive before doing this command line. umount worked.  When I plug the USB drive into the RaspPi it automatically mounts it to the original location.  So I umount ed with the command line and it unmounted. Then this when mounting it with the command line specified.  ????

 

UPDATE - rebooted Pi - auto mounted USB to old location. Ran command line to mount above and it worked. Now there is only one usb folder and it is the new location. Will finish the commands on the linked page and then try to get it on Emby.

Edited by qbranchltd@gmail.com
Link to post
Share on other sites
qbranchltd@gmail.com

IT WORKED!

 

Thanks so much for this!

 

Greatly appreciate everyone's efforts to get this working!

 

Again, many thanks!

  • Like 2
Link to post
Share on other sites
qbranchltd@gmail.com

Oh well - tried to use another USB drive formatted in NTFS - went through the whole process again - the drive after several attempts using all the steps in mounting the usb through the command line finally worked and was found by Emby and loaded into the library.  After writing what should have been the correct automount line into fstab - Raspbian crashed on reboot again.  ntfs-g is supported in Buster. I am back to re-writing an SD card with Buster - and starting all over again. Everything was working fine with the original USB - but it was too limiting in video file sizes.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...