Jump to content

I'm not getting HW transcoding with my J4105 NUC


nmkaufman
 Share

Go to solution Solved by softworkz,

Recommended Posts

nmkaufman

I did some testing today, and I'm not getting HW transcoding with my J4105 NUC, either. It has DX12 capable UHD 600 on the die.

 

I'd been writing it off for months as having to do with me not having a monitor attached, but I hooked up a monitor, mouse and keyboard, and it's still not working.

 

I'll backtrack for instructions, and upload logs.

Link to comment
Share on other sites

nmkaufman

I was about to try installing the beta, but I'm using a Windows portable install (x64) and don't know where to find a link.

 

The installer won't do.

 

 

Found it. Trying now.

Edited by nmkaufman
Link to comment
Share on other sites

nmkaufman

4.4.0.10 fixed it for me, and that hardware transcode is good stuff. Transcoded a 7 minute 1080P video to 360P in ~30 seconds.

 

Suspicions are confirmed that a monitor needs to be connected, and a local user session may even need to be logged in.

 

Is there a way for me to test whether or not it's working without logging into the machine? I'd be curious to know if it's working when running as a service, after a fresh reboot.

 

If there's a way to test that, I'll see if you even need a monitor plugged in, or if it's truly just RDP that breaks it.

Link to comment
Share on other sites

Happy2Play

4.4.0.10 fixed it for me, and that hardware transcode is good stuff. Transcoded a 7 minute 1080P video to 360P in ~30 seconds.

 

Suspicions are confirmed that a monitor needs to be connected, and a local user session may even need to be logged in.

 

Is there a way for me to test whether or not it's working without logging into the machine? I'd be curious to know if it's working when running as a service, after a fresh reboot.

 

If there's a way to test that, I'll see if you even need a monitor plugged in, or if it's truly just RDP that breaks it.

All you can do is test those variables.

 

Restart Emby and perform tests without a monitor connected, and don't have a RDP session.

 

You may have to set HWA to Advanced and only select the specific decoders and encoders that that work in your setup.

  • Like 2
Link to comment
Share on other sites

4.4.0.10 fixed it for me, and that hardware transcode is good stuff. Transcoded a 7 minute 1080P video to 360P in ~30 seconds.

 

Suspicions are confirmed that a monitor needs to be connected, and a local user session may even need to be logged in.

 

Is there a way for me to test whether or not it's working without logging into the machine? I'd be curious to know if it's working when running as a service, after a fresh reboot.

 

If there's a way to test that, I'll see if you even need a monitor plugged in, or if it's truly just RDP that breaks it.

 

It's not always that RDP breaks it. We haven't found out under which conditions that happens.

 

D3D11 hardware acceleration should normally work always without a display, without a logged-in user and inside a service.

  • Like 1
Link to comment
Share on other sites

nmkaufman

I'll play around with it tomorrow, if I get a chance.

 

For now, I'm pretty content knowing I can get it working if I need it.

  • Like 1
Link to comment
Share on other sites

nmkaufman

I've determined that (with my setup, at least) no monitor is required.

 

I can log into the box with Google Remote Desktop without breaking quicksync transcoding.

 

Logging into the machine with RDP breaks quicksync until I log back in, either locally or with Google Remote Desktop (which emulates a local user.)

 

Nvidia users will want to do their own testing, because on my desktop machine I absolutely need a monitor connected in order to use the Nvidia Hardware (for Gamestream.)

 

The NVENC transcoding may still work, without a monitor, but I have no plans to test it at this time.

Edited by nmkaufman
Link to comment
Share on other sites

  • Solution

For Nvidia hw acceleration, there's no connected display required. Never. And with no exceptions.

(Gamestream is probably a different story)

 

For QuickSync: The D3D11 variants don't need a display, neither a user session and they work from inside a Windows service. For the 'normal' QuickSync variants, the opposite is true.

 

 

For RDP, there's something you could try:

 

Open Group Policy Editor > Local Computer Policy and navigate in the tree as you can see in the title bar:

 

5e338a84ef161_rdp_policy.jpg

 

 

Go through all settings about "hardware" and "RemoteFX" and disable everything that seems to be related to hardware acceleration.

 

Reboot.

 

Let us know if that makes a change!

  • Like 2
Link to comment
Share on other sites

nmkaufman

Nice! That worked.

 

All I had to disable is the option you have highlighted in your post, and transcoding no longer breaks while / after signing into an RDP session.

 

No reboot even required.

Link to comment
Share on other sites

Nice! That worked.

 

All I had to disable is the option you have highlighted in your post, and transcoding no longer breaks while / after signing into an RDP session.

 

No reboot even required.

So you set the option highlighted above to DISABLED and it worked for you?

Link to comment
Share on other sites

nmkaufman

Correct, I disabled using the graphics card for hosting RDP sessions, and it no longer breaks HW transcoding / Quicksync.

 

It might make hosting an RDP session more taxing on the CPU, if that's a concern.

Link to comment
Share on other sites

Thanks for the feedback nmkaufman.

I've update the hardware acceleration page for windows article with this information on connected monitors.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...