Jump to content

Connection refused - TS-251 setup


ngranger
Go to solution Solved by ngranger,

Recommended Posts

Ive searched a bunch and cant seem to figure out what im doing wrong.... 

 

background:

I have a TS-251, firmware 4.4.1.1146

I downloaded the emby-server-qnap_4.3.0.30_x86_64 file as directed and everything installed ok.

I started the setup and it took me to the setup screen for emby

i picked my language, but then had to go do a few things. by the time came back my laptop had gone to sleep and i lost the connection in the web browser. 

now i keep getting the "site cant be reached" ERR_CONNECTION_REFUSED error when i try to go back to do the setup. 

 

I have tried removing emby from my qnap, restarted the NAS, reinstalling the emby app multiple times. 

 

Im not sure what to do now. I also have installed linux so i can access the file system on the NAS, since i have zero experience with ssh. 

I also have very little knowledge of networking so i pretty much need instructions on setting up that stuff up. (i enabled the web server and sql server, pretty sure thats required to make this work?)

 

any help is much appreciated!

Thanks

Nick

Link to post
Share on other sites
slangwanger

Hi, is it possible to post logs so someone more knowledgeable than myself can help you.

if you have use of a windows you could try using winscp to retrieve the log files

5df45c8aad837_22Untitled.jpg

 

and then navigate to

5df460d70fefb_23Untitled.jpg

i hope this helps

Link to post
Share on other sites

can i attach .txt files here somehow? i cant seem to figure it out, and the log file is pretty long so i didnt want to copy/paste if i didnt have to.

 

Thanks

Nick

Link to post
Share on other sites

It appears to be starting successfully. Is the emby server application still running when you get the connection refused error?

Link to post
Share on other sites
Happy2Play

the address is http://yourip:8096/

 

and the emby server shows up as enabled under qboost

Are you saying local connect is not working either? LANIP:8096

 

 

Have you verified a site like canyouseeme.org shows your ports open?  As I currently can not see the port open.

 

Have you checked the Connectivity wiki?

 

https://github.com/MediaBrowser/Wiki/wiki/Connectivity#external-connections

Edited by Happy2Play
Link to post
Share on other sites

thanks for the replies

this is where my knowledge gets dicey... i dont know much at all about networking and such. 

 

I tried the page you referenced, put the NAS IP in, and port 8096 and it timed out. 

 

I dont know what the diff is between the wan/lan IP is or how to change what im using. 

 

I will take some time to look through the connectivity wiki you referenced and see if theres anything that i can figure out. 

 

Thanks again guys

Nick 

Link to post
Share on other sites

Morning guys. 

 

I access my NAS interface (QTS desktop) from the web browser via an IP:8080 address which is shown as my WAN IP when i look at the network & virtual switch control panel window. i log into myqnapcloud website to access the NAS so that might be why its using the WANIP? 

 

Sounds like i need to try accessing it using the IP address shown under system status (which i assume is the LAN IP). and i will do this later tonight and let you know if it worked. I cant use the qfinder on my computer cause its a work computer and they limit what i can install on it. (my home PC was destroyed in a flood recently and i havent replaced it) 

 

sorry for my arrogance here im dumb when it comes to this stuff, i really appreciate your help!

 

Nick

Link to post
Share on other sites
  • Solution

Hi guys, 

 

Last night i was able to get the emby server setup completed. 

 

From what i can tell, when you use myqnapcloud to sign into your NAS, it uses the WAN IP, even if you're doing this from within your home network. then when you open the emby server, it attempts to open the 8096 port using that same IP. that resulted in the connection refused error. 

 

So this time i connected the the NAS directly using the LAN IP, and clicked the emby app and it opened successfully. problem solved. 

 

thanks again for your patience and guidance. it is much appreciated!

 

Nick 

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...