Jump to content
rliepins

problems watching a recording while being recorded

Recommended Posts

rliepins

Hi

 

After my switch from Comcast to Frontier FIOS, I have been dealing with various issues (transcoding being the biggest previous problem).  I am not sure if this latest problem is due to the switch, but I don't recall this issue before.

 

So, there are times I want to start watching a recorded show shortly after I started recording it, while it continues to record.  I like to skip commercials...  Anyway, when doing so, the quality is poor and freezes often.  I definitely cannot skip forward or back.  However, if I stop recording it, playback works just fine as does the skip forward and back.  This is especially bad for a program over digital antenna, but affects the new FIOS channels as well.  

 

I have tried toggling hardware transcoding, but no setting seems to make a difference in quality.

 

Would the ffmpeg files and server log be in order here?  Or is this a known issue?

 

Thanks

Share this post


Link to post
Share on other sites
rliepins

Right, possibly, however the kicker here is if I stop recording the show, playback is smooth.  If I don't skip, then playback is ok while recording.

Share this post


Link to post
Share on other sites
ebr

Right, possibly, however the kicker here is if I stop recording the show, playback is smooth.  If I don't skip, then playback is ok while recording.

 

Sounds exactly the same except you are experiencing the corruption in the live playback instead of the recording.

Share this post


Link to post
Share on other sites
rliepins
Posted (edited)

Sorry I dropped off...holidays.

 

So, the problem still exists.  I want to watch a recording that is currently still recording (or live).  There are definite problems, especially with sports and especially when the time of recording gets close to live, playback simply fails and hangs.

 

What I would like is something that WMC did so well - the ability to watch a recording that is currently recording and not have any glitches or abnormalities.  I do see references to this problem from other users...

 

Also, I wonder if it is because I am watching from an Nvidia Shield.  Perhaps watching from Emby Theater would eliminate?  I should test.

 

How or what log files do I need to provide?

 

Thanks

Edited by rliepins

Share this post


Link to post
Share on other sites
Luke

Is this with HD Homerun?

Share this post


Link to post
Share on other sites
rliepins

It is indeed.  I'm beginning to see the writing on the wall here...  Can anything be done?  Would the beta firmware be in order?

 

Also, I still have an older Ceton PCI 4 tuner I can pull out of storage.  I was helping with a developer on creating drivers, but have lost track of that thread.

Share this post


Link to post
Share on other sites
Luke

 

 

It is indeed.  I'm beginning to see the writing on the wall here...  Can anything be done?  Would the beta firmware be in order?

 

Yes, why not try setting up directly in Emby Server without using ServerWMC?

Share this post


Link to post
Share on other sites
rliepins

I'm not using WMC at the moment.  This is all straight from Emby using HDHomeRun Prime units.  The underlying issue is watching a recording of a show that is currently being recorded is problematic.  I see others with the same issues.

Share this post


Link to post
Share on other sites
Luke

Yes we are working on improving it. Thanks.

Share this post


Link to post
Share on other sites
rliepins

Thanks for that.  Anything I can do in the meantime to minimize this issue?

Share this post


Link to post
Share on other sites
rliepins

Here is a new tidbit....

 

I have 3 SiliconDust tuners.  2 of them are cablecard HDHOMERUN Prime 3 units.  The third is an ota tuner, the HDHOMERUN Connect Duo.  I was testing the Live TV/recording issue and tried it with an OTA channel.  There was no issue whatsoever and it behaves as expected.  

 

Now, I started recording a channel via the Prime.  I waited about 10 minutes and began to watch, just like I did with the Duo.  Starting the currently recording recording was fine and I was able to fast forward and rewind as needed.  However, things fell apart quickly once I advanced relatively close to the live time in the recording.  Between 2 and 5 minutes from live, watching the recording simply froze.  I tried stopping and resuming, but I got the spinning wheel.  Nothing I could do would fix this.  I couldn't even start from the beginning.

 

There is a marked difference between ota and cablecard behavior for this.

 

So, what log files are needed for this for you to look over?

Share this post


Link to post
Share on other sites
Luke

Thanks for the info. We are looking into it.

Share this post


Link to post
Share on other sites
rliepins

In a like thread, I made mention of this.  Others suggest it is because of the Android app.  I am using an Nvidia Shield to watch.

 

I will try the same testing on a browser and Emby Theater tonight...

Share this post


Link to post
Share on other sites
rliepins

So I did a bit of testing and went out and got a Roku and a Fire Cube.  Both were way worse on this issue.  I tried it via Emby Theater from the local system (Windows 10), a remote system and from the XBox.  All failed and were worse than the NVidia Shield - that box seems to be the best streamer out there and only the web client beats it.

 

If I start watching a live recording from a browser on a separate system, then the performance is good and I don't freeze at all.

 

Is this an issue with the Live TV feature in Emby or the recording/Live TV source?  In my case, its the HDHomeRun Prime 3.  However, this does not seem to be an issue with the Connect Duo.  Perhaps I should do a test with my Ceton card via NextPVR...

 

Is there any hope on the horizon for this?

Share this post


Link to post
Share on other sites
Luke

We are looking into this. Thanks for reporting.

  • Like 1

Share this post


Link to post
Share on other sites
brennanthl

Is there any update on this? This is happening to me still and I can't find any help on the forums about it. If I have started recording a program and want to join live, it is nearly impossible to scrub through and fast forward through commercials. And sometimes it just randomly jumps around. It's super frustrating. It seems to be less bad if I start at the "live" point and let it build up a buffer and then fast forward through that, rather than using the recording.

Share this post


Link to post
Share on other sites
Luke

Hi, have you updated to Emby Server 4.5? Are you still running into this?

Share this post


Link to post
Share on other sites
Noel-M

I am running emby server 4.5.2, cpu is i7 - 16gb ram, ssd & plenty of other disks.  Have been an Emby user for a long time and the product(s) are now getting quite good.  Still a few gliches that need ironing out.  The problem in this item is the most annoying to me.  I can add the following --

* If replaying whilst recording - all is well until you reach the point that the recorder was up to when you started watching.  That is, if I start watching 30 minutes after the program started recording, I get 30 minutes of good replay.  After that the picture is heavily pixelated as described in this item.

* The first time I attempt to watch, I can skip forward while watching and recording without problem.  If I stop watching, then try to resume the watch (while the program is still recording), the replay suffers horrible delays - often hangs.

* Once the recording is complete, I can watch the previously pixelated sections without a problem - the recording itself is good - just the replay whilst recording is problematic.

Share this post


Link to post
Share on other sites
Noel-M

Forgot to say - I have Hauppauge Quad tuner card.

Share this post


Link to post
Share on other sites
cayars

Try making sure your DVR recording path and Transcoding directory are set to different discs, SSD for both if possible.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...