Jump to content

Problem with folder view (yes again)


franco735
 Share

Recommended Posts

Hi, I'm using Emby on several devices, and here is a problem with folder view that I could not solve.

 

I have created a media library with mixed content on my Freenas server:

5db03b45c66e3_emby1.gif

 

So when I enter the library here is what I see:

 

5db03b7b6e7c1_emby2.gif

 

For some reason the Series folder became different. What is 462 tag mean? Why is there a check mark? It says Played but doesn't seem to change anything. If I go to the Music folder (or any other folder) I can see the normal folder structure which I can browse without difficulty.

 

5db03c9165bd4_emby3.gif

But when I try to go to Series folder it's a complete mess:

 

5db03cef28e16_emby4.gif

 

I don't have 'Season 2' folder, at least not on the top level. So I suppose it's some kind of virtual folders, which are by the way unusable. If I try to go to Season 2 folder, it starts playing:

 

5db03de568b19_emby5.gif

Why is it playing Downton Abbey while the file name suggests Jeeves and Wooster? Maybe there is a mistake in the file name? Ok, let's find the file in Windows Explorer:

 

5db03e9e3f947_emby6.gif

 

So it's OK with the file name and its contents. So far I tried to delete and rebuild the library, to create a separate library only for Series, to change library content type, to check and uncheck any settings I could possibly find, to uninstall any add-ons - nothing helps. How can I restore my Series folder to a standard folder view and navigation?

 

Thanks,

 

Link to comment
Share on other sites

Looks like your "Series" folder has been identified as a single TV series.  Did you recently add a folder under there with "Season" in the name?

 

Can you show us the direct contents of that folder?

Link to comment
Share on other sites

Hi.  Remove "Season 01" from your "Big Little Lies" folder name.

 

Then, also be sure there is no series.nfo or similar file in the main "Series" folder.

Link to comment
Share on other sites

OK thank you guys, did as suggested, removed and rebuilt the library, and the problem disappeared!

 

Well, not entirely. At least it disappeared at the top level. Now the same problem is pushed to a level down, whenever the \showname\ folder contains subfolders like \Showname.s01\, or \Season 1\, or just \S01\ etc.

 

Do I have to change manually all the nested folders names? Or maybe there is a magic setting which will tell Emby not to try to be so smart and disregard the folder name, whatever it says?

 

 

Thanks, 

Link to comment
Share on other sites

If you want Emby to not try and discover your items as actual TV series and movies, then use "Home Videos" as the library type.

 

OTOH - if you do want us to discover TV shows properly, then you need  to respect the naming conventions that allow us to do that.

 

Please let us know which way you go on this.

 

Thanks.

Link to comment
Share on other sites

Hi, I removed the library and recreated it again selecting Home Videos as content type.

 

Unfortunately didn't help and no improvement from the previous step, I still have no access to individual files, only to those 'virtual' folders which start playing from S1E1 when I select them. So if I want to watch for example S8E15 the only way to do so is to skip the episodes to the next one by one, and that's a lot of skipping!

Link to comment
Share on other sites

A correction to my previous message - so far I was testing the access to the library from my Win10 PC (Chrome) with reported problems which still persist.

 

However, when accessing the library from an Android Emby app or LG Smart TV Emby client, everything looks back to normal! I can now select the show, the season and the episode.

 

 

So a special thanks from my wife, she is now able again to browse her preferred episodes the way she likes it!

 

Any ideas what could block the normal operations when accessing the library from Chrome?

Link to comment
Share on other sites

@@franco735, form what i saw in your earlier posts this looks like an issue of supported naming conventions for a TV library (which we have since gone over).

 

The folders tab is not a substitute for using supported naming schemes, you still need to do that.

 

 

A correction to my previous message - so far I was testing the access to the library from my Win10 PC (Chrome) with reported problems which still persist.

 

However, when accessing the library from an Android Emby app or LG Smart TV Emby client, everything looks back to normal! I can now select the show, the season and the episode.

 

Is the same emby user logged into both apps? Just trying to ascertain what the difference might be. Thanks.

Link to comment
Share on other sites

 

Any ideas what could block the normal operations when accessing the library from Chrome?

 

Yea I didn’t realize when you hit refresh on Chrome unlike Safari and other browsers it doesn’t refresh the cache. You must clear it in the settings. Wasted a couple hours modifying css theme files and couldn’t figure out why the changes weren’t kicking in so to speak.

Link to comment
Share on other sites

Yea I didn’t realize when you hit refresh on Chrome unlike Safari and other browsers it doesn’t refresh the cache. You must clear it in the settings. Wasted a couple hours modifying css theme files and couldn’t figure out why the changes weren’t kicking in so to speak.

 

Hit shift-refresh to re-load a page without the cache.

Link to comment
Share on other sites

Hi, in my case in all three instances (Desktop/Crome, Android and LG TV) it's the same user. Actually there's only one user account on Emby server.

 

Tried to access from Chrome incognito tab - same result.

 

BTW what are the naming conventions for TV shows and where can I read about it?

 

Thanks,

Link to comment
Share on other sites

Hi, in my case in all three instances (Desktop/Crome, Android and LG TV) it's the same user. Actually there's only one user account on Emby server.

 

Tried to access from Chrome incognito tab - same result.

 

BTW what are the naming conventions for TV shows and where can I read about it?

 

Thanks,

 

Here is the Wiki link.

 

https://github.com/MediaBrowser/Wiki/wiki/TV-naming

Link to comment
Share on other sites

 

On the Library setup page in the server dashboard there is a "Help" button.  Just curious if you noticed it or ever tried clicking it?

 

Not trying to be an a$$ :)  We just are trying to understand how best to present this information so that people can easily find it.

 

Thanks.

Link to comment
Share on other sites

On the Library setup page in the server dashboard there is a "Help" button.  Just curious if you noticed it or ever tried clicking it?

 

Not trying to be an a$$ :)  We just are trying to understand how best to present this information so that people can easily find it.

 

Thanks.

 

Well, honestly no, I didn't, because I didn't have to! I even wasn't aware Emby would interpret the library based on files and folders names and structure.

 

As I said earlier up to a certain moment my Series folder was represented just the same plain way as other folder, which is for me the ultimate way of storing any computer information and being able to find it later. Maybe it's another discussion, but I'm not sure I fully understand the advantage of Emby interpreting the files/folders names as it does for TV shows, if I already have all my library set in files and folders.

 

So if you allow me my suggestion would be to add an option at the moment of creating the library, something like 'Use advanced library features for TV Shows' so it makes library creation and interpretation more transparent.

 

 

Thanks,

Link to comment
Share on other sites

One library for all media files on a freenas server and one library for all files on Windows PC. I would limit it to only one library for all media content but encountered problems accessing shares from freenas server to windows and vice versa.

Link to comment
Share on other sites

I have a Emby server installed on a Windows PC with one library created from local windows storage and another Emby server installed on a Freenas machine with one library created from local freenas storage. They are not connected to each other. What is the purpose of comparing those two libraries?

 

Or you mean the content of Windows Emby server/library might influence the way how windows chrome client will represent the content of the Freenas server library? 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...