Jump to content

Scan Library Erroring Out


Natilus13
 Share

Recommended Posts

I recently had to rebuild my file server and as such had to remap my folders for TV on emby. I am try to run a scan to update things, but it keeps getting to around 90% and failing. This is the error message I get:

 

 

 

Scan media library failed

Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown.

at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc)

at SQLitePCL.pretty.StatementImpl.MoveNext()

at Emby.Server.Implementations.Data.SqliteItemRepository.InsertItemLinks(Int64 internalId, Int64 topParentId, List`1 values, IDatabaseConnection db)

at Emby.Server.Implementations.Data.SqliteItemRepository.UpdateItemLinks(Int64 internalId, Int64 topParentId, List`1 values, IDatabaseConnection db)

at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItemsInTranscation(IDatabaseConnection db, List`1 tuples)

at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItems(List`1 items, CancellationToken cancellationToken)

at Emby.Server.Implementations.Library.LibraryManager.UpdateItems(List`1 items, BaseItem parent, ItemUpdateType updateReason, CancellationToken cancellationToken)

at Emby.Server.Implementations.Library.LibraryManager.UpdateItem(BaseItem item, BaseItem parent, ItemUpdateType updateReason)

at MediaBrowser.Providers.Manager.MetadataService`2.SaveItem(MetadataResult`1 result, LibraryOptions libraryOptions, ItemUpdateType reason, CancellationToken cancellationToken)

at MediaBrowser.Providers.Manager.MetadataService`2.RefreshMetadata(BaseItem item, MetadataRefreshOptions refreshOptions, CancellationToken cancellationToken)

at MediaBrowser.Controller.Entities.BaseItem.RefreshMetadata(MetadataRefreshOptions options, CancellationToken cancellationToken)

at MediaBrowser.Controller.Entities.Folder.RefreshAllMetadataForContainer(IMetadataContainer container, MetadataRefreshOptions refreshOptions, IProgress`1 progress, CancellationToken cancellationToken)

at MediaBrowser.Controller.Entities.Folder.RefreshMetadataRecursive(BaseItem[] children, MetadataRefreshOptions refreshOptions, Boolean recursive, IProgress`1 progress, CancellationToken cancellationToken)

at MediaBrowser.Controller.Entities.Folder.RefreshMetadataRecursive(BaseItem[] children, MetadataRefreshOptions refreshOptions, Boolean recursive, IProgress`1 progress, CancellationToken cancellationToken)

at MediaBrowser.Controller.Entities.Folder.ValidateChildrenInternal(IProgress`1 progress, CancellationToken cancellationToken, Boolean recursive, Boolean refreshChildMetadata, MetadataRefreshOptions refreshOptions, IDirectoryService directoryService)

at Emby.Server.Implementations.Library.LibraryManager.PerformLibraryValidation(IProgress`1 progress, CancellationToken cancellationToken)

at Emby.Server.Implementations.Library.LibraryManager.ValidateMediaLibraryInternal(IProgress`1 progress, CancellationToken cancellationToken)

at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options)

 

 

Anyone have any suggestions on how to resolve this?

 

Thanks,

N

Link to comment
Share on other sites

Thanks @@Luke. Just sent you a PM with a link to grab my log (it was too big to include in the message).

 

Cheers,

N

You could restart the server to start a new log, perform a library scan and post that log.  Or run the rotate logs task and perform scan.

  • Like 1
Link to comment
Share on other sites

So I finally got a scan to complete. I had to reboot the server a few times, but each time the scan made it a little farther. The scan did take a long time. It would move at the regular speed until about 90% and then take a long time to error out. Each time the scan made it a little farther though, until it finally completed.

Link to comment
Share on other sites

It appears to be running correctly now. I added a number of new files last night and did not have any errors. The scan is in the process of running again now, and I anticipate that it will also finish without issue.  :)

Link to comment
Share on other sites

And... it is now failing again. The failure seems to have happened when I had to remap some of my network shares due to a network issue. I have since corrected the issue and mapped the shares back to what they were originally. Once again the scans are failing, but I suspect that this will be the same as before and will eventually work after a few restarts and additional scans.

Link to comment
Share on other sites

After a couple more failures, everything finally worked. So it seems emby just doesn't like remapping shares... although it does warm up to the change eventually  ;)

Link to comment
Share on other sites

If you're using network shares mapped to a windows drive letter, I wouldn't do that and instead use the original share path instead.

Link to comment
Share on other sites

The shares are coming from a Windows box, but the server runs on macOS. I have some sort of DNS issue that I have not been able to resolve, so I had to mount the shares based on IP. When I had some cabling in my wall short out, I had to switch to Wi-Fi (which gave me a different IP), so I had to re-mount the shares using the new IP, and Emby just stuggled a bit with that it would seem.

 

Everything is back to normal now though :-)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...