Jump to content

Music scan missing albums and tracks with # in their name


knowenoughtobedangerous
 Share

Go to solution Solved by knowenoughtobedangerous,

Recommended Posts

knowenoughtobedangerous

Topic title says it all really.

 

Example of albums missed:  //HomeServer/Music/MediaMonkey/Louis Jordan/Jivin' With Jordan #2 - Let The Good Times Roll/.   #1, #3 and #4 are also missed.  There are entries in the attached logs that appear to relate to this.

 

Example of tracks missed: //HomeServer/Music/MediaMonkey/Vivaldi/Four Seasons/Spring - Concerto #1 in E major - 2 - Largo.mp3.  11 other tracks with similar names and from the same album are also missed.  But 6 more tracks from the same album were found.  I can see nothing in the log relating to the missed tracks.

 

Plex running on the same server finds these and other missed items fine.

 

I've not tested for similar failures wth Album Artist names.

 

I'll thank you not to suggest that I edit the tags - they were completed automatically and would likely be changed back, if not by Emby then by MediaMonkey.

 

I believe this to be a fault.  But I'm amazed that nobody else has reported it as far as I can see. Anyone?

 

Thanks

 

Ian

 

QNAP TS-453 Pro, V 4.4.1.1064

Emby V 4.2.1.0

embyserver.txt

hardware_detection-63704836041.txt

Link to comment
Share on other sites

PenkethBoy

I cant test directly on my Qnap as its down at the moment

 

but just tested on Windows and the files/album were read by Emby and added to a test library - for both examples

Link to comment
Share on other sites

knowenoughtobedangerous

To confirm PenkethBoy's results, I've run up Emby on Windows 10 running in a VM on my QNAP and it found them.

Link to comment
Share on other sites

  • Solution
knowenoughtobedangerous

Ah, a possible reason for our different results:

 

as I implied above, I had the defined the folder in my lusic library as   //HomeServer/Music/MediaMonkey/.   ie. in it's network share name. That was updated by Emby as smb://HomeServer/Music/MediaMonkey/ 

 

I've now tried defining it what I suppose to be a native name as   /share/CACHEDEV3_DATA/share/Music/MediaMonkey/

 

That works:  missing items found.

 

Thank you both for nudging me to another level of thinking.  I'm happy that I now have a workaround to my problem. I'll leave it for Luke to decide whether the smb-style name should have worked and should be treated as a fault or whether that style should be rejected as invalid.  

 

Note the 'help' on the "select path" form:  "Network paths can be entered manually in the event the Network button fails to locate your devices. For example, \\server or \\192.168.1.101."   That's what guided me in the direction that I took, not least because I couldn't find any "Network button"

 

Anyway, happy for now.

 

Thanks.

Edited by ian.addison
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...