Jump to content
rancid_

NextPVR & Emby Setup - Need help, please!

Recommended Posts

rancid_

Afternoon all,

 

I am a complete newbie to IPTV, but spent the entire weekend trying providers, apps, setup emby and also NextPVR so I am progressing.  The issue I am having is with Emby's implementation of NextPVR which has me completely baffled.  I would like to use NextPVR to be my main guide for Live TV channel surfing since it gives you more flexibility for channel grouping, removing, etc.  I originally setup my m3u and epg files in Emby, downloaded the NextPVR plugin (and configured it) along with adding the same files in NextPVR, but things began really slowing down which I believe is because it was polling the data twice.  I removed the live tv m3u file and the the epg file and assumed Emby would utilize NextPVR for the guide as I wanted, but nothing is showing up.  I did confirm that in NextPVR all the channels are there with the guide data.

 

What is the easiest way to set this up assuming it can do what I am wanting?  

 

Thanks for the help!

Share this post


Link to post
Share on other sites
arrbee99

Few things might be worth mentioning -

 

Think you need Emby Premiere to watch Live TV, even if its via Nextpvr.

 

There's a v4 version of NextPVR and a new v5 version, the same applies to NextPVR Emby plugins, so make sure you're using v4 NPVR with v4 version of the plugin and the same for v5.

 

After you removed the m3u and epg from Emby, try a few things like refreshing the guide, restarting Emby server etc. Check NextPVR server is still running.

Share this post


Link to post
Share on other sites
rancid_

Few things might be worth mentioning -

 

Think you need Emby Premiere to watch Live TV, even if its via Nextpvr.

 

There's a v4 version of NextPVR and a new v5 version, the same applies to NextPVR Emby plugins, so make sure you're using v4 NPVR with v4 version of the plugin and the same for v5.

 

After you removed the m3u and epg from Emby, try a few things like refreshing the guide, restarting Emby server etc. Check NextPVR server is still running.

Thanks, I have premiere emby and I restarted both servers several times with no luck.

 

Is the correct procedure to not add any guide or playlists to emby and do everything through NextPVR?

Edited by rancid_
  • Like 1

Share this post


Link to post
Share on other sites
rikiwi

Thanks, I have premiere emby and I restarted both servers several times with no luck.

 

Is the correct procedure to not add any guide or playlists to emby and do everything through NextPVR?

Yes, that's what I do.

 

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites
arrbee99

That sounds correct. I'm using NextPVR (V5) at the mo, and don't have anything under Live TV -

 

5d80356375bdd_EmbyNextPVRnolivetvsetup.j

 

I guess under Plugins, you have something like -

 

5d8035e240314_EmbyNextPVRnolivetvsetupPl

 

8866 = standard NextPVR port thingy

 

http... = same as that given  as Server Dashboard > In-Home (LAN) access

 

Think NextPVR server has something like a 'Allow Remote Access' box which I presume should be ticked.

Share this post


Link to post
Share on other sites
rancid_

Thanks all, I will give it another go and perhaps upgrade to v5.

Edited by rancid_

Share this post


Link to post
Share on other sites
rancid_

Dumb question, where does the plugin go?  I tried uninstalling the old one and placing this in the emby-server plugins directory but it isn't picking up the plugin.  If I put it in the program data folder and delete the 3.3 plugin it shows 3.5, but is just constantly showing a spinning icon.

 

Thx

 

*update - doesn't work with beta emby, went back to official and it resolved the spinning icon issue.*

Edited by rancid_

Share this post


Link to post
Share on other sites
arrbee99

Far as I remember you uninstall the old one from the server dashboard > Plugins, and probably restart the server. If you're installing the v5 plugin you unzip the file to give a .dll and install in

C:\Users\username\AppData\Roaming\Emby-Server\plugins\ and restart the server.

Share this post


Link to post
Share on other sites
arrbee99

You mean this ?

 

5d8055667988e_EmbyNextPVRnolivetvsetupsp

 

Bit weird. Still plays stuff here for me though.

Share this post


Link to post
Share on other sites
rancid_

I have everything up and running. I have no idea why, but updating to v5 and the new plugin fixed all my issues.

 

Thx for sticking with me while I figured this out, super happy at the moment. :)

Edited by rancid_

Share this post


Link to post
Share on other sites
arrbee99

Excellent. Glad you fixed it  :)

Share this post


Link to post
Share on other sites
emveepee

You mean this ?

 

5d8055667988e_EmbyNextPVRnolivetvsetupsp

 

Bit weird. Still plays stuff here for me though.

What specifically is weird that I should look at?

 

Martin

Share this post


Link to post
Share on other sites
arrbee99

It was, and still is - if I just go to that plugin page I get that spinning circle, which just keeps spinning as long as you stay there.

Share this post


Link to post
Share on other sites
pünktchen

What specifically is weird that I should look at?

 

Martin

The javascript code of the config page needs some update. Just look at the last commits for the MediaPortal plugin in Emby's github repos.

Share this post


Link to post
Share on other sites
emveepee

The javascript code of the config page needs some update. Just look at the last commits for the MediaPortal plugin in Emby's github repos.

 

Thanks both of you, I haven't run Emby for a few months and the installed version 4.1.0 works fine as well as the update 4.2.1.0  Is this a beta only change and will it break production use?

 

Martin

Share this post


Link to post
Share on other sites
Luke

Yes what you could do to avoid an update that will change your min required server version is simply to keep the version targeting as it is, and update javascript to remove uses of the jquery functions $(...).selectmenu() and $(..).checked(), and $(...).checkboxradio(...). So essentially just convert those to vanilla js and then the same dll should work with both newer and older server versions.

Share this post


Link to post
Share on other sites
emveepee

Thanks for confirming that Luke.

 

Martin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...