Jump to content


Photo

Live TV Channels Dissapearing


  • Please log in to reply
10 replies to this topic

#1 salazr OFFLINE  

salazr

    Newbie

  • Members
  • 5 posts
  • Local time: 04:52 PM

Posted 15 September 2019 - 01:29 PM

Hey guys,

 

Log is attached. Running raspbian, stable. Emby 4.2.1.0.

 

I have been using Premiere & Live TV for about a year. I run another program in the same server that generates a playlist file and it's been working well.

 

The issue is that in the last week or so,  the live tv channels have started disappearing. Emby goes from having a full channel list in the live tv section, to no channels at all without me doing anything. The error from the logs seems to point to the playlist itself not being available, but I have tested this many times, and the playlist is available. Any get request to the playlist works fine.

 

If I restart emby, the channels come back up successfully, but then go missing some time after.

I have been paying attention to this for about a week and it is a consistent issue.

 

I've attached the server log that starts with the restart. The moment emby starts, the channels are there, and some time after, we see this issue:

 

2019-09-15 06:05:10.288 Error HttpClient: Error getting response from http://192.168.1.10:...v/playlist.m3u8

*** Error Report ***
Version: 4.2.1.0
Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_armhf.deb
Operating system: Unix 4.14.79.7
64-Bit OS: False
64-Bit Process: False
User Interactive: True
Runtime: file:///opt/emby-server/system/System.Private.CoreLib.dll
Processor count: 4
Program data path: /var/lib/emby
Application directory: /opt/emby-server/system
System.ObjectDisposedException: System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'System.Net.Http.HttpClient'.
  at System.Net.Http.HttpClient.CheckDisposed()
  at System.Net.Http.HttpClient.SendAsync(HttpRequestMessage request, HttpCompletionOption completionOption, CancellationToken cancellationToken)
  at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
Source: System.Net.Http
TargetSite: Void CheckDisposed()
 
2019-09-15 06:05:10.327 Error M3UTunerHost: Error getting channel list
*** Error Report ***
Version: 4.2.1.0
Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_armhf.deb
Operating system: Unix 4.14.79.7
64-Bit OS: False
64-Bit Process: False
User Interactive: True
Runtime: file:///opt/emby-server/system/System.Private.CoreLib.dll
Processor count: 4
Program data path: /var/lib/emby
Application directory: /opt/emby-server/system
System.ObjectDisposedException: System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'System.Net.Http.HttpClient'.
  at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
  at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
  at Emby.LiveTV.TunerHosts.M3uParser.Parse(String url, String channelIdPrefix, String tunerHostId, CancellationToken cancellationToken)
  at Emby.LiveTV.TunerHosts.M3UTunerHost.GetChannelsInternal(TunerHostInfo info, CancellationToken cancellationToken)
  at Emby.LiveTV.TunerHosts.BaseTunerHost.GetChannels(TunerHostInfo tuner, Boolean enableCache, CancellationToken cancellationToken)
  at Emby.LiveTV.TunerHosts.BaseTunerHost.GetChannels(Boolean enableCache, CancellationToken cancellationToken)
Source: System.Net.Http
TargetSite: Void CheckDisposed()

Attached Files


Edited by salazr, 15 September 2019 - 01:30 PM.


#2 salazr OFFLINE  

salazr

    Newbie

  • Members
  • 5 posts
  • Local time: 04:52 PM

Posted 18 September 2019 - 06:38 PM

This is still an issue.. is there a separate forum for premiere feature support?



#3 salazr OFFLINE  

salazr

    Newbie

  • Members
  • 5 posts
  • Local time: 04:52 PM

Posted 22 September 2019 - 09:00 PM

No help at all?



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146297 posts
  • Local time: 03:52 PM

Posted 24 September 2019 - 12:54 PM

@salazr this looks like an issue in the .net core runtime. We'll be updating to .net core 3.0 soon so let's re-evaluate then. In the meantime you can probably work around this by adjusting the schedule of your live tv guide refresh.



#5 salazr OFFLINE  

salazr

    Newbie

  • Members
  • 5 posts
  • Local time: 04:52 PM

Posted 24 September 2019 - 12:56 PM

Yes, I disabled the refresh after a restart and the guide has worked.

 

I'll keep an eye on the update, thanks.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146297 posts
  • Local time: 03:52 PM

Posted 24 September 2019 - 03:23 PM

Thanks for the feedback.



#7 DFWjih3rt7h OFFLINE  

DFWjih3rt7h

    Newbie

  • Members
  • 6 posts
  • Local time: 08:52 PM

Posted 19 November 2019 - 11:30 AM

I'm also having this issue with m3u tuners. After a couple of refreshes I get the issue. I can cause it quickly by opening the tuner settings and resaving a couple of times. The error in the logs looks exactly the same. I went to see if .NET core was in the beta but it specifically mentions this only for Windows and Mac. I'm using the official Docker image, do you expect the issue to be resolved there?

 

Thanks



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146297 posts
  • Local time: 03:52 PM

Posted 19 November 2019 - 11:54 AM

I'm also having this issue with m3u tuners. After a couple of refreshes I get the issue. I can cause it quickly by opening the tuner settings and resaving a couple of times. The error in the logs looks exactly the same. I went to see if .NET core was in the beta but it specifically mentions this only for Windows and Mac. I'm using the official Docker image, do you expect the issue to be resolved there?

 

Thanks

 

hi there, let's look at your issue from the beginning. Please attach the emby server log. thanks.



#9 DFWjih3rt7h OFFLINE  

DFWjih3rt7h

    Newbie

  • Members
  • 6 posts
  • Local time: 08:52 PM

Posted 19 November 2019 - 01:41 PM

Attached, thanks


Edited by DFWjih3rt7h, 19 November 2019 - 03:58 PM.


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146297 posts
  • Local time: 03:52 PM

Posted 19 November 2019 - 02:38 PM

Ok yes that looks the same. As soon as we release 4.3, then in the coming days after that we'll be updating Linux beta packages to .NET Core 3.0. So at that point you could jump on the beta.

 

If you need an immediate workaround, you could download that m3u url to a file and then point Emby to the file instead of the url. This approach means you'll have to update the file anytime the m3u changes, but it will work as a temporary solution.


  • DFWjih3rt7h likes this

#11 DFWjih3rt7h OFFLINE  

DFWjih3rt7h

    Newbie

  • Members
  • 6 posts
  • Local time: 08:52 PM

Posted 19 November 2019 - 03:57 PM

Thanks for the update






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users