Jump to content
dtcpro

Emby for Android not producing anything on Shield

Recommended Posts

dtcpro

I have a 2017 Nvidia Shield 16GB, have a 1TB WD External Drive attached to Shield used for External Storage, HDHomerun, Wired or Wireless internet. Also have several Fire sticks throughout the house that benefit from the HDHomerun. Hoping Emby will fit in fine.

 

I am having the hardest time getting installed and working. I am new to Emby and have purchased Premier and I have questions:

 

1. Is Emby for Android the same file as Emby for Nvidia Shield? From what I have seen written it sounds like it is a special file just for Shield. If it is I can't find it. I downloaded the one for Android.

 

2. Are there separate Envy files for server and one for just viewing. If you go to google play store there is only one Envy that I see.

 

I want my server to be my Nvidia Shield and I want to be able to watch my TV etc... on Envy from other tvs with Firestick.

 

3. Is there a way to install Emby server on my external storage?

 

4. Is there a clear step by step installation/ video for emby on Nvidia Shield? I see a lot for installing on Windows etc....

 

5. My Nvidia Shield REMOTE does not work very well trying to install Emby. It is all over the place. Right now I'm switching between 2 remotes trying to configure Emby. It is a nightmare.

 

Right now what I have on my Shield are 2 Envy apps a Green and I think Blues or Black Icon. When I select the Green colored app I get a screen with a search function on left an Emby icon and then my user name top right. Nothing else listed and nothing is functional on this screen....you can't search or anything.

 

On the Blue/black Envy Icon (2nd icon) this is the server icon and I can log in. I have tried to configure the best I can the live tv and Dvr. I can eventually dig down and find my tv listings (Very hard to do with remote situation) and watch a show and it stops after a few seconds.

 

None of this can be working correctly from what I've seen on videos. I assumed it would be easier than this. What am I doing wrong?

 

Would someone be kind enough to answer the 5 questions? I think will help a lot.

 

Thank you,

Steve

Share this post


Link to post
Share on other sites
Luke

Hi, Emby for Android is our mobile app. We have an app for the Shield that is better suited for use with a remote control:

 

https://emby.media/emby-for-nvidiashield.html

 

Please let us know if this helps. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
dtcpro

This is the same file I have already installed....so no help, but I'm going to uninstall and try again...

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Hi, that's not a file, that's an app from the Google play store. This is the app to play your content.

 

You said you want the server to be your shield as well so that would actually be step 1. Have you installed the server first?

Share this post


Link to post
Share on other sites
dtcpro

This is the same APP I have already installed on the Shield....Is this app the only one needed to install? Is this the server for the Shield too?

 

I have two apps installed on Shield.....Emby and Emby Server.

 

If I select the Emby Server App I can get to the TV Guide etc... and view showsb but my Shield remote does not work....very hard to get around. At the top of the screen it says localhost:8096/web/index etc..... I had downloaded this apk for the server from the website not the google playstore.

This would work if I could get around with remote I think.

 

When I select the other APP that just says Emby (not server) it has the search, emby icon and the time and my username, but nothing works...

 

I'm going to reinstall the android tv app

Edited by dtcpro

Share this post


Link to post
Share on other sites
Luke

You need to setup Emby Server before you can use Emby playback apps. What you've installed is a playback app. Emby Server can be installed on your Shield, or you could put it on a computer, NAS device, etc. The options are on our download page:

 

https://emby.media/download.html

 

Does this answer your question?

Share this post


Link to post
Share on other sites
dtcpro

I think we are both typing at the same time and missing each other....I edited my post above your last reply...please read that again.

So now I'm going to uninstall Emby, but leave the server installed. Reinstall Emby for Android TV and see if it works. If not I may have the wrong version server installed and I will re-install everything.

 

BTW thanks for the help

Steve (DTCPRO)

Share this post


Link to post
Share on other sites
Luke

Let us know how you get on. Thanks.

Share this post


Link to post
Share on other sites
dtcpro

Ok, I reinstalled everything on my Nvidia Shield and it seems to working fine except for a couple issues.

 

1. I sometimes get a warning that my Shield storage is extremely low.

 

I think this stems from my file paths being automatically being installed on my Internal Shield Storage (16gb) instead of my External WD

USB Hard drive such as Cache and Transcoding temp.

 

Question: Can I create these paths on my External drive?

 

I am already storing my recordings on my external drive.

 

 

2. A tv show I recorded was stored as 2 separate recordings with the same name, but of different lengths and between the 2 recordings equalled the correct length of the show.

 

I'm thinking this was because of low storage during Transcoding. If I can redirect that path for Transcoding to the External 1TB drive I think that will solve that problem. I don't know for sure, but I'm thinking that is the cause and remedy.

 

And if possible where to go to edit those paths?

 

I appreciate the help.

 

Steve

Share this post


Link to post
Share on other sites
ebr

Hi.  Have you looked in the settings in the server dashboard?

Share this post


Link to post
Share on other sites
dtcpro

Hi.  Have you looked in the settings in the server dashboard?

Hi, Yes I figured it out late last night and reconfigured my Paths. All seems ok now. I'll watch it a few days with several recordings and shall see.

Thanks,

Steve

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...