Jump to content


Photo

Unable to Stream Roku off Network


  • Please log in to reply
26 replies to this topic

#21 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 3990 posts
  • Local time: 03:11 PM

Posted 27 May 2014 - 12:57 AM

I do not know what that is or why you would get a pop up. @Luke

Not a pop-up as in popup window, the process "dllhost" appears in process list is what I meant. Usually it appears alongside ffmpeg but sometimes it doesn't. That's the problem now, figuring out how to successfully reproduce the issue in the first place was the other. ;)

--------------------------------

 

With the dev-build ( Version 3.0.5256.36270 ), it behaves oddly. You have this strange lingering blackscreen everytime you exit a video before it ends. There is this oddball 5 seconds of blackscreen before it wants to kick you back to the details. If you are quick, like instantly start the video, then stop.. quick as *snap your fingers* ... well, you did it now. You reproduced the problem, ffmpeg wont spawn now.. DOH! oddly the blackscreen didn't occur either forcing you to watch it for 5 seconds. This is the clue letting you know you reproduced the issue in the dev-build.

 

So to me, the dev-build is actually a step backwards because of that lingering black screen the beta build didn't have. This is why it's a dev-build. I totally see how it's not ready for prime time the blackscreen may be a side effect of some larger feature evolving. This is a good thing I'm sure. But I don't actually see any effect on this issue as it's still happening.

 

so...

 

This the important part of the log where ffmpeg stops responding ever after.

2014-05-26 22:02:57.5822 Debug - HttpServer: HTTP GET http://192.168.1.253:8096/mediabrowser/Videos/364e802192cca5b123d5d4ebb5e45962/stream.m3u8?profile=high&deviceid=1GJ37M000975&audiochannels=2&audiobitrate=128000&maxwidth=1920&timestampoffsetms=0&audiocodec=aac&videobitrate=20000000&level=4.0&maxheight=1080&videocodec=h264
2014-05-26 22:02:57.5822 Debug - Dlna: No matching device profile found. The default will be used. User-agent: Roku/DVP-5.4 (045.04E03340A).
2014-05-26 22:02:57.5822 Info - App: C:\Users\speechles\AppData\Roaming\MediaBrowser-Server\ffmpeg\20140304\ffmpeg.exe -fflags genpts -i file:"L:\--TV SHOWS\Eastbound And Down\Season 1\eastbound.and.down.s01e03.dvdrip.xvid-reward.avi" -map_metadata -1 -threads 2 -map 0:0 -map 0:1 -map -0:s -codec:v:0 libx264 -preset ultrafast -crf 23 -maxrate 1226076 -bufsize 2452152 -r 23.97602 -vsync vfr -profile:v high -level 4.0 -force_key_frames expr:if(isnan(prev_forced_t),gte(t,.1),gte(t,prev_forced_t+5)) -vf "scale=trunc(min(iw\,1920)/2)*2:trunc(min((iw/dar)\,1080)/2)*2" -sc_threshold 0 -codec:a:0 aac -strict experimental -ac 2 -ab 128000 -af "adelay=1,aresample=async=1" -hls_time 10 -start_number 0 -hls_list_size 1440 "C:\Users\speechles\AppData\Roaming\MediaBrowser-Server\transcoding-temp\ac7107d5-3a45-5eda-e272-0e1155a32f36.m3u8"
2014-05-26 22:02:58.1750 Debug - HttpServer: HTTP DELETE http://192.168.1.253:8096/mediabrowser/Users/14da26f23a8692342b18ad401d2642ab/PlayingItems/364e802192cca5b123d5d4ebb5e45962?PositionTicks=00000000
2014-05-26 22:02:58.1750 Warn - App: PlaybackStopped reported with null media info.
2014-05-26 22:02:58.1750 Debug - HttpServer: HTTP Response 204 to 192.168.1.239:41589. Response time: 0 ms
    Url: http://192.168.1.253:8096/mediabrowser/Users/14da26f23a8692342b18ad401d2642ab/PlayingItems/364e802192cca5b123d5d4ebb5e45962?PositionTicks=00000000
2014-05-26 22:02:58.1750 Debug - HttpServer: HTTP DELETE http://192.168.1.253:8096/mediabrowser/Videos/ActiveEncodings?DeviceId=1GJ37M000975
2014-05-26 22:02:58.1750 Info - App: Killing ffmpeg process for C:\Users\speechles\AppData\Roaming\MediaBrowser-Server\transcoding-temp\ac7107d5-3a45-5eda-e272-0e1155a32f36.m3u8
2014-05-26 22:02:58.1750 Info - App: FFMpeg exited with code -1
2014-05-26 22:02:58.1906 Info - App: Deleting partial stream file(s) C:\Users\speechles\AppData\Roaming\MediaBrowser-Server\transcoding-temp\ac7107d5-3a45-5eda-e272-0e1155a32f36.m3u8

and here is the full log :: http://paste2.org/34HjmhIy

 

Any other questions, tests to try, babies to kiss, let me know I'll be up for awhile longer.


Edited by speechles, 27 May 2014 - 02:01 AM.


#22 econ OFFLINE  

econ

    Advanced Member

  • Alpha Testers
  • 467 posts
  • Local time: 06:11 PM

Posted 29 May 2014 - 07:07 PM

After continuous frustration with not being able to stream off the network I decided to see if a clean install of media browser would fix the issue.  To my amazement, it did!!!!   

 

Version 3.0.5238.39498 works off the network

Version 3.0.5253.35926 does not



#23 Tharnax OFFLINE  

Tharnax

    Advanced Member

  • Members
  • 179 posts
  • Local time: 05:11 PM
  • LocationToronto, Canada

Posted 29 May 2014 - 09:13 PM

I agree with @speechles it appears if you start a movie the requires transcoding and you cancel at some point through the movie you can't request another movie to start transcoding.

 

I just cleared by Mediaserver Logs and tried to launch a movie using the Roku, here are the logs:

 

http://paste2.org/apB3264M

 

I'm going to clear the logs, restart the media browser server and attempt to reproduce the issue and will post the logs.

 

MediaServer logs immediately after service restart - No video/music requests sent to MB Server.

 

http://paste2.org/XBkKpbK7

 

Cleared MediaServer logs - went to Roku - launch Media Browser app.  Went to Movies folder, scrolled to 21 and over and selected it.  Selected Play.  Loaded progress bar about half way and crashed back to menu. 

 

Log: http://paste2.org/nmw2C4Mg

There was no transcode log.

 

Left 21 and Over - Movie specs: 

Video

Codec: H264
Profile: High
Level: 41
Resolution: 1280x536
Aspect Ratio: 2.40:1
Interlaced: No
Framerate: 23.97599
Bitrate: 6723 kbps

 

Audio

Language: eng
Codec: DCA
Profile: DTS
Layout: 5.1
Bitrate1536 kbps
Sample Rate: 48000 khz
Default: Yes

 

Loaded Trailer for 47 Ronin worked fine, exited before it was finish.  Started 47 Ronin full movie, watched the intro, exited before it was finished.  Loaded Abduction trailer - 1080p, crashed before loading.  Tried full movie - Crashed back to menu screen before loading.

 

Logs:

MediaServer - Logs: http://paste2.org/9LXWeEyp

Transcode log 1: http://paste2.org/Y403Nw23

Transcode log 2: http://paste2.org/m6pd95EC

Transcode log 3: http://paste2.org/Fys7AKYe

Transcode log 4: http://paste2.org/FJpM8YLL

 

21 and Over through MediaBrowser URL - Transcode log: http://paste2.org/5fFBZxDY - Movie play fine.  Selected different points in the movie on the web browser and not issues everything played fine.  Stopped the movie, went to the Roku and browsed to 21 and Over.  It had the option to Resume Playing.  Selected Resume playing on the Roku and it tried to load for about 30 seconds and crashed out to the menu screen:

 

Transcode Log: http://paste2.org/C0FcyZaJ

 

Finally full server log after all that:  http://paste2.org/tefp7AE2

 

I don't know if any of this is helpful, but it's what I've got.  


Edited by Tharnax, 29 May 2014 - 10:00 PM.


#24 squatingyeti OFFLINE  

squatingyeti

    Newbie

  • Members
  • 8 posts
  • Local time: 11:11 PM

Posted 30 June 2014 - 05:18 PM

Has this ever been sorted and if so how is it corrected? I've got a relative with a Roku that is having all kinds of trouble streaming anything from my server. I've tried to troubleshoot, but I don't have a Roku myself to take off network and see how it behaves.



#25 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124601 posts
  • Local time: 06:11 PM

Posted 30 June 2014 - 07:19 PM

Try our new Roku app that has been released since the time of this discussion

#26 squatingyeti OFFLINE  

squatingyeti

    Newbie

  • Members
  • 8 posts
  • Local time: 11:11 PM

Posted 30 June 2014 - 07:56 PM

Should I be telling them to get the media browser beta app or the regular media browser app? I'm a little confused not having a Roku to mess around with myself.



#27 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124601 posts
  • Local time: 06:11 PM

Posted 30 June 2014 - 07:58 PM

Get this app:

 

http://mediabrowser....u-beta-channel/

 

The public store channel will soon be available.


  • squatingyeti likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users