Jump to content


Photo
- - - - -

emby critical error


Best Answer yobrevar , 25 May 2019 - 07:50 AM

I believe this is a long known issue with WMC sleeping.  It loses its network connection and lots of other things go bad.  Basically, you cannot sleep a machine with WMC running.

 

Back in the day there were utilities people wrote to close WMC when the machine went to sleep.

 

Did a full un-install and re-install of Emby and its components while retaining all my data and cache files and it seems to have worked. 

WMC Emby is now working after resume-from-standby like it used to do.

Go to the full post


  • Please log in to reply
36 replies to this topic

#1 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 02:03 PM

suddenly...
 
 
emby critical error
 
 
Object reference not set to an instance of an object. In mediabrowser. application. connect automatically (int 32 timeout)


#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 22 March 2019 - 02:06 PM

Hi.  Can you please provide a bit more detail?

 

How to Report a Problem



#3 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 02:14 PM

I have been using the product for many years, I have not changed anything. Win7. emby for WMC does not start and gives this error. reinstallation did not help. what should I do? what specific details?



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 22 March 2019 - 02:22 PM

Hi.  Please read the article I linked to.  It explains the details we need.

 

Thanks.



#5 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 05:44 PM

embyserver.txt https://paste2.org/v9HzW5NK

 

5c95573479a3c_IMG_2747.jpg 

 

last wmc event  

 

 

Exception Microsoft.MediaCenter.UI.HostLoadException: Error while attemping to load:

 

 

'http://go.microsoft....LinkID=130677'.

 Details:
  http://go.microsoft....nkID=130677(3):Syntax error ("ng-controller" не является допустимым маркером. Ожидается маркер "=". Строка 3, позиция 37.)
 
 
в Microsoft.MediaCenter.UI.Host.OnPreInitialize()
   в Microsoft.MediaCenter.UI.ViewItem.PreInitializeTreeWorker()
   в Microsoft.MediaCenter.UI.ViewItem.PreInitializeTreeWorker()
   в Microsoft.MediaCenter.UI.ViewItem.PreInitializeTreeWorker()
   в Microsoft.MediaCenter.UI.NewUiZone.DeliverInitializations()
   в Microsoft.MediaCenter.UI.NewUiZone.ImplementUiTask(UiTask task, Object param)
   в Microsoft.MediaCenter.UI.UiZone.ProcessUiTask(UiTask task, Object param)
   в Microsoft.MediaCenter.UI.UiSession.ProcessInitialization()
   в Microsoft.MediaCenter.Queues.Dispatcher.MainLoop(Queue queue)
   в Microsoft.MediaCenter.UI.UIDispatcher.MainLoop(Queue queue, LoopCondition condition)
   в MediaCenter.Extensibility.Host.Main(String[] args)

Edited by cucoops, 22 March 2019 - 05:47 PM.


#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 22 March 2019 - 05:47 PM

Can we please see the Emby for Media Center log?



#7 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 05:51 PM

2019-03-23 00:38:35.3091,Debug,,=========System looking for assembly: System.Data.SQLite,, Version=1.0.88.0,, Culture=neutral,, PublicKeyToken=db937bc2d44ff139,1,Application
2019-03-23 00:38:35.3111,Info,,System.Data.SQLite,, Version=1.0.88.0,, Culture=neutral,, PublicKeyToken=db937bc2d44ff139 is being resolved to System.Data.SQLite,, Version=1.0.88.0,, Culture=neutral,, PublicKeyToken=db937bc2d44ff139,1,Application
2019-03-23 00:38:35.3171,Info,,==========Using new SQL Repo========,1,Application
2019-03-23 00:38:35.5091,Info,,Playstate initialization took 0,,00 seconds.,1,Application
2019-03-23 00:38:35.5421,Info,,Successfully loaded fastload data for : C:\ProgramData\MediaBrowser-Classic\Cache\playstate MediaBrowser.Library.Entities.PlaybackStatus,13,Worker thread for FastLoadLoader
2019-03-23 00:38:35.5621,Info,,Using String Data from C:\ProgramData\MediaBrowser-Classic\Localization\strings-en.xml,1,Application
2019-03-23 00:38:35.5711,Info,,Total Kernel Init took 0,,28 seconds.,1,Application
2019-03-23 00:38:35.6141,Info,,Finished validating : C:\ProgramData\MediaBrowser-Classic\Cache\playstate MediaBrowser.Library.Entities.PlaybackStatus,13,Worker thread for FastLoadLoader
2019-03-23 00:38:35.6141,Info,,Dictionary loading and validation took 0,,11 seconds.,13,Worker thread for FastLoadLoader
2019-03-23 00:38:35.7371,Info,,Information DisplayText: Welcome to Emby for WMC,1,Application
2019-03-23 00:38:35.7581,Info,,Emby (version 3.0.317.0 ) Starting up.,1,Application
2019-03-23 00:38:35.7581,Info,,Startup parameters: ,1,Application
2019-03-23 00:38:36.7262,Debug,,Having to get media experience by reflection due to bug in Windows 7,1,Application
2019-03-23 00:38:36.7272,Debug,,GetMediaExperienceUsingReflection was unsuccessful,1,Application
2019-03-23 00:39:37.6779,Info,,Application Init took 62,,11 seconds.,1,Application
2019-03-23 00:39:37.6789,Info,,Information DisplayText: Welcome to Emby for WMC,1,Application


#8 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 22 March 2019 - 05:53 PM

That is the entire log?



#9 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 05:54 PM

Only this in app data



#10 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 05:56 PM

I don't know what it looks like



#11 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 22 March 2019 - 05:59 PM

What version of the server are you running?



#12 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 06:01 PM

4.0.2.0



#13 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 06:04 PM

embyserver.txt https://paste2.org/v9HzW5NK  -- isnt it?



#14 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 22 March 2019 - 06:06 PM

Have you made any changes to your network recently?

 

I can't tell exactly where the problem is occurring but I can see the general area and it is something that has never happened before so I'm not sure how it is happening.

 

Does your server dashboard show a proper remote and local address on it?



#15 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 06:10 PM

1 no changes
2 server dashboard DONT show remote and local address!


#16 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 22 March 2019 - 06:14 PM

2 server dashboard DONT show remote and local address!

 

That is the root of the problem.  The app will need to be updated to handle that but, if you can solve that issue (whatever is keeping the server from discovering its own addresses) then your crash on EMC will go away.



#17 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 22 March 2019 - 06:16 PM

I allowed the latest server updates, now there is no such option



#18 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 22 March 2019 - 10:53 PM

I allowed the latest server updates, now there is no such option

 

To what option are you referring...?



#19 cucoops OFFLINE  

cucoops

    Advanced Member

  • Members
  • 31 posts
  • Local time: 07:02 PM

Posted 23 March 2019 - 03:31 AM

update option. I am using the latest version. can't change anything. should I step back?


Edited by cucoops, 23 March 2019 - 03:36 AM.


#20 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46397 posts
  • Local time: 03:02 PM

Posted 23 March 2019 - 09:39 AM

update option. I am using the latest version. can't change anything. should I step back?

 

No, you need to troubleshoot why the server cannot see its own IP address.  That is likely to lead to other issues.

 

However, you can also enter it manually in the Hosting settings in the server.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users