Jump to content


Photo

Trakt sync not uploading since latest update

Trakt

  • Please log in to reply
35 replies to this topic

#1 claptnei OFFLINE  

claptnei

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:04 AM

Posted 08 March 2019 - 06:16 AM

Hello,

Since the last plugin update this week (3.3.1.0), Trakt no longer updates my collection. It does scrobble and it does seem to download.

I have re authenticated both users to Trakt both it still fails.

I have attached the Emby log file that seems to show its an authentication api issue?

Tried going back to 3.3.0.0 and all works.

Any help please?

 

thanks,

Neil.

Attached Files

  • Attached File  Log.txt   263.77KB   3 downloads

Edited by claptnei, 09 March 2019 - 02:06 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135815 posts
  • Local time: 03:04 AM

Posted 08 March 2019 - 01:35 PM

@J2ghz



#3 claptnei OFFLINE  

claptnei

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:04 AM

Posted 09 March 2019 - 02:05 PM

How to I stop this pluggin auto updating to 3.3.1.0 as this does not work. I want to stay on 3.3.0.0 that does work.


Edited by claptnei, 09 March 2019 - 02:06 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135815 posts
  • Local time: 03:04 AM

Posted 09 March 2019 - 03:26 PM

You can't, but @J2ghz will look into your issue. Thanks !

#5 J2ghz OFFLINE  

J2ghz

    Advanced Member

  • Members
  • 75 posts
  • Local time: 09:04 AM

Posted 10 March 2019 - 05:51 PM

Can you enable debug logging in emby and enable debug logging in the Trakt plugin? Thanks



#6 claptnei OFFLINE  

claptnei

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:04 AM

Posted 11 March 2019 - 03:01 AM

Ok Debugging on in both Emby and Trakt pluggin.

Scheduled trakt upload task run for over 12 mins.

Log file attached not attached as it says its 179MB ?

Thanks, Neil.



#7 J2ghz OFFLINE  

J2ghz

    Advanced Member

  • Members
  • 75 posts
  • Local time: 09:04 AM

Posted 11 March 2019 - 07:42 AM

Can you try running the "Rotate log file" scheduled task before you run the trakt scheduled tasks? That should reduce the size of the log.



#8 claptnei OFFLINE  

claptnei

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:04 AM

Posted 11 March 2019 - 12:02 PM

Sadly, done that and the file is still 110Mb



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135815 posts
  • Local time: 03:04 AM

Posted 11 March 2019 - 08:42 PM

Can you post it to Dropbox or Google drive?

#10 claptnei OFFLINE  

claptnei

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:04 AM

Posted 12 March 2019 - 03:27 AM

I give up, I will wait an see if the next update works?

Why is something continually updated when it already works?

If it aint broke, dont fixit.



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135815 posts
  • Local time: 03:04 AM

Posted 12 March 2019 - 11:29 AM

Thanks for the feedback.

#12 elsker OFFLINE  

elsker

    Advanced Member

  • Members
  • 30 posts
  • Local time: 07:04 PM

Posted 13 March 2019 - 09:01 PM

Just realised I have been having this issue too. Last time Trakt was updated was 3rd march. When I run the task it appears to complete successfully. 

 

Scrobbling working ok. 

 

I have attached a log with debug mode on for emby and trakt plugin.

 

 

Attached Files



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135815 posts
  • Local time: 03:04 AM

Posted 14 March 2019 - 01:58 AM

thanks, @J2ghz will take a look at that.



#14 J2ghz OFFLINE  

J2ghz

    Advanced Member

  • Members
  • 75 posts
  • Local time: 09:04 AM

Posted 14 March 2019 - 02:44 PM

@claptnei I'm not sure it will be fixed, since I don't know what the problem is. If you want, you can split the log and upload only a part. Usually, the interesting things will be at the end.

@elsker I had a look at the log and there don't seem to be any problems. Can you check again that Trakt debug logging is on? If it was on there should be some lines containing "Debug Trakt:" in the log, but there are none. Also, can you describe the problem in more detail? Is it that when you mark something as watched in emby, it does not get marked on trakt?



#15 claptnei OFFLINE  

claptnei

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:04 AM

Posted 15 March 2019 - 08:21 AM

As a quick work around, I changed the permissions on trakt.dll version 3.3.0.0 , it has stopped it updating to 3.3.1.0



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135815 posts
  • Local time: 03:04 AM

Posted 15 March 2019 - 02:42 PM

Well that's not really a good solution. Sooner or later that version of the plugin will become incompatible as Emby Server gets updated. Please help us help you by working with us to resolve your issue. Thanks.



#17 slappfisk OFFLINE  

slappfisk

    Newbie

  • Members
  • 2 posts
  • Local time: 08:04 AM

Posted 15 March 2019 - 04:05 PM

3.3.1.0 included a change to the settings concerning collection syncs to trakt ("Sync Collection during Scheduled Task"). For some reason, that was disabled after the upgrade on my system. Re-enabling it solved my sync issues.



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135815 posts
  • Local time: 03:04 AM

Posted 15 March 2019 - 04:10 PM

3.3.1.0 included a change to the settings concerning collection syncs to trakt ("Sync Collection during Scheduled Task"). For some reason, that was disabled after the upgrade on my system. Re-enabling it solved my sync issues.

Thanks for the info !



#19 elsker OFFLINE  

elsker

    Advanced Member

  • Members
  • 30 posts
  • Local time: 07:04 PM

Posted 17 March 2019 - 06:03 AM

3.3.1.0 included a change to the settings concerning collection syncs to trakt ("Sync Collection during Scheduled Task"). For some reason, that was disabled after the upgrade on my system. Re-enabling it solved my sync issues.

 

realised I had the same issue, rechecked that option and all working correctly again.



#20 claptnei OFFLINE  

claptnei

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:04 AM

Posted 17 March 2019 - 11:55 AM

realised I had the same issue, rechecked that option and all working correctly again.

I tried that on 3.3.2 turning on "Sync Collection during Scheduled Task", it still doesn't update trakt. 3.3.0 is the only version that still work correctly.







Also tagged with one or more of these keywords: Trakt

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users