Jump to content

Remote vs. Local


loeffelpan
 Share

Recommended Posts

loeffelpan

I've just started with Emby and Emby for Kodi and I really like it. Thanks for your work.

But there mybe a simple question about this you may answer for me.

 

I set up a bitrate of 4.7 Mbps for remote connections in Emby for Kodi.

I connected Emby for Kodi manual without Emby connect. Emby for Kodi shows the local IP of my Server.

 

Unfortunately every video with higher bitrate than 4.7 Mbps is transcoded. If I change the above mentioned setting everything is fine an Kodi uses direct play as I expect.

 

Is my connection remote?

How could I change this behavior?

Do I have to use Emby connect?

Link to comment
Share on other sites

Angelblue05

Thank you :)

 

Your connection is not remote. However the bitrate setting will play a role no matter what. So it’s best to leave it at the default bitrate if you are connected to the same network as your server.

 

If you do go remote with the Kodi device, the addon will use your remote address. Then it is a good time to adjust the remote video quality setting as you did.

 

Emby connect is optional. You can connect it, to have access to other servers that are linked to your Emby connect account. It doesn’t change anything beyond that. It’s just a way to authenticate you against the server you are connecting to.**

Edited by Angelblue05
Link to comment
Share on other sites

loeffelpan

Ok, good for me.

But you should change the description in addon settings to something like „Bitrate for usage with addon playback mode“ to make clear the bitrate is used in any case.

Link to comment
Share on other sites

  • 2 weeks later...
loeffelpan

There is another question, concerning to remote access via Emby for Kodi.

I use apache as an remote proxy for Emby. Emby is accessable via "toothless.goip.de" on port 8443. Websocket connection are working - tested via https://www.websocket.org/echo.html.

 

Unfortunately I can't use this to connect in Emby for Kodi.

I tried to "refesh server information" with "toothless.goip.de" an port 8443 with no success.

17:56:29.366 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: http://toothless.goip.de:8443/emby/system/info/public
17:56:29.422 T:1423958784  NOTICE: Emby.emby.core.http -> ERROR:: 400 Client Error: Bad Request for url: http://toothless.goip.de:8443/emby/system/info/public
17:56:29.426 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> ERROR::
17:56:29.434 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> ERROR:: connectToAddress http://toothless.goip.de:8443 failed

Well, this cannot work. Addon has to connect via https on this port.

Due to that I tried "https://toothless.goip.de"and port 8443.

Now got this:


17:56:48.422 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: https://toothless.goip.de:8443/emby/system/info/public
17:56:48.655 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> connectToAddress https://toothless.goip.de:8443 succeeded
17:56:48.658 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> begin connectToServer
17:56:48.660 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> beginning connection tests
17:56:48.662 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> testing connection mode 2 with server ToothLess
17:56:48.664 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: https://toothless.goip.de:8443/emby/system/info/public
17:56:48.844 T:1423958784  NOTICE: Emby.emby.core.connection_manager -> calling onSuccessfulConnection with connection mode 2 with server ToothLess

But the server address in the settings dialog doesn't change and after a restart I can see, that the Addons uses the local IP as before.

Any suggestion?

  • Like 1
Link to comment
Share on other sites

Angelblue05

I misread what you said. What is displayed in settings is just for display purposes. It's not what the add-on uses to connect. This information is held in a separate file (data.json).

 

If you restart Kodi, does it then display the correct one? If not, I'll check to make sure that display setting is updated accordingly. Thanks.

Link to comment
Share on other sites

loeffelpan

As I mentioned above I can see in server logs that the addon uses local IP as before.

Even after restarting the addon / kodi.

This is not an display issue.

Link to comment
Share on other sites

Angelblue05

@@loeffelpan

 

I don't have this issue, can you provide your complete log rather than a snippet. Thank you.

 

Add-on settings > update server information > Put in my external address, restart Kodi. It connects using the external address (manual entry), even if I'm local.

Link to comment
Share on other sites

loeffelpan

Oh I just took a look in data.json.

My added server is entered as manualAddress.

Is this as expected?

 

Local and remote is discovered from emby?

 

Order is manual, local remote?

  • Like 1
Link to comment
Share on other sites

Angelblue05

Yes that is correct. manual > local (discovered) > remote (discovered) is the connection order. Any of them works, it stops the chain.

 

Edit: The only thing I can think that could mess up somehow, is the LastConnectionMode value. Is it 0, 1 or 2? But that should be updated when you updated the server information to reflect 2. Keep me posted, thank you.

Edited by Angelblue05
Link to comment
Share on other sites

loeffelpan

OK. Tested this again.

I reset the database and the addon to be sure.

After setup is done and I added manualAdress by selecting "Update Server Information" this is my "data.json".

{
    "Servers": [
        {
            "AccessToken": "{accesstoken}",
            "DateLastAccessed": "2019-03-03T22:06:08Z",
            "Id": "f7d73428ff464ce39b8a28f80df3d5a8",
            "LastConnectionMode": 2,
            "LocalAddress": "http://172.20.2.2:8096",
            "ManualAddress": "{remote}",
            "Name": "ToothLess",
            "UserId": "d4a7d2a90ac54c368953000cb8d025ad",
            "Users": [
                {
                    "Id": "d4a7d2a90ac54c368953000cb8d025ad",
                    "IsSignedInOffline": true
                }
            ]
        }
    ]
}

After a restart of Kodi "LastConnectionMode" switches back to 0 and local connection is used.

Here is a full log in debug mode. I just masked the auth-token by myself.

 

kodi.old.log

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...