Jump to content

Kodi Upgraded to Kodi 18 - Can't play anything.


JoshFink
 Share

Recommended Posts

JoshFink

I'm sure it's something simple. My Kodi automatically updated to Kodi 18. I installed the new Embuary skin and set back up the menus and such. However, when I go into to play a show it sometimes says there was an error and to check the log and sometimes it says nothing. 

 

I've restarted the Nvidia Shield with no luck. 

 

I'm attaching the logs here. Hopefully it's something simple and I just forgot something obvious. 

 

Thanks for the help

kodi.log

Edited by JoshFink
Link to comment
Share on other sites

Ok, so I managed to get 4.0.3 installed (requiring me to update the repository before updating the add-on....ugh), and now I can play content. 

 

But now there's a secondary Emby pop-up whenever I play anything that is "in progress" (meaning, I can either "resume" or "play from beginning"). Kodi asks me this, and now Emby asks the same question as well. Looks like there are more suitable threads for this topic, so I'll take this discussion elsewhere. Thanks.

  • Like 1
Link to comment
Share on other sites

JoshFink

 

Update to 4.0.3

 

I post these releases every build. Read them

https://emby.media/c...-kodi/?p=694404

 

 

Thanks for the help on this. I updated yesterday and things started working. Today, things stopped working again. Not sure why. I'm actually on 4.0.4 now. I did a repair hoping that something got changed but that did not work. 

 

I'm attaching the log again. Sorry if this is straight forward and I should have figured it out on my own. 

Thanks

kodi.log

Link to comment
Share on other sites

sualfred

You are running Emby 3.5.3. 

 

The addon currently does not support the 3.5.3 anymore. For a quick fix please update to Emby 4. 

Link to comment
Share on other sites

JoshFink

You are running Emby 3.5.3. 

 

The addon currently does not support the 3.5.3 anymore. For a quick fix please update to Emby 4. 

 

Really? Yesterday it was support 3.5.3 on 4.0.3. Did that change with 4.0.4? If I update to Emby 4 I then need to go back and repair 6 TV's which is going to take a bit. 

Link to comment
Share on other sites

sualfred

It's up to @@Angelblue05 if 3.5.3 will be still supported. I will talk to her and we are aware of the reason why it's happening on your end.  

 

I don't want to kill your Sunday evening, so please use the attached build. That should work temporary. But I highly suggest you to switch to Emby 4.

plugin.video.emby-4.0.4.zip

Edited by sualfred
  • Like 1
Link to comment
Share on other sites

JoshFink

It's up to @@Angelblue05 if 3.5.3 will be still supported. I will talk to her and we are aware of the reason why it's happening on your end.  

 

I don't want to kill your Sunday evening, so please use the attached build. That should work temporary. But I highly suggest you to switch to Emby 4.

 

Thanks. If this works temporarily then I will be fine. I plan to update next weekend when I have some free time. 

 

I really appreciate the help.

  • Like 1
Link to comment
Share on other sites

JoshFink

It's up to @@Angelblue05 if 3.5.3 will be still supported. I will talk to her and we are aware of the reason why it's happening on your end.  

 

I don't want to kill your Sunday evening, so please use the attached build. That should work temporary. But I highly suggest you to switch to Emby 4.

 

Thanks, worked perfectly. 

  • Like 1
Link to comment
Share on other sites

cw-kid

@@Angelblue05

 

I'm still on Emby server 3.5.3 and my Kodi remote clients are still on Kodi V17.x

 

I've been away for a month and I am being told Kodi / Emby no longer works now, keeps asking them to resync the local DB again. 

 

Reason I blocked auto updates on the Emby server is because I don't currently have Premiere and it sounds like Emby server 4.0 will no longer transcode? I've been using only software transcoding not hardware accelerated.

 

Any way does the Emby add-on for Kodi still support Emby server version 3.5.3 ? Maybe this is why they have been having problems with it. 

 

Also does the Emby repo need updating or something? Looking in the devices in the Emby Server dashboard it says they are on version Kodi 3.0.34. 

 

Which I assume is their Emby add-on for Kodi version number. So sounds like its not been updating the add-on for some time if 4.0.5 is the latest version ? 

 

Thanks

Link to comment
Share on other sites

feerlessleadr

@@Angelblue05

 

I'm still on Emby server 3.5.3 and my Kodi remote clients are still on Kodi V17.x

 

I've been away for a month and I am being told Kodi / Emby no longer works now, keeps asking them to resync the local DB again. 

 

Reason I blocked auto updates on the Emby server is because I don't currently have Premiere and it sounds like Emby server 4.0 will no longer transcode? I've been using only software transcoding not hardware accelerated.

 

Any way does the Emby add-on for Kodi still support Emby server version 3.5.3 ? Maybe this is why they have been having problems with it. 

 

Also does the Emby repo need updating or something? Looking in the devices in the Emby Server dashboard it says they are on version Kodi 3.0.34. 

 

Which I assume is their Emby add-on for Kodi version number. So sounds like its not been updating the add-on for some time if 4.0.5 is the latest version ? 

 

Thanks

 

Emby Server 4.0 software transcodes for free. Hardware acceleration for transcoding is now a premiere feature.

  • Like 1
Link to comment
Share on other sites

cw-kid

I updated the server to 4.0.1.0, I can confirm it still does the software transcoding. However I have lost all Live TV now. I was occasionally using Emby with the DVBLink plugin, so I could watch TV channels when out of the country. I have a BlackGold PCI tuner card on the server and DVBLink software. 

 

I never used Emby server with a HD HomeRun and didn't use any of the recording or EPG guide data features in Emby. But seems you cannot even view live TV channels now. 

 

Maybe I need to buy a Lifetime pass or start paying monthly again. 

 

Thanks

Link to comment
Share on other sites

cw-kid

 

Thanks I will have to update the Emby repo then on my two remote access Amazon FireTV sticks and reset / rebuild their local Kodi databases. 

 

Just currently updating my own HTPC's to Kodi V18 / LibreElec 9.0.0 which has been tricky so far. 

  • Like 1
Link to comment
Share on other sites

cw-kid

Don't forget you can create a backup and restore if needed.

https://github.com/MediaBrowser/plugin.video.emby/wiki/create-and-restore-from-backup

 

They have been having big problems lately. I've been away out of country for a month and I've been told that on one Fire stick, Kodi kept crashing or wouldn't even launch, I got them to clear the app cache for Kodi in the Fire stick settings and that got it launching Kodi again, but he said it kept prompting for the local DB to be reset. Maybe something got corrupted? 

 

Now I'm back, I've updated the Emby server to version 4.0.2.0 I was under the impression the local Kodi database had to be reset and rebuilt anyways ? 

Link to comment
Share on other sites

Angelblue05

A db reset is needed to move from 3.0.34 to 4.x. and yes a reset is required if your database was built with server 3.5 and you moved to 4.0. So the ideal thing to do was update the server first, then update the add-on and rebuild the database.

Edited by Angelblue05
Link to comment
Share on other sites

cw-kid

I was previously on Emby server 3.5.3 and the Kodi add-on for Emby were on version 3.0.34, so looks like I need to reset their database then as you say.

Link to comment
Share on other sites

cw-kid

I also want to update Kodi from V17 to V18 would you do that first or after updating the Kodi add-on for Emby / resetting the DB ? 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...