Jump to content

emby can't reach server with Google Home


Recommended Posts

Hi,

 

I trying to get get my google mini to work with Emby. When i ask "Hey Google Talk to Emby Home get the following message,

 

"I can't reach your Emby Server. Make sure your server is accessible from your outside network. If the external server address has changed, redo the account linking to update your server address."

 

I'm  on a Nvidia Shield and i have the latest update Version 4.0.0.2  on Emby as well as the Emby Premiere package and it's using port 8096.I'm also have a wired ethernet connection hooked up to my Nvidia Shield .Any help/suggestions would be greatly appreciated.

 

Thanks,

Bdub44

Link to post
Share on other sites

Hi Luke,

 

No it seems when i turn off my wifi on my phone it just hangs in trying to talk to the server. Does this have to do with the static settings on my Nvidia Shield Or do i have to create a Proxy setting?

 

Thanks

Bdub44

Edited by bdub44
Link to post
Share on other sites

Hi Luke,

 

I have a static address on my Nvidia Shield and made sure that address was configured on my router.

Then i added the emby app on my phone and tried to login without  my wifi on my phone on with the Http://192.168.x.xx.8096 and i get the message cannot connect to the server.

I have two libraries with different IP's and hardwired but all are running on the same network. I've tried bot ways connect manually and connect through Emby direct connect I get the same message. I don't have a antivirus on the shield but do on my PC.

Also i have tried Port forwarding on my router. I have my static address as my Internal and use the router address as my external.

Finally I tried the last step in the directions on my phone to test the connection andi get the message "i could not see your service on Http port connection timeout.

 

Bdub44

Edited by bdub44
Link to post
Share on other sites

If you are inside your network trying to connect with a local network address, then at this point you don't need to worry about port forwarding on the router.

 

It sounds like the problem is on the Shield, and you need to open up ports on that. Are you able to access the server web interface on the shield itself?

Link to post
Share on other sites

Hi Luke,

 

"Are you able to access the server web interface on the shield itself?"

If you mean am i able to see this from the emby server i loaded on to the shield then yes.

When i connect to emby on my smartphone via wifi i have no issues. It's only when i turn the wifi off and depend on my internet through my phone is when i can't connect through Emby on my phone.

 

Bdub44

Link to post
Share on other sites

Hi Luke,

 

Yes that where i get the "i could not see your service on Http port connection timeout." message when i turn off the wifi feature on my phone.

 

I'm learning on the fly.

 

Thanks for the patience.

Bdub44

Link to post
Share on other sites

Hi Luke,

 

On my phone when i open the link it gives me a ip address that i can't change because ts shaded. i can only change the port number which shows 80 i guess which is the default and i change it to 8096.

 

Bdub44

Link to post
Share on other sites

Hi Luke,

 

No i have to manually change it to 8096. Its shows 80 which i can and do change to 8096.

I can't change the IP 174.xx.x.xx.x

Now when canyouseeme.org shows the IP address Am i supposed to put that number 174.xx.x.xx.x as external into my router for port forwarding ?

 

Bdub44

Edited by bdub44
Link to post
Share on other sites

Hi Luke,

 

It shows 80 in where on the port to check section right after the Your IP part . i just add the 96 to the 80 that already there.

 

Bdub44

Link to post
Share on other sites
mastrmind11

Hi Luke,

 

No i have to manually change it to 8096. Its shows 80 which i can and do change to 8096.

I can't change the IP 174.xx.x.xx.x

Now when canyouseeme.org shows the IP address Am i supposed to put that number 174.xx.x.xx.x as external into my router for port forwarding ?

 

Bdub44

No, your router will route to your internal server.  You would put the internal ip address of your emby server into the port forward.  You would use the 174.x WAN ip to connect to your server when outside your LAN.

Link to post
Share on other sites

Hi Mastermind11,

 

Ok I have 182.xxx.xx on my Nicosia shield which is where my Emby server resides as my internal for port forwarding. I have 162. Which is on my phone with no WiFi as my external. I have this number as my external for port forwarding my WiFi router. When is go to the canyon seems.org for testing it doesnt see my service. I was telling Luke earlier that when I go to the canyon seems.org site by default is show a port number of 80. I have to manually put in the 96 part of the number. Just to add even when I try to do this test with my WiFi on different iP number it still cannot see me.

 

 

Bdub44

Edited by bdub44
Link to post
Share on other sites

Is there any other default port number thatcan be used?

 

The reason why im asking is anything with port 80 seems to be commonly blocked by residential ISP's according to canyouseeme.org?

 

Bdub44

Link to post
Share on other sites

Port 80 is not the default public port. The default public port is 8096. Yes you can use a different port by configuring this in the Advanced section of the Emby Server dashboard. Try setting the public http port value. Please let us know if this helps. Thanks !

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...