Jump to content

DLNA issue with Samsung Television(s)


dannymez

Recommended Posts

Okay this one has me a little stumped- Both of these televisions could see the regular (out of the box) DLNA that came with the NAS

 

But with Emby as DLNA server only one is working properly

 

I am not a DLNA expert so let me say that at the outset

 

The first output below is where the television is able to see the NAS as a Media Server (working)

 

I noticed it is using UPnP and doing both GET and POST between the devices

 

[/share/CACHEDEV1_DATA/.qpkg/EmbyServer/programdata/logs] # cat embyserver.txt | grep -i UN40JU7100
2019-01-17 21:48:40.030 Info Dlna: DLNA Session created for [TV] UN40JU7100 - UN40JU7000
2019-01-17 21:48:42.500 Info HttpServer: HTTP GET http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/description.xml. UserAgent: DLNADOC/1.50 SEC_HHP_[TV] UN40JU7100/1.0 UPnP/1.0
2019-01-17 21:48:42.506 Info HttpServer: HTTP GET http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/contentdirectory/contentdirectory.xml. UserAgent: DLNADOC/1.50 SEC_HHP_[TV] UN40JU7100/1.0 UPnP/1.0
2019-01-17 21:48:42.507 Info HttpServer: HTTP GET http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/connectionmanager/connectionmanager.xml. UserAgent: DLNADOC/1.50 SEC_HHP_[TV] UN40JU7100/1.0 UPnP/1.0
2019-01-17 21:48:42.516 Info HttpServer: HTTP POST http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/contentdirectory/control. UserAgent: DLNADOC/1.50 SEC_HHP_[TV] UN40JU7100/1.0 UPnP/1.0
2019-01-17 21:48:46.218 Info HttpServer: HTTP POST http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/contentdirectory/control. UserAgent: DLNADOC/1.50 SEC_HHP_[TV] UN40JU7100/1.0 UPnP/1.0
 
 
With the second television it says the session is created but I noticed it is not using UPnP (not working)- does that indicate some sort of problem?
 
I also noticed it is doing the HTTP GET but there are not any corresponding POST entries
 
2019-01-17 21:43:25.337 Info Dlna: DLNA Session created for [TV]Samsung LED65 - UN65H7100
2019-01-17 21:43:26.296 Info HttpServer: HTTP GET http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/description.xml. UserAgent: SEC_HHP_[TV]Samsung LED65/1.0 DLNADOC/1.50
2019-01-17 21:43:26.423 Info HttpServer: HTTP GET http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/contentdirectory/contentdirectory.xml. UserAgent: SEC_HHP_[TV]Samsung LED65/1.0 DLNADOC/1.50
2019-01-17 21:43:26.906 Info HttpServer: HTTP GET http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/description.xml. UserAgent: SEC_HHP_[TV]Samsung LED65/1.0 DLNADOC/1.50
2019-01-17 21:43:27.012 Info HttpServer: HTTP GET http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/contentdirectory/contentdirectory.xml. UserAgent: SEC_HHP_[TV]Samsung LED65/1.0 DLNADOC/1.50
2019-01-17 21:45:24.859 Info HttpServer: HTTP GET http://<IP REMOVED>:8096/dlna/12049253d89f4e4483f2311016fab7cb/description.xml. UserAgent: SEC_HHP_[TV]Samsung LED65/1.0 DLNADOC/1.50
Edited by dannymez
Link to post
Share on other sites

Hi, yes this is always tricky, but the repeat requests to description.xml are generally an indication that the TV didn't like something in our response. Either in the description response or the contentdirectory response. One of those two.

 

Can you get the responses from the built-in nas server to compare?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...