Jump to content
io1901

Not scaling video on Roku Express (UK spec)

Recommended Posts

jonathanp

Same problems here, with a Roku Express 3900EU in the UK 

Share this post


Link to post
Share on other sites
speechles

https://forums.roku.com/viewtopic.php?f=28&t=111274&p=648658

 

Do you have multiple HDMI ports on your TV? If you use another HDMI port for the Roku does it solve the problem?

 

Does this only happen with MPEG2 that is in SD quality? Or any Video Codec in SD quality?

 

You can also try a factory reset. Some users claim this fixes the issue.

Share this post


Link to post
Share on other sites
jonathanp

Yes, tried different TVs etc, turning Direct Play on and off etc

Share this post


Link to post
Share on other sites
speechles

Yes, tried different TVs etc, turning Direct Play on and off etc

 

While the item plays press DOWN on the Roku remote to open the On-Screen-Display (OSD). On the bottom of the OSD is a cog/gear. Navigate to that and click it. Once on the Playback Settings you can press Playback Correction. This will change the play method to the next. Direct play will change to Direct stream. Now use Playback Correction again. It will change from DIrect stream to Transcode. Once fully transcoding does this play the item correctly. It should. We do have ways to force the items to play correctly built-into-the-app as Playback Correction. This will simulate an error just like one occured on the Video Player and will immediately stop and restart the Video Player with your new play method.

 

This may be the only way for you to resolve this issue until we investigate this problem more.

 

We do have logic in the application for special treatment of both 3700 and 3900 Roku express models. But the MPEG2 codec is new so it looks like it is scale to 1080P for the video but the viewport it is leaving at the resolution of the media item. So you see 544x720 viewport of the normal full 1920x1080 video. In other words you see the video stretched beyond the viewport. This is an obvious firmware bug and I can probably get Roku to fix this since I can understand what is happening. We will have to investigate this with Roku and see how far we get. 

 

I really think too that it might be that the Roku express just doesn't like anamorphic video. That video is 576 pixels deep. It is anamorphic. Somehow the Roku express may be reporting it supports anamorphic but in reality it may not. That might be the headache we are fighting. The Roku may get confused. It is an anamorphic video in 4:3 format. So can potentially have black bars on the sides _AND_ the top/bottom. This might confuse the Roku express and it scales to the fullest resolution and gives the normal viewport. I can make sure in our capabilities that we do not allow 3700/3900 Roku express to detect anamorphic support even if found. Then see if it solves your issue...

' TODO: Remove that
globals.AddReplace("playsAnamorphic", true)

Here is our present detection for anamorphic support. It is always true. Note the comment above about removing it. Nah.. Let's improve it instead and have that thing flag false if it is a Roku express model 3700 or 3900. Here is to hoping it fixes it. Cross your fingers. :)

 

Changes are submitted:

Reference: Fix #518: [GlobalsManager] Roku express fixes

Edited by speechles

Share this post


Link to post
Share on other sites
jonathanp

Thanks for the detailed reply, and that is all correct. I will probably shelve the Express for now, as it is a bit annoing having to go through the workaround.  I have an old Roku 2 which works fine and the LG TV app is great too so I have options, thanks!

Share this post


Link to post
Share on other sites
speechles

Thanks for the detailed reply, and that is all correct. I will probably shelve the Express for now, as it is a bit annoing having to go through the workaround.  I have an old Roku 2 which works fine and the LG TV app is great too so I have options, thanks!

 

I bet it is the lack of anamorphic support on the Roku express. The #518 fix I just submitted should fix it. The change will first be pushed to Beta. We will announce when we push the next Beta so you can be ready at that time. Thanks for the report and inspiring me to find the cause and fix it. ^_^

Share this post


Link to post
Share on other sites
astuff
Posted (edited)

Any updates on this?   Hadn't tried Roku in awhile but now both the regular and beta show only upper half of picture stretched out.  If I change to lower bitrate then it works?

Edited by astuff

Share this post


Link to post
Share on other sites
Luke

@@astuff can we please go over an example? Thanks !

Share this post


Link to post
Share on other sites
speechles
Posted (edited)

Any updates on this? Hadn't tried Roku in awhile but now both the regular and beta show only upper half of picture stretched out. If I change to lower bitrate then it works?

Is this a newer Roku express 3930?

 

If so, apologies. This model does not support anamorphic display. We will update our capabilities to fix this. Thank you for reporting.

 

I am away from home at the moment. I have uploaded the fix for the team. :)

 

 

 

 

Reference: Fix #846: [CreateGlobalsTask] Disable anamorphic on latest Roku express 3930

Edited by speechles

Share this post


Link to post
Share on other sites
astuff

FYI - I have a 3900X.  Issue appears mostly with live TV recordings @1080P

Share this post


Link to post
Share on other sites
speechles
Posted (edited)

FYI - I have a 3900X.  Issue appears mostly with live TV recordings @1080P

 

What resolution is the Roku set to? Is that Roku set to 1080P?

 

The problem is anamorphic videos that do not have the anamorphic flag set. If the Emby server has not fully scanned your recordings after they complete. The video bitrate field may be missing.

 

What does the media information for that item show in the web client?

 

 

 

5cb994ae8585e_IMG_02511.jpg

 

For example on the image above the video bitrate field is <UNKNOWN> and this causes the problem. If you "Refresh metadata" of that item does it solve the issue?

 

 

 

Does your problem appear like the above where the video is stretched vertically and only the top portion appears on your TV?

Edited by speechles

Share this post


Link to post
Share on other sites
astuff

Yes, Roku auto detected 1080P.  With live TV it can't scan after complete but it happens on other videos as well. Looking around nothing shows anamorphic as yes including months old recordings and other videos.

Share this post


Link to post
Share on other sites
speechles
Posted (edited)

Yes, Roku auto detected 1080P.  With live TV it can't scan after complete but it happens on other videos as well. Looking around nothing shows anamorphic as yes including months old recordings and other videos.

 

Well that is just it. Anamorphic is 720(704)x576 resolution. It isn't 1080P. For the issue to happen with LiveTV recordings these need to be SD resolution. Because PAL/SECAM has 100 extra lines the problem usually exhibits itself with UK(AUS) LiveTV recordings. These will come through as anamorphic needing stretching.

 

This anamorphic problem will not happen on 720P or 1080P media. These do not stretch to fill.

 

 

 

If these are 1080P recordings playing incorrectly and you have your Roku express set to 1080P then this must be related to something else. We can figure out what that something else is.

 

I have a Roku express 3900X.  Can you place that video on Google Drive, Microsoft Onedrive, DropBox, or anything similar and share that with me? I should be able to then see the same problem you do and figure out the cause and cure. Thanks. 8^)

Edited by speechles

Share this post


Link to post
Share on other sites
speechles
Posted (edited)

@@astuff thank you very much. It was due to the Roku express no longer supports on device de-interlacing. Roku must want people to upgrade their Roku devices. Maybe the Roku express wasn't fast enough at deinterlace and that is why support was dropped. We now account for this in the capabilities profile and these will properly cause a transcode now. Apologies for the interruption. We will have a new Beta soon with this to test. Thanks again. ;)

Edited by speechles

Share this post


Link to post
Share on other sites
ebr

He said the video was 1080P...

Share this post


Link to post
Share on other sites
speechles
Posted (edited)

He said the video was 1080P...

 

image.png

 

He was wrong. But we know the truth. Some people get confused about resolution always having the P. It does not always.

 

side-note: ALL my interlaced content does this on my Roku express. Tested against all interlaced content in my test folder and all produces same peculiar defect.

Edited by speechles

Share this post


Link to post
Share on other sites
astuff

I thought I was being asked about the Roku to TV connection which is 1080P.

 

When I change the playback settings on the Emby screen to1080P - 50mb/s it shows only the top half of the picture.  When I change it to 1080P - 6mb/s it displays properly.

Share this post


Link to post
Share on other sites
speechles

I thought I was being asked about the Roku to TV connection which is 1080P.

 

When I change the playback settings on the Emby screen to1080P - 50mb/s it shows only the top half of the picture.  When I change it to 1080P - 6mb/s it displays properly.

 

It is all good. Maybe we should not have those P on those settings. Perhaps it should just say:

 

1080 - 50mb/s ... etc etc ?

 

If it confuses you it will confuse others. Confusion leads to situations like this.

 

@@ebr the "P" on the quality selection. Should these lose the P?

Share this post


Link to post
Share on other sites
astuff

Thanks for tracking down the issue.   

 

And sorry for the confusion.  I piggybacked on this UK thread as the symptoms matched.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...