Jump to content


Photo

Roku Does Not Show Collections


  • Please log in to reply
18 replies to this topic

#1 PuffyToesToo OFFLINE  

PuffyToesToo

    Advanced Member

  • Members
  • 421 posts
  • Local time: 02:58 PM

Posted 20 December 2018 - 04:36 PM

Neither of my Rokus show Collections, despite the fact that they show up and work fine via the web interface. Is there something I can check, as this has been going on for a while and I keep forgetting to ask. Thank you.



#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14740 posts
  • Local time: 11:58 AM
  • LocationWashington State

Posted 20 December 2018 - 04:47 PM

The Roku only has a Collections Row under Movies menu (scroll down).  I will have to check again when I get a chance, but I think the only issue is the restriction on the displayed items on that row.


  • PuffyToesToo likes this

#3 EZEd OFFLINE  

EZEd

    Advanced Member

  • Members
  • 68 posts
  • Local time: 07:58 PM

Posted 20 December 2018 - 05:30 PM

I have experienced this as well. The Collections tab/icon does show up on the main menu when first entering Emby on Roku; its just that sometimes when you enter into it, it buffers for a long time and stalls out saying "0 of 0" collections and nothing comes up.  It doesn't behave this way using the web interface - only Roku for me.  In general both collections and playlists are very slow and intermittent for me on Roku.  web interface always seems to behave normally for everything.


  • PuffyToesToo likes this

#4 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14740 posts
  • Local time: 11:58 AM
  • LocationWashington State

Posted 20 December 2018 - 05:41 PM

Will have to test Collections folder as I don't have that option enabled on my Home Screen.


  • PuffyToesToo likes this

#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131589 posts
  • Local time: 02:58 PM

Posted 20 December 2018 - 05:41 PM

The Roku only has a Collections Row under Movies menu (scroll down).  I will have to check again when I get a chance, but I think the only issue is the restriction on the displayed items on that row.

 

@speechles, does the app ignore the top level Collections entry?



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131589 posts
  • Local time: 02:58 PM

Posted 20 December 2018 - 05:42 PM

Will have to test Collections folder as I don't have that option enabled on my Home Screen.

 

Yes that would be helpful, thanks.



#7 PuffyToesToo OFFLINE  

PuffyToesToo

    Advanced Member

  • Members
  • 421 posts
  • Local time: 02:58 PM

Posted 20 December 2018 - 06:37 PM

Thank you. I am able to see movies under Collections on my friend's Emby just fine, but as EZEd says, my Collections shows, but spins for a long time and just says 0of0.  Thank you.



#8 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 4669 posts
  • Local time: 11:58 AM

Posted 20 December 2018 - 06:40 PM

d0FFTKM.jpg

 

You don't have a collections icon/tile in the My Media row at the top of the homescreen?



#9 RobWayBro OFFLINE  

RobWayBro

    Advanced Member

  • Members
  • 125 posts
  • Local time: 02:58 PM
  • LocationCentral Indiana

Posted 20 December 2018 - 08:50 PM

The collections library does show on all of the Rokus we have, not only that, but nested collections show up inline instead of at the bottom with a reference to other media (it is gone so I don't remember the exact wording) 



#10 PuffyToesToo OFFLINE  

PuffyToesToo

    Advanced Member

  • Members
  • 421 posts
  • Local time: 02:58 PM

Posted 20 December 2018 - 09:03 PM

To expand, I DO get the Collections category "Icon" on the main page when I log on, but once I enter the Collections, it spins and eventually just says 0of0. This does not happen via the web app, only Roku.



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131589 posts
  • Local time: 02:58 PM

Posted 20 December 2018 - 09:32 PM

To expand, I DO get the Collections category "Icon" on the main page when I log on, but once I enter the Collections, it spins and eventually just says 0of0. This does not happen via the web app, only Roku.

 

Can you please attach the emby server log? thanks !



#12 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14740 posts
  • Local time: 11:58 AM
  • LocationWashington State

Posted 21 December 2018 - 07:29 AM

I have no issues clicking the Collections library and displaying 270 collections.

 

3.0.131

3.6.0.80



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131589 posts
  • Local time: 02:58 PM

Posted 21 December 2018 - 12:42 PM

Thanks !



#14 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 4669 posts
  • Local time: 11:58 AM

Posted 21 December 2018 - 02:59 PM

@PuffyToesToo How did you build these collections? Are they AutoBoxSet plugin automagic? Built in the web app? Using legacy [boxset] tag on the folder?



#15 EZEd OFFLINE  

EZEd

    Advanced Member

  • Members
  • 68 posts
  • Local time: 07:58 PM

Posted 08 January 2019 - 03:57 PM

@PuffyToesToo How did you build these collections? Are they AutoBoxSet plugin automagic? Built in the web app? Using legacy [boxset] tag on the folder?

I can't speak for PuffyToes but the way mine are created is to "add to collection" from the options pull down ( ... ) of each movie that I want to be in the collection. Then either to an existing collection or create a new one if that is the objective. I haven't tried to use the feature on Roku recently since it wasn't working. I just now ignore the icon on the home page assuming that it doesn't work. I also noticed that music playlists will sometimes act similarly on Roku. If I go directly to the playlist icon on homepage it will spin for several minutes and then die saying 0 of 0 playlists found. Evidently playlists and collections are handled similarly hince why they behave similarly on Roku.

It would be useful feature if it worked. Since it doesn't work I just ignore it.

Thanks for trying anyway. And do keep up the good work. All that you guys do is appreciated even if we forget to say it sometimes.

EZEd

Sent from my SAMSUNG-SM-G900A using Tapatalk

#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131589 posts
  • Local time: 02:58 PM

Posted 09 January 2019 - 01:06 AM

The upcoming new release of Emby Server will have much faster playlist and collection performance. Thanks.



#17 PuffyToesToo OFFLINE  

PuffyToesToo

    Advanced Member

  • Members
  • 421 posts
  • Local time: 02:58 PM

Posted 17 January 2019 - 11:42 AM

I just wanted to let you know that after updating to the new release, Collections have returned to Roku and now show up. Thanks.


  • ebr likes this

#18 PuffyToesToo OFFLINE  

PuffyToesToo

    Advanced Member

  • Members
  • 421 posts
  • Local time: 02:58 PM

Posted 17 January 2019 - 11:42 AM

And also, everything is lightning fast! 


  • ebr likes this

#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131589 posts
  • Local time: 02:58 PM

Posted 17 January 2019 - 12:26 PM

Thanks for the feedback !


  • PuffyToesToo likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users