Jump to content


Photo

MPC-HC launches in the background


Best Answer fibertech , 29 December 2018 - 12:59 AM

UPDATE: I found a setting in MPC in "view>top" and I selected "always" now it is launching in front again. It was set to default. I am sorry that I wasted your time on my nonsense. Thank you guys again for your help.

Go to the full post


  • Please log in to reply
22 replies to this topic

#1 fibertech OFFLINE  

fibertech

    Member

  • Members
  • 29 posts
  • Local time: 07:48 AM
  • LocationDallas

Posted 14 December 2018 - 10:42 PM

I use MPC-HC as an external player for Emby Theater. Every time it launches it is behind the Emby screen. Is there any way to set it to launch in the front? I play a trailer, then an entrance video and finally the movie. I have to downsize Emby on every new video that is Launched. I am running this on Windows 10. Thank you for your help on this.



#2 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11486 posts
  • Local time: 05:48 AM

Posted 14 December 2018 - 10:51 PM

Theater should minimize. If you turn off cinema mode, what happens?



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131576 posts
  • Local time: 08:48 AM

Posted 15 December 2018 - 12:29 AM

Also what command line params are you using for the external player?



#4 fibertech OFFLINE  

fibertech

    Member

  • Members
  • 29 posts
  • Local time: 07:48 AM
  • LocationDallas

Posted 15 December 2018 - 02:04 AM

I will try to turn off cinema mode and see what happens tomorrow.

The commands I have are:

{path}

/play

/close

/fullscreen



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131576 posts
  • Local time: 08:48 AM

Posted 15 December 2018 - 02:07 AM

Is Theater not minimizing? 



#6 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11486 posts
  • Local time: 05:48 AM

Posted 15 December 2018 - 02:17 AM

I will try to turn off cinema mode and see what happens tomorrow.

The commands I have are:

{path}

/play

/close

/fullscreen

 

A better way to do this is configure all of that in MPC-HC, and just have {path}, in Emby Theater. In this case, all that means is just enable fullscreen in MPC-HC. 

 

5c149c65ed793_Snapshot_109.jpg

 

 

Also, you can enable this

 

5c149d82cff17_Snapshot_110.jpg


Edited by Doofus, 15 December 2018 - 02:22 AM.

  • fibertech likes this

#7 fibertech OFFLINE  

fibertech

    Member

  • Members
  • 29 posts
  • Local time: 07:48 AM
  • LocationDallas

Posted 15 December 2018 - 02:23 AM

Theater is not minimizing and pushing MPC-HC behind it.

 

I already have MPC-HC configured like your screenshots. I will remove the extra lines in Theater.

 

Thank you guys for your quick replies.



#8 fibertech OFFLINE  

fibertech

    Member

  • Members
  • 29 posts
  • Local time: 07:48 AM
  • LocationDallas

Posted 16 December 2018 - 12:52 PM

Well, it is still performing the same. ugh



#9 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11486 posts
  • Local time: 05:48 AM

Posted 16 December 2018 - 01:09 PM

To be clear, Theater doesn't change at all, and your external player opens behind it?

#10 fibertech OFFLINE  

fibertech

    Member

  • Members
  • 29 posts
  • Local time: 07:48 AM
  • LocationDallas

Posted 16 December 2018 - 01:31 PM

The external player shows in front for a millisecond and then Emby immediately  jumps in front, I the have to minimize Emby every movie that I launch.



#11 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11486 posts
  • Local time: 05:48 AM

Posted 16 December 2018 - 02:37 PM

Try this. Disable using an external player. Play a video, stop the video, and close Theater. Restart Theater, re-enable the external player. Close Theater, again. Open Theater and play a video. I'm just wondering if the command to minimize Theater wasn't enabling. 



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131576 posts
  • Local time: 08:48 AM

Posted 17 December 2018 - 01:00 PM

@Doofus are you able to reproduce? This is quite strange. I just tested mpc a month or so ago and this was all fine.



#13 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11486 posts
  • Local time: 05:48 AM

Posted 17 December 2018 - 01:10 PM

It's working for me, too. I was just thinking that something got tweaked. I'm assuming that it used to work ok, but doesn't now???

#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131576 posts
  • Local time: 08:48 AM

Posted 18 December 2018 - 12:42 PM

@fibertech did this work previously for you?



#15 fibertech OFFLINE  

fibertech

    Member

  • Members
  • 29 posts
  • Local time: 07:48 AM
  • LocationDallas

Posted 29 December 2018 - 12:22 AM

Sorry for the delayed response, life got in my way. This worked for me forever and then one day it started doing this. Today I completely uninstalled Theater and reinstalled a new download - same issue. I have not changed anything on this HTPC for months. I have no idea what has happened to cause this pain. Thanks for your help.



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131576 posts
  • Local time: 08:48 AM

Posted 29 December 2018 - 12:24 AM

Can you explain exactly what you are doing? Thanks.

#17 fibertech OFFLINE  

fibertech

    Member

  • Members
  • 29 posts
  • Local time: 07:48 AM
  • LocationDallas

Posted 29 December 2018 - 12:59 AM   Best Answer

UPDATE: I found a setting in MPC in "view>top" and I selected "always" now it is launching in front again. It was set to default. I am sorry that I wasted your time on my nonsense. Thank you guys again for your help.


  • Luke and Doofus like this

#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131576 posts
  • Local time: 08:48 AM

Posted 29 December 2018 - 01:03 AM

Thanks for the feedback !



#19 fibertech OFFLINE  

fibertech

    Member

  • Members
  • 29 posts
  • Local time: 07:48 AM
  • LocationDallas

Posted 02 January 2019 - 07:23 PM

Well. that didn't solve the issue. Today I uninstalled theater and mpc-hc, ran ccleaner (registry clean until it came back empty) then rebooted. I then ran ccleaner again to make sure no entries and reinstalled mpc-hc and sat it up. I then downloaded theater, installed it and sat it up. Theater will now play my trailer ok but when it launches my intro and movie it still jumps to the front. Is there a switch in theater that can tell it to downsize when launching an external player? Where would that be located?

Thanks again and sorry to be a pain about this.



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131576 posts
  • Local time: 08:48 AM

Posted 10 January 2019 - 05:28 PM

Are you still running into this?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users