Jump to content


Photo

Podcast plugin oddity via ROKU


  • Please log in to reply
17 replies to this topic

#1 gwbaker OFFLINE  

gwbaker

    Member

  • Members
  • 17 posts
  • Local time: 02:27 AM

Posted 14 December 2018 - 02:03 AM

Anyone else experiencing issues with the podcast plugin used via the Roku app?

 

I have a PC which I just recently rebuilt and reinstalled everything fresh (then used backup plugin to restore settings).  The Podcast plugin just quit working via my Roku Ultra.  Several sources, Twit, Tekthing, and a few others, and none work.  When I try via emby and a the web interface on a PC, it works just find.  But with roku, the podcast episodes list normally with the informaton and all.  But, when I click play, EMBY exits back to the Roku channel menu.

 

I tried uninstalling and reinstalling the podcast plugin...  No change.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 113306 posts
  • Local time: 02:27 AM

Posted 14 December 2018 - 02:13 AM

Hi, can you please attach the emby server log? Thanks !



#3 gwbaker OFFLINE  

gwbaker

    Member

  • Members
  • 17 posts
  • Local time: 02:27 AM

Posted 14 December 2018 - 04:00 AM

There are several files in the log folder and I an uncertain which you would need.  I hope this one is the correct file...

 

 

Attached Files



#4 gwbaker OFFLINE  

gwbaker

    Member

  • Members
  • 17 posts
  • Local time: 02:27 AM

Posted 14 December 2018 - 11:01 PM

Are there other log files that I need to attach??



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 113306 posts
  • Local time: 02:27 AM

Posted 15 December 2018 - 01:22 AM

Thanks. There's nothing obvious here. @speechles is testing podcasts on Roku. Can you provide some sample podcast feeds he can test with to reproduce the problem? Thanks !



#6 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 3307 posts
  • Local time: 11:27 PM

Posted 15 December 2018 - 02:17 AM

Yeah I plan on taking a major stab at the Audio issues next. I took some preliminary looks and couldn't even get the Podcasts to load. I hadn't scanned my library after adding the podcasts and maybe that was the issue. I still have it scanning my library. I will take another shot at this in the morning for sure. Apologies for not being quicker. I was busy with a huge effort that will soon be revealed. Now that all that heavy lifting is over I can get back to chasing issues. Sorry again. Watch this thread tomorrow I will be back.. :)



#7 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 3307 posts
  • Local time: 11:27 PM

Posted 15 December 2018 - 05:18 PM

@gwbaker Can you invite me to your server?

 

username: speechles

 

I cannot reproduce the issue, but having the app access your server in the same way will let me experience the same issue and see complete debug. To do this your server must be accessible from outside your network. If it is go to your "Users" tab of your dashboard. Click the + and add my username. Limit my access to just where your issue is. Emby will send me an email and let me access your server. Once I have finished fixing your issue feel free to delete my user. Let me know. Thanks.  :)



#8 gwbaker OFFLINE  

gwbaker

    Member

  • Members
  • 17 posts
  • Local time: 02:27 AM

Posted 16 December 2018 - 12:34 AM

@gwbaker Can you invite me to your server?

 

username: speechles

 

I cannot reproduce the issue, but having the app access your server in the same way will let me experience the same issue and see complete debug. To do this your server must be accessible from outside your network. If it is go to your "Users" tab of your dashboard. Click the + and add my username. Limit my access to just where your issue is. Emby will send me an email and let me access your server. Once I have finished fixing your issue feel free to delete my user. Let me know. Thanks.  :)

 

I send you a PM with log in details since I do not use Emby Connect...



#9 gwbaker OFFLINE  

gwbaker

    Member

  • Members
  • 17 posts
  • Local time: 02:27 AM

Posted 16 December 2018 - 01:52 PM

If you have tried to get into my Emby and could not....  My router suddenly quit forwarding all ports.  I have rebooted you should be able to get in.  

 

If you did not notice, I misspelled Speechles to Speechless....

 

Thanks so much for the help.



#10 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 3307 posts
  • Local time: 11:27 PM

Posted 16 December 2018 - 02:25 PM

Thanks for sharing. I see the PM you sent and thank you. I should be able to diagnose your issue on your server today in a few hours. Right now I have to do things with family. Your issue is important and it is the very next one I will be handling today. Thank you for your patience and stay tuned.



#11 gwbaker OFFLINE  

gwbaker

    Member

  • Members
  • 17 posts
  • Local time: 02:27 AM

Posted 19 December 2018 - 03:36 AM

Any update?



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 113306 posts
  • Local time: 02:27 AM

Posted 19 December 2018 - 12:12 PM

@speechles is looking into this. Thank you for your patience.

#13 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 41063 posts
  • Local time: 02:27 AM

Posted 19 December 2018 - 12:56 PM

Hi.  Can you please try the beta of the Roku app?



#14 gwbaker OFFLINE  

gwbaker

    Member

  • Members
  • 17 posts
  • Local time: 02:27 AM

Posted 19 December 2018 - 04:25 PM

The Beta version of Emby seems to have the problem corrected.

 

I tried beta several times and it worked every time.  I tried the regular Emby app and it failed every time.  So, whatever has changed seems to have fixed the problem.

 

Thanks!!!

 

Any prediction on when the updates will be applied to the non-beta version?  I would like to delete the beta channel once I know the changes are applied to the main app.  Thanks again!



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 113306 posts
  • Local time: 02:27 AM

Posted 19 December 2018 - 04:27 PM

Thanks for the feedback. Hopefully we'll be able to release soon.



#16 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 3307 posts
  • Local time: 11:27 PM

Posted 19 December 2018 - 04:39 PM

The Roku blackout precludes release until Jan 2nd 2019 onto the Roku store. Until then keep using the latest Beta and have a Happy Holiday. :)

 

Edit: Also.. Why would you delete the Beta? The Beta allows you to get bugfixes immediately and helps us test new features on a subset of users who visit the forum and can provide feedback. You can participate in this and help those on the Store build. The Store build is delayed purposely. It can be several versions behind. In fact, the Store build has to be approved by Roku which causes this delay. This means they control when we release it. We can only submit. So some version of the Beta will never be pushed to the Store.

 

As we correct bugs, add features, receive feedback we tailor accordingly. There may be several versions of the Beta released in one day. Your Roku will auto update you to these. You are much better off using the Beta app as we can immediately and with swiftness react to your issue. The Store version must wait the delay of Roku approving our submission. So think twice before you delete the Beta and instead keep it as a backup. You can have both Store and Beta on your Roku homescreen at the same time. They can exist together just fine.

 

There is a misconception that Store = Stable and Beta = Broken. The Beta is fully functional and a future edition of what the Store version will be. It is not inferior in any way. Thanks for reading. :)


Edited by speechles, 19 December 2018 - 04:53 PM.


#17 gwbaker OFFLINE  

gwbaker

    Member

  • Members
  • 17 posts
  • Local time: 02:27 AM

Posted 19 December 2018 - 05:02 PM

I definately subscribed to the Beta=Broken camp, but you have won me over to keeping and relying mainly on the beta.  

 

As much as I have grown to love Emby, I will be glad to offer whatever help I can provide.  And, even thoug I don't think I helped here....  At least I was able to point out an issue that you guys quickly resolved.  You folks ROCK!



#18 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 3307 posts
  • Local time: 11:27 PM

Posted 19 December 2018 - 05:20 PM

I definately subscribed to the Beta=Broken camp, but you have won me over to keeping and relying mainly on the beta.  

 

As much as I have grown to love Emby, I will be glad to offer whatever help I can provide.  And, even thoug I don't think I helped here....  At least I was able to point out an issue that you guys quickly resolved.  You folks ROCK!

 

That is the mindset we need to fix. We are here to help you. We aren't going to disappear if you report issues to us and get angry. People are human. They have emotions and get mad when our bugs break their happiness. I understand. We only hope that in the future you can repeat this ability to find/report bugs. The larger our pool of participants in the Beta who are active on the forums the better chance we have at finding and fixing more issues. You may not feel you helped, but we cannot find every issue ourselves and some people do not report issues they find. So some issues may exist that only people who never visit the forum experience and they abandon emby and might say bad things about it. To prevent this from eroding our userbase we must value the people who do come forward with issues. That is what I am doing here. Your input is valuable and helpful. Thanks. Please continue to trust we will react with the same speed and seriousness to every bug you find. We hate bugs as much as you and everyone else.


Edited by speechles, 19 December 2018 - 05:21 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users