Jump to content

Can't watch Recordings through ServerWMC Tile


ppickle

Recommended Posts

I was able to watch recorded shows while remote with a previous build of ServerWMC, but since the recording access has been moved to a ServerWMC tile on the home page, I have not been able to play them when remote from my home network.

 

My workaround has been to add the WMC recordings folder as another library and I'm able to stream the recordings fine that way although the shows are not organized great.

 

So my problem is this:

  • If remote from my home network
    • I can click on the ServerWMC Tile on the Emby home page and see a list of series and subsequent recordings.  Trying to play a recording results in a constant spinning wheel.  From the server logs it would appear that transcoding doesn't actually start.  ServerWMC does report the streaming of the media file as started
    • I can watch LiveTV no issue
    • I can watch RecordedTV shows if added to the library as an independent folder
  • If I'm connected to my home network then I'm able to watch recorded shows normally through the ServerWMC Tile on the Emby interface without fail on the Server Machine and other PCs, but not on a mobile device.

I don't believe it is a sharing or network config issue.  Log attached.

 

Help would be appreciated.

Log.txt

Link to post
Share on other sites

 

 

  • I can watch RecordedTV shows if added to the library as an independent folder

 

Hi, yes this is what you'll need to do for now. There is an issue with live tv recordings via server wmc. thanks.

Link to post
Share on other sites
  • 1 year later...
byusinger84

Sorry to respond to an older thread, but since it was still on page one of the sub forum I don't feel too bad. :)

 

Is this still the case or is there a better solution? It's been 14 months now so I'm not sure. I still can't get it to work directly so I assume no?

Edited by byusinger84
Link to post
Share on other sites

I would just setup the recordings folder in emby server as a regular library. It's the most practical answer right now.

Link to post
Share on other sites
  • 2 weeks later...

I think I found the issue why only HTTP URLs work for live streams. 

 

Emby is looking for the TS of the live stream in the TempSWMC folder, but it is actually in the TempRec folder. Can we get this fixed?

 

For Example, Emby is looking for the TS file here: \\192.168.1.50\Recorded TV2\TempSWMC\LiveTV_Emby^HTPC-Xeon^0_Digital Cable_502_2020_01_30_17_25_32.ts

However, it should be looking here: \\192.168.1.50\Recorded TV2\TempRec\LiveTV_Emby^HTPC-Xeon^0_Digital Cable_502_2020_01_30_17_25_32.ts

 
I tried setting the <RemuxCustomFolderUNC> to correct for this in ServerWMC, but it doesnt work. 
Link to post
Share on other sites

 

I think I found the issue why only HTTP URLs work for live streams. 

 

Emby is looking for the TS of the live stream in the TempSWMC folder, but it is actually in the TempRec folder. Can we get this fixed?

 

For Example, Emby is looking for the TS file here: \\192.168.1.50\Recorded TV2\TempSWMC\LiveTV_Emby^HTPC-Xeon^0_Digital Cable_502_2020_01_30_17_25_32.ts

However, it should be looking here: \\192.168.1.50\Recorded TV2\TempRec\LiveTV_Emby^HTPC-Xeon^0_Digital Cable_502_2020_01_30_17_25_32.ts

 
I tried setting the  to correct for this in ServerWMC, but it doesnt work. 

 

 

Can you provide a server/ffmpeg log example? Thanks.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...