Jump to content

Using XTeVe with Emby


EODCrafter
Go to solution Solved by EODCrafter,

Recommended Posts

cayars

Nothing built in that I know of.

edit: just chatted with marmei about this but he came in and answered so it's covered.

Edited by cayars
Link to post
Share on other sites

Is there any way to bind xTeVe to a particular IP/NIC? I want to install on a server with 2 NIC's. One connected to my LAN and the other to the internet. I can't change the metrics or it will affect other software. I tried ForceBindIP, but xTeVe still starts to the wrong interface.

 

I know you can change the port. Any way to change the binding?

 

xTeVe uses the network stack of the operating system and thus all IP addresses, just like your browser. In the Browser you do not set also, which IP address to be used. xTeVe displays only the first IP address, but is accessible via all. With IPv6 it is also normal that a network card has several IP addresses, it simply makes no sense to display all IP addresses. xTeVe also remembers if it is retrieved via a domain and then adapts all URLs with the domain name.

  • Like 1
Link to post
Share on other sites

xTeVe uses the network stack of the operating system and thus all IP addresses, just like your browser. In the Browser you do not set also, which IP address to be used. xTeVe displays only the first IP address, but is accessible via all. With IPv6 it is also normal that a network card has several IP addresses, it simply makes no sense to display all IP addresses. xTeVe also remembers if it is retrieved via a domain and then adapts all URLs with the domain name.

Ok, I just assumed since xTeVe diplays the wrong IP and I couldn't access it via web browser, that I needed to do something extra. I will work on it and see if I can access it.

Thanks for the quick response

Link to post
Share on other sites

DUH, shoulda remembered that. I will rethink my strategy so I don't use URL's

I always advise NEVER to use Live URL's for the m3u used in any Media software package. It could mess up configuration done for your channels, like EPG assignment, channel names, channel logo's, channel groups etc when you (or the Media software package) refreshes that URL when your IPTV provider has changed TAGS for mentioned items in m3u.

 

In DVBLink/TVMosaic/Emby, I always use local m3u's, so that m3u changes of my IPTV provider doesn't affect my setup, regarding EPG assignment, channel names, channel logo's, channel groups etc.

Link to post
Share on other sites

I realized this and am now using the URL's only in xTeVe and then using the xTeVe m3u/xml with my Emby servers and Perfect Player. Time consuming to get it all right, but worth it in the end. The constant adding and deleting of channels, mostly sporting events, from the IPTV providers was driving me bonkers. xTeve can filter out most of what I don't want to see.

  • Like 1
Link to post
Share on other sites

I always advise NEVER to use Live URL's for the m3u used in any Media software package. It could mess up configuration done for your channels, like EPG assignment, channel names, channel logo's, channel groups etc when you (or the Media software package) refreshes that URL when your IPTV provider has changed TAGS for mentioned items in m3u.

 

In DVBLink/TVMosaic/Emby, I always use local m3u's, so that m3u changes of my IPTV provider doesn't affect my setup, regarding EPG assignment, channel names, channel logo's, channel groups etc.

there are providers that have unique ID for each stream in the M3U. If an IPTV client also supports this function, the provider can change the name of the channel or all other parameters without breaking the mapping. xTeVe supports this feature.

 

https://cdn.discordapp.com/attachments/484099914574462977/525051040739885077/cuid.mp4

Link to post
Share on other sites

Seems on one computer 2 providers are clashing and mixing up ownership of channels. Same two providers in another computer running xTeVe gets all the channels correctly.

Is there some clue as how I can fix this? Is it an ordering issue? When I added in the second provider it took over some of the channels and then has a bunch of missing ones.

Using the same filters on both computers. I like xTeVe but it is really touchy sometimes.

Link to post
Share on other sites
groenator

Hi,

 

Totally different subject.

 

Since yesterday emby and xteve are acting wired, in a sense of tunner not being available when I play iptv via emby using xteve as a proxy.

 

At the beginning I thought xteve app might be down, I took the xteve m3u list and play it on my other iptv app. It worked as expected, all feeds were up.

 

The only way I found to fix the issue is by restarting the emby container.

 

Does any one having the same issue or encounter similar issues in the past?

 

It used to work without problems, until yesterday night.

Edited by groenator
Link to post
Share on other sites
cayars

Did you xTeVe update from 1.4.2 to 1.4.3 by any chance?

Is Stream buffering turned on in xTeVe by any chance?

Link to post
Share on other sites
groenator

Stream buffering is not on. I haven't checked the version, I think I'm still on the old one (1.4.1), I'll check when I get home.

 

Thanks!

Edited by groenator
Link to post
Share on other sites
EODCrafter

Did you xTeVe update from 1.4.2 to 1.4.3 by any chance?

Is Stream buffering turned on in xTeVe by any chance?

Stream Buffering will have 0 effect on M3U Tuner.

Edited by EODCrafter
Link to post
Share on other sites
groenator

I am using the latest version of xteve. Since I created the thread it seems that the issue didn't re-occur again. I will keep watching until it does. It only happens two times. 

 

Thanks for helping!

Edited by groenator
Link to post
Share on other sites
EODCrafter

good question, on plex forums I only found notes related to 1.4.0. Nothing about 1.4.3 release.

Join our Discord group...Were FREE, free...free..free..free; if that costs to much were also free....xTeVe

Edited by EODCrafter
Link to post
Share on other sites
EODCrafter

I am using the latest version of xteve. Since I created the thread it seems that the issue didn't re-occur again. I will keep watching until it does. It only happens two times. 

 

Thanks for helping!

Excuse me? you did not create this thread nor did you invent the internet :) (older people will get it ;) )

Edited by EODCrafter
Link to post
Share on other sites
cayars

Stream Buffering will have 0 effect on M3U Tuner.

EDIT: My bad.  Didn't notice the "M3U Tuner" above.  Everything said was geared to HDHomeRun emulation mode not M3U.  Also edited message a bit to get at what I was really getting at without the technical jargon.  Sorry for the misinformation posted. Not a lot of information written in one place to understand how it all works so you have to piece info together from here and there.

 

Original message:

Except for instead of of just handing back the links exactly as if you didn't use xTeVe, it instead changes the links to go through xTeVe which then runs the streams through ffmpeg xTeVe to buffer them which hasn't yet worked correctly in Plex or Emby up to 1.4.3 and why it's still experimental.  This will mean in Emby all streams are running through ffmpeg at a buffer at least 2 times.  :(

 

It actually has a great affect on how things work (or don't).

 

Also keep in mind you could have been running xTeVe in a virtual machine or very lowend or over worked computer and it didn't previously matter much as the only slow down is in managing links.  Once buffering is turned on this "machines" needs a lot more power and CPU to run ffmpeg for each stream being delivered.

Edited by cayars
Link to post
Share on other sites
EODCrafter

Except for instead of of just handing back the links exactly as if you didn't use xTeVe, it instead changes the links to go through xTeVe which then runs the streams through ffmpeg to buffer them which hasn't yet worked correctly in Plex or Emby up to 1.4.3 and why it's still experimental.  This will mean in Emby all streams are running through ffmpeg at least 2 times.  :(

 

It actually has a great affect on how things work (or don't).

 

Also keep in mind you could have been running xTeVe in a virtual machine or very lowend or over worked computer and it didn't previously matter much as the only slow down is in managing links.  Once buffering is turned on this "machines" needs a lot more power and CPU to run ffmpeg for each stream being delivered.

 

Where did you get this information? That is not true at all for a M3U Tuner.

 

Buffer only effects Streams in Emby if they are set up as HD Homerun Tuner.

 

I think your going way off topic here, This thread is about using xTeVe with Emby M3U Tuner, not HD Homerun Tuner.

 

5c98aa0d729b7_Capture.png

Edited by EODCrafter
  • Like 1
Link to post
Share on other sites

Except for instead of of just handing back the links exactly as if you didn't use xTeVe, it instead changes the links to go through xTeVe which then runs the streams through ffmpeg to buffer them which hasn't yet worked correctly in Plex or Emby up to 1.4.3 and why it's still experimental. This will mean in Emby all streams are running through ffmpeg at least 2 times. :(

 

It actually has a great affect on how things work (or don't).

 

Also keep in mind you could have been running xTeVe in a virtual machine or very lowend or over worked computer and it didn't previously matter much as the only slow down is in managing links. Once buffering is turned on this "machines" needs a lot more power and CPU to run ffmpeg for each stream being delivered.

Unfortunately, that's all wrong. If you use xTeVe as M3U tuner, xTeVe is not involved in streaming. The buffer function is only available if you are using xTeVe as the HDHomeRun tuner. The buffer also does not use FFMPEG or the like. The stream is also not transcoded. The CPU load is minimally higher, xTeVe needs about 2MB RAM for buffering.

  • Like 2
Link to post
Share on other sites
cayars

Sorry, understand how what I said is confusing (and wrong).  Typed it late.  I edited it with strike outs to make it more clear what I was getting at.  In essence the streams need to run through xTeVe if using the buffer functionality which is duplicated functionality of what Emby already does internally.

 

Emby already takes to long to tune to channels so any additional middleware that does any additional processing to the stream in any manner that isn't needed is going to slow this process down further and make diagnosing an issue even harder as there are more layers involved (not really a problem just an observation).

 

In Plex using the HDHomeRun emulation is needed more so then in Emby as Plex doesn't support M3U streams but only TS.  In Emby we can add multiple tuners which can be HDHomeRun and/or M3Us but more importantly can add multiple EPGs.  Correct me if I'm wrong but there doesn't seem to be a big difference in using xTeVe as a HDHomeRun tuner or M3U tuner with Emby except for weather Emby runs through xTeVe or just uses the streams directly.  Missing anything?

 

Admittedly, I've had to stop using xTeVe myself as the channel number changes were driving me crazy in Emby due to the automapping in Emby using channel numbers and not just station ID/names.  I've been trying to participate in discord to learn more, make suggestions and gather ideas how to incorporate it better with Emby in general.

 

marmei just yesterday spent some time in discord yesterday giving me/us additional tips on using CUID to "lock" channels numbers, etc which is a help.

 

Thank you both for the clarification which I think was very helpful!

Carlo

Link to post
Share on other sites

Join our Discord group...Were FREE, free...free..free..free; if that costs to much were also free....xTeVe

What a useless reply. Didn't see any release notes there either. And I can't stand discord. Very messy and hard to navigate system.

This is the forum I use. So where are the release notes!

Link to post
Share on other sites

What a useless reply. Didn't see any release notes there either. And I can't stand discord. Very messy and hard to navigate system.

This is the forum I use. So where are the release notes!

They're in the #release-notes section of the XTeVe Discord.

 

If you want to obtain further XTeVe support, then Discord is their support channel.

  • Like 1
Link to post
Share on other sites

Ok, see it now. Looks like latest release only affect HDHomerun users with the stream option enabled.

Man I don't like Discord. Horrible interface.

  • Like 1
Link to post
Share on other sites
EODCrafter

Ok, see it now. Looks like latest release only affect HDHomerun users with the stream option enabled.

Man I don't like Discord. Horrible interface.

Yea, Not everyone has Resources like Emby, this is all done voluntarily with no Pay. I'm curious @@dcol, how do you get IPTV to work in Emby without Sorting the channels? Do you just throw 8k channels at Emby and let it randomly sort them?

Edited by EODCrafter
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...