Jump to content
minikN

Poor performance on ReadyNAS Pro 4

Recommended Posts

minikN

Hello,

 

I've recently switch from Plex to Emby. However, I'm experience quite poor streaming perfomance. Actually at the moment, it's not possible to watch movies at all.

I own a ReadyNAS Pro 4 (Modell RNDP4000). It's quite an old model. Officially it only supports Firmware version 4.X. However years ago there was (and probably

still is) an unofficial way to update to Firmware Version 6.X. I did that about 6 years go or so and never had a problem with it. I'm currently on Version 6.9.4, which is the latest

I believe.

 

Before I go on - sorry but I have to point this out - Plex worked flawlessly in terms of streaming. I had little to no load times when watching 1080p H264 videos and it never got interupted

because of buffering. It just worked. With Emby, I can't even watch 480p videos. I tried it on my Apple TV and directly from the Web GUI. It buffers every 5 seconds for 15 seconds, then plays

5 seconds just to buffer again. I don't know whats going on.

I first thought it has something to do with transcoding, however it also happens with "direct play".

 

My NAS is directly connected to my router, so is my Apple TV / PCs.

 

Emby Version: 3.5.3.0

 

I hope someone is able to help. Thanks!

ffmpeg.txt

server.txt

Share this post


Link to post
Share on other sites
Luke

Hi, it's burning in subtitles with transcoding. Try turning them off and see if this helps. Thanks.

Share this post


Link to post
Share on other sites
minikN

Hi, it's burning in subtitles with transcoding. Try turning them off and see if this helps. Thanks.

 

Hello. Thanks for the super fast answer. That indeed help - for some movies, but not for all of them. Some of them still have the same buffering issues (see logs).

 

Subtitles are turned on by default for every media. How do I turn them off by default? And if so, what if sometimes I indeed want subtitles. Again, this didn't happen to some movies / tv-shows but rather all of them.

 

Cheers.

ffmpeg.txt

server.txt

Share this post


Link to post
Share on other sites
Luke

Try setting the subtitle preferences for your emby user. You can also try enabling vaapi hardware transcoding in server settings, if supported by your NAS.

Share this post


Link to post
Share on other sites
minikN

Try setting the subtitle preferences for your emby user. You can also try enabling vaapi hardware transcoding in server settings, if supported by your NAS.

 

Hello. If I go to my user settings and turn subtitles (or automatic subtitles I guess) off, the buffering is gone. However, as soon as I want to enable them, it becomes unwatchable. Buffers every 2 seconds for 5 seconds. I hope we can resolve this.

Share this post


Link to post
Share on other sites
Luke

Hi, web browsers do not support DVDSUB subtitles, so we have to burn them in with transcoding, and this is a costly process that might be too much for your NAS to handle. There's not much we can do to make it go faster.

 

But you do have options:

  • Use an Emby app that supports the subtitles natively without transcoding, such as Emby Theater, or our android/ios mobile app
  • Use our media convert feature to pre-convert your media to more streaming friendly formats
  • Use our subtitle download feature to download external text subtitles. External text subtitles will not require transcoding.

Please let us know if this helps. Thanks !

Share this post


Link to post
Share on other sites
minikN

Hi, web browsers do not support DVDSUB subtitles, so we have to burn them in with transcoding, and this is a costly process that might be too much for your NAS to handle. There's not much we can do to make it go faster.

 

But you do have options:

  • Use an Emby app that supports the subtitles natively without transcoding, such as Emby Theater, or our android/ios mobile app
  • Use our media convert feature to pre-convert your media to more streaming friendly formats
  • Use our subtitle download feature to download external text subtitles. External text subtitles will not require transcoding.

Please let us know if this helps. Thanks !

 

Thanks for the answer. I'm using the AppleTV app 90% of the time. However, it doesn't work well (or at all) with my subtitles.

 

 

 

  • Use our subtitle download feature to download external text subtitles. External text subtitles will not require transcoding.

 

I turned this feature on.

 

 

 

  • Use our media convert feature to pre-convert your media to more streaming friendly formats

 

Where would I find this?

 

So far I wasn't able to display a single line of subtitles. It either causes eternal buffering as said before, or it simply doesn't show anything (after turned on manually). I'm testing this on movies and TV shows. On the Apple TV app, when viewing an episode (for example), using the OSD (the one you enter with pulling down) I can't even choose any sub titles, it only offers me "Off", "Auto" and "CC". None of them work. One layer up however, in the episode menu - where you can start viewing, when choosing the "Choose subtitles and audio" (or something like that - German version here sorry) option it offers me the correct options. Unfortunately, none of them work either.

 

I've tested it with several movies / TV shows. Always same result. I'm at a point where I don't want to waste any more time with that (no offense). I'm just getting used to not having sub titles as an option.

 

However, another problem I have - which I definitely want to get fixed - are episode images. For some reason, on Apple TV, only the very next episode picture is displayed correctly - take a look:

 

5bd0c791c76eb_IMG_20181024_212417.jpg

 

Can I somewhere control how episodes are displayed? I don't want to use the backdrop, but rather the episode picture itself. Thanks.

Edited by minikN

Share this post


Link to post
Share on other sites
Luke

Right as i said, if the app doesn't support that format subtitles, then it will require transcoding on the server, which we've established your NAS can't handle. To learn  more about our media convert feature I would suggest checking out our announcement about it:

 

https://emby.media/community/index.php?/blog/1/entry-423-emby-server-34-released/

 

We are working on a custom video player for the apple tv app that can handle these subtitles natively, but it's not quite ready yet.

Share this post


Link to post
Share on other sites
Luke

Regarding the episodes, it looks like you don't have images for those episodes. Try using the image editor in the web app to download images for them.

 

Please let us know if this helps. Thanks.

Share this post


Link to post
Share on other sites
minikN

Regarding the episodes, it looks like you don't have images for those episodes. Try using the image editor in the web app to download images for them.

 

Please let us know if this helps. Thanks.

 

I do have episode images for each episode.

 

Iwq0R6H.jpg

Share this post


Link to post
Share on other sites
Luke

Ok, I think it might actually be an anti-spoiler feature. I would suggest opening a topic in our apple tv section. thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...