Jump to content

Error on Helper ..... EMBYCON Embuary


nyplayer
 Share

Recommended Posts

nyplayer

I am getting this error when I go into all Movies using embuary ..... 

10:12:21.073 T:172103787760  NOTICE: script.embuary.helper: Refreshing widgets
10:12:21.099 T:171785741552  NOTICE: CVideoPlayer::CloseFile()
10:12:21.099 T:171785741552  NOTICE: VideoPlayer: waiting for threads to exit
10:12:21.099 T:171785741552  NOTICE: VideoPlayer: finished waiting
10:12:21.099 T:171785741552  NOTICE: CVideoPlayer::CloseFile()
10:12:21.099 T:171785741552  NOTICE: VideoPlayer: waiting for threads to exit
10:12:21.099 T:171785741552  NOTICE: VideoPlayer: finished waiting
10:12:21.203 T:171850003696  NOTICE: script.embuary.helper: No inprogress movies found.
10:12:21.211 T:171850003696  NOTICE: script.embuary.helper: No inprogress episodes found.
10:12:21.833 T:171853112560  NOTICE: script.embuary.helper: No inprogress movies found.
10:12:21.841 T:171853112560  NOTICE: script.embuary.helper: No inprogress episodes found.
10:12:39.434 T:171785741552 WARNING: Trying to add unsupported control type 1
10:12:40.192 T:171851039984 WARNING: Previous line repeats 12 times.
10:12:40.192 T:171851039984  NOTICE: script.embuary.helper: No inprogress movies found.
10:12:40.836 T:171855185136   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.KeyError'>
                                            Error Contents: ('genres',)
                                            Traceback (most recent call last):
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.embuary.helper/plugin.py", line 61, in <module>
                                                Main()
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.embuary.helper/plugin.py", line 24, in __init__
                                                self.getinfos()
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.embuary.helper/plugin.py", line 45, in getinfos
                                                plugin.get_genre()
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.embuary.helper/resources/lib/plugin_content.py", line 67, in get_genre
                                                for genre in json_query["result"]["genres"]:
                                            KeyError: ('genres',)
                                            -->End of Python script error report<--
10:12:40.959 T:171796976880   ERROR: GetDirectory - Error getting plugin://script.embuary.helper/?info=getgenre&type=movie&reload=20180928171221
10:12:41.343 T:171853112560  NOTICE: script.embuary.helper: Not able to get genres
10:12:41.467 T:171796976880   ERROR: GetDirectory - Error getting library://video/emby_Favoritemovies.xml

Edited by nyplayer
Link to comment
Share on other sites

  • 1 month later...

I also have this error at boot. Embuary Helper version is 0.1.4.

 

I used that test version provided here and it works now without error message. The version is 0.0.4 which is inferior.

Link to comment
Share on other sites

sualfred

You need the latest version otherwise you will have troubles in Embuary.

Please upgrade to the recent one and provide a log.

Link to comment
Share on other sites

horstepipe

You need the latest version otherwise you will have troubles in Embuary.

Please upgrade to the recent one and provide a log.

 

this sounds like the recent version isn't provided by the Emby for Kodi (beta) repo? Is that true?

Link to comment
Share on other sites

sualfred

It is available on the repo -> 0.1.4

 

The testbranch I linked in this thread a few weeks ago is just outdated and doesn't include required features.

  • Like 1
Link to comment
Share on other sites

This is where it happens

17:29:22.084 T:3533271904   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.KeyError'>
                                            Error Contents: ('genres',)
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/script.embuary.helper/plugin.py", line 73, in <module>
                                                Main()
                                              File "/storage/.kodi/addons/script.embuary.helper/plugin.py", line 24, in __init__
                                                self.getinfos()
                                              File "/storage/.kodi/addons/script.embuary.helper/plugin.py", line 57, in getinfos
                                                plugin.get_mediabygenre()
                                              File "/storage/.kodi/addons/script.embuary.helper/resources/lib/plugin_content.py", line 219, in get_mediabygenre
                                                for item in movies_genres_query["result"]["genres"]:
                                            KeyError: ('genres',)
                                            -->End of Python script error report<--

Here is the log:

01_KODI.log

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...